summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/a52dec
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/a52dec')
-rw-r--r--abs/core-testing/a52dec/PKGBUILD26
-rw-r--r--abs/core-testing/a52dec/a52dec-0.7.4-build.patch27
2 files changed, 0 insertions, 53 deletions
diff --git a/abs/core-testing/a52dec/PKGBUILD b/abs/core-testing/a52dec/PKGBUILD
deleted file mode 100644
index cba41ae..0000000
--- a/abs/core-testing/a52dec/PKGBUILD
+++ /dev/null
@@ -1,26 +0,0 @@
-# $Id: PKGBUILD 5601 2008-07-18 22:06:17Z jgc $
-# Maintainer: Thomas Baechler <thomas@archlinux.org>
-# contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
-
-pkgname=a52dec
-pkgver=0.7.4
-pkgrel=4
-pkgdesc="liba52 is a free library for decoding ATSC A/52 streams."
-arch=('i686' 'x86_64')
-license=('GPL2')
-depends=('glibc')
-options=(!libtool)
-source=(http://liba52.sourceforge.net/files/${pkgname}-${pkgver}.tar.gz
- a52dec-0.7.4-build.patch)
-url="http://liba52.sourceforge.net/"
-md5sums=('caa9f5bc44232dc8aeea773fea56be80' 'fa16f224a7dceb7613824380abef0052')
-
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- patch -Np1 -i ${srcdir}/a52dec-0.7.4-build.patch || return 1
- ./bootstrap || return 1
- ./configure --prefix=/usr --enable-shared || return 1
- make || return 1
- make DESTDIR=${pkgdir} install || return 1
- install -m644 liba52/a52_internal.h $startdir/pkg/usr/include/a52dec/ || return 1
-}
diff --git a/abs/core-testing/a52dec/a52dec-0.7.4-build.patch b/abs/core-testing/a52dec/a52dec-0.7.4-build.patch
deleted file mode 100644
index f3a29f3..0000000
--- a/abs/core-testing/a52dec/a52dec-0.7.4-build.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -Naur a52dec-0.7.4.orig/liba52/Makefile.am a52dec-0.7.4/liba52/Makefile.am
---- a52dec-0.7.4.orig/liba52/Makefile.am 2002-01-27 20:36:48.000000000 -0800
-+++ a52dec-0.7.4/liba52/Makefile.am 2004-11-05 01:10:21.317401872 -0800
-@@ -1,4 +1,3 @@
--CFLAGS = @CFLAGS@ @LIBA52_CFLAGS@
-
- lib_LTLIBRARIES = liba52.la
-
-diff -Naur a52dec-0.7.4.orig/liba52/configure.incl a52dec-0.7.4/liba52/configure.incl
---- a52dec-0.7.4.orig/liba52/configure.incl 2002-01-27 20:36:48.000000000 -0800
-+++ a52dec-0.7.4/liba52/configure.incl 2004-11-05 01:11:38.172672216 -0800
-@@ -2,7 +2,6 @@
- AC_SUBST([LIBA52_LIBS])
-
- dnl avoid -fPIC when possible
--LIBA52_CFLAGS="$LIBA52_CFLAGS -prefer-non-pic"
-
- AC_ARG_ENABLE([double],
- [ --enable-double use double-precision samples])
-diff -Naur a52dec-0.7.4.orig/src/Makefile.am a52dec-0.7.4/src/Makefile.am
---- a52dec-0.7.4.orig/src/Makefile.am 2002-06-22 18:51:57.000000000 -0700
-+++ a52dec-0.7.4/src/Makefile.am 2004-11-05 01:10:21.320401375 -0800
-@@ -1,4 +1,3 @@
--CFLAGS = @A52DEC_CFLAGS@
-
- bin_PROGRAMS = a52dec extract_a52
- a52dec_SOURCES = a52dec.c getopt.c gettimeofday.c