summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/alsa-utils
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/alsa-utils')
-rw-r--r--abs/core-testing/alsa-utils/PKGBUILD31
-rwxr-xr-xabs/core-testing/alsa-utils/alsa56
-rw-r--r--abs/core-testing/alsa-utils/alsa.conf.d15
-rw-r--r--abs/core-testing/alsa-utils/alsaconf.patch32
4 files changed, 0 insertions, 134 deletions
diff --git a/abs/core-testing/alsa-utils/PKGBUILD b/abs/core-testing/alsa-utils/PKGBUILD
deleted file mode 100644
index 2f6e163..0000000
--- a/abs/core-testing/alsa-utils/PKGBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# $Id: PKGBUILD 79271 2010-05-02 14:42:00Z tpowa $
-# Maintainer: judd <jvinet@zeroflux.org>
-pkgname=alsa-utils
-pkgver=1.0.23
-pkgrel=2
-pkgdesc="An alternative implementation of Linux sound support"
-arch=('i686' 'x86_64')
-url="http://www.alsa-project.org"
-#can not use >=$pkgver due to use of letters in alsa-lib update versioning
-depends=("alsa-lib>1.0.22.99" 'dialog' 'pciutils' 'ncurses')
-makedepends=('xmlto' 'docbook-xsl')
-license=('GPL')
-source=(ftp://ftp.alsa-project.org/pub/utils/$pkgname-${pkgver}.tar.bz2
- alsa
- alsaconf.patch
- alsa.conf.d)
-backup=(etc/conf.d/alsa)
-
-build() {
- cd $startdir/src/$pkgname-${pkgver}
- patch -Np1 -i ../alsaconf.patch || return 1
- ./configure --prefix=/usr
- make || return 1
- make DESTDIR=$startdir/pkg install
- install -D -m755 ../alsa $startdir/pkg/etc/rc.d/alsa
- install -D -m644 ../alsa.conf.d $startdir/pkg/etc/conf.d/alsa
-}
-md5sums=('cb0cf46029ac9549cf3a31bff6a4f4e1'
- '3ef812cae83053d01cd560284efad71f'
- '62ebef77d5617d0036012cc541dcf23c'
- '93089f0d8872078939f76dd2acaebc2b')
diff --git a/abs/core-testing/alsa-utils/alsa b/abs/core-testing/alsa-utils/alsa
deleted file mode 100755
index 08f76af..0000000
--- a/abs/core-testing/alsa-utils/alsa
+++ /dev/null
@@ -1,56 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/conf.d/alsa
-. /etc/rc.d/functions
-
-case "$1" in
- start)
- stat_busy "Restoring ALSA Levels"
- /usr/sbin/alsactl $ALSA_ARGS restore
- if [ $? -gt 0 ]; then
- stat_fail
- else
- stat_done
- add_daemon alsa
- fi
-
- POWERSAVE=${POWERSAVE:-0}
- if [ -e /sys/module/snd_ac97_codec/parameters/power_save \
- -a $POWERSAVE -ne 0 ]; then
- echo $POWERSAVE > /sys/module/snd_ac97_codec/parameters/power_save
- [ -c /dev/dsp ] && echo 1 > /dev/dsp
- fi
-
- if [ -e /sys/module/snd_hda_intel/parameters/power_save \
- -a $POWERSAVE -ne 0 ]; then
- echo $POWERSAVE > /sys/module/snd_hda_intel/parameters/power_save
- [ -c /dev/dsp ] && echo 1 > /dev/dsp
- fi
- ;;
- stop)
- SAVE_VOLUME=${SAVE_VOLUME:-yes}
- if [ "$SAVE_VOLUME" == "yes" ]; then
- stat_busy "Saving ALSA Levels"
- /usr/sbin/alsactl $ALSA_ARGS store
- else
- stat_busy "Stopping ALSA"
- fi
- if [ "$MUTE_VOLUME" == "yes" ]; then
- /usr/bin/amixer -q set Master 0 mute
- fi
- if [ $? -gt 0 ]; then
- stat_fail
- else
- stat_done
- rm_daemon alsa
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
diff --git a/abs/core-testing/alsa-utils/alsa.conf.d b/abs/core-testing/alsa-utils/alsa.conf.d
deleted file mode 100644
index 2c4a92e..0000000
--- a/abs/core-testing/alsa-utils/alsa.conf.d
+++ /dev/null
@@ -1,15 +0,0 @@
-# Arguments for alsactl
-# example: ALSA_ARGS="--file /var/run/alsa-state"
-ALSA_ARGS=""
-
-# Enables powersaving mode for AC97 and hda_intel audio chips.
-# Set to 1 to enable powersaving.
-# Set to 0 to disable powersaving (default).
-POWERSAVE=0
-
-# Whether to save volume levels when stopped ("yes" or "no").
-SAVE_VOLUME="yes"
-
-# Whether to mute the master volume when stopped ("yes" or "no").
-# Useful for bad audio cards which make a noise on system poweroff.
-MUTE_VOLUME="no"
diff --git a/abs/core-testing/alsa-utils/alsaconf.patch b/abs/core-testing/alsa-utils/alsaconf.patch
deleted file mode 100644
index ec79fe9..0000000
--- a/abs/core-testing/alsa-utils/alsaconf.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -Naur alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in alsa-utils-1.0.9a/alsaconf/alsaconf.in
---- alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in 2005-03-24 00:24:52.000000000 -0800
-+++ alsa-utils-1.0.9a/alsaconf/alsaconf.in 2005-07-18 09:25:02.000000000 -0700
-@@ -58,6 +58,8 @@
- distribution="redhat"
- elif test -f /etc/fedora-release && grep -q "Fedora" /etc/fedora-release; then
- distribution="fedora"
-+elif test -f /etc/arch-release && grep -q "Arch" /etc/arch-release; then
-+ distribution="arch"
- elif [ -f /etc/slackware-version -o -f /etc/slamd64-version ]; then
- distribution="slackware"
- else
-@@ -382,6 +384,8 @@
- rcalsasound=/etc/rc.d/init.d/alsasound
- elif [ -x /etc/init.d/alsa ]; then
- rcalsasound=/etc/init.d/alsa
-+elif [ -x /etc/rc.d/alsa ]; then
-+ rcalsasound=/etc/rc.d/alsa
- else
- rcalsasound=rcalsasound
- fi
---- alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in 2010-01-03 19:44:08.000000000 +0100
-+++ alsa-utils-1.0.9a-orig/alsaconf/alsaconf.in 2010-01-03 19:44:08.000000000 +0100
-@@ -315,7 +315,7 @@
- 3.[789]*)
- ;;
- *)
-- cfgout="/etc/modprobe.d/sound"
-+ cfgout="/etc/modprobe.d/sound.conf"
- cfgoldout=""
- ;;
- esac