summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/aufs-utils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/aufs-utils/PKGBUILD')
-rw-r--r--abs/core-testing/aufs-utils/PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/abs/core-testing/aufs-utils/PKGBUILD b/abs/core-testing/aufs-utils/PKGBUILD
index b845405..ee0932c 100644
--- a/abs/core-testing/aufs-utils/PKGBUILD
+++ b/abs/core-testing/aufs-utils/PKGBUILD
@@ -1,21 +1,24 @@
-# $Id: PKGBUILD 2265 2008-05-30 12:12:12Z paul $
+# $Id: PKGBUILD 15034 2008-10-12 11:58:48Z thomas $
# Contributor: Paul Mattal <paul@mattal.com>
# Maintainer: Paul Mattal <pjmattal@elys.com>
pkgname=aufs-utils
-pkgver=20080527
+pkgver=20081012
pkgrel=1
-_kernver='2.6.26-ARCH'
+_kernver='2.6.27-ARCH'
pkgdesc="Another Unionfs Implementation that supports NFS branches"
arch=('i686' 'x86_64')
url="http://aufs.sourceforge.net/"
license=('GPL2')
depends=('glibc')
source=(ftp://ftp.archlinux.org/other/aufs/aufs-$pkgver.tar.gz)
-md5sums=('4378221aa5763d1f4408a0bbb0e80f0a')
+md5sums=('fb5eaa69b2c7e6e521cb9a9cae9ac23f')
build() {
cd $startdir/src/aufs || return 1
+ # Fix TMPFS_MAGIC error
+ sed 's|-le 26|-le 27|g' -i fs/aufs25/Makefile || return 1
+
# configure for NFS by:
# 1) configure local.mk to use FILP and LHASH
sed -i 's|CONFIG_AUFS_PUT_FILP_PATCH =|CONFIG_AUFS_PUT_FILP_PATCH = y|' \