summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/bash
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/bash')
-rw-r--r--abs/core-testing/bash/PKGBUILD69
-rw-r--r--abs/core-testing/bash/bash.install21
-rw-r--r--abs/core-testing/bash/bashrc6
-rw-r--r--abs/core-testing/bash/enable-system-config-files.patch15
-rw-r--r--abs/core-testing/bash/profile.bash11
-rw-r--r--abs/core-testing/bash/system.bashrc31
6 files changed, 0 insertions, 153 deletions
diff --git a/abs/core-testing/bash/PKGBUILD b/abs/core-testing/bash/PKGBUILD
deleted file mode 100644
index 96c24a1..0000000
--- a/abs/core-testing/bash/PKGBUILD
+++ /dev/null
@@ -1,69 +0,0 @@
-# $Id: PKGBUILD 82719 2010-06-16 04:44:35Z allan $
-# Maintainer: Aaron Griffin <aaron@archlinux.org>
-
-pkgname=bash
-_patchlevel=007 #prepare for some patches
-pkgver=4.1.$_patchlevel
-pkgrel=1
-pkgdesc="The GNU Bourne Again shell"
-arch=('i686' 'x86_64')
-license=('GPL')
-url="http://www.gnu.org/software/bash/bash.html"
-groups=('base')
-backup=(etc/profile.bash etc/skel/.bashrc etc/skel/.bash_profile)
-depends=('readline>=6.1' 'glibc')
-makedepends=(gzip)
-provides=('sh')
-install=bash.install
-source=(http://ftp.gnu.org/gnu/bash/bash-4.1.tar.gz
- profile.bash
- bashrc
- enable-system-config-files.patch
- system.bashrc)
-if [ $_patchlevel -gt 000 ]; then
- for (( p=1; p<=$_patchlevel; p++ )); do
- source=(${source[@]} http://ftp.gnu.org/gnu/bash/bash-4.1-patches/bash41-$(printf "%03d" $p))
- done
-fi
-
-build() {
- cd ${srcdir}/${pkgname}-4.1
- for p in ../bash41-*; do
- [ -e "$p" ] || continue
- msg "applying patch ${p}"
- patch -Np0 -i ${p} || return 1
- done
-
- patch -Np0 -i $srcdir/enable-system-config-files.patch || return 1
-
- ./configure --prefix=/usr --with-curses --enable-readline \
- --without-bash-malloc --with-installed-readline \
- --bindir=/bin --mandir=/usr/share/man --infodir=/usr/share/info
- make || return 1
- make DESTDIR=${pkgdir} install
-
- install -D -m644 ${srcdir}/profile.bash ${pkgdir}/etc/profile.bash || return 1
- install -D -m644 ${srcdir}/system.bashrc ${pkgdir}/etc/bash.bashrc || return 1
-
- # for now, bash is our default /bin/sh
- cd ${pkgdir}/bin
- ln -s bash sh
-
- mkdir -p ${pkgdir}/etc/skel/
- install -D -m644 ${srcdir}/bashrc ${pkgdir}/etc/skel/.bashrc
- echo ". \$HOME/.bashrc" >${pkgdir}/etc/skel/.bash_profile
-}
-
-md5sums=('9800d8724815fd84994d9be65ab5e7b8'
- '17f20ec69535a2f50f2112a8c700630d'
- '3d2837e84645eac9bde399b58014bafa'
- '51725defa4c2dec49c1bc15883e0bee2'
- '196697769f1667a8a1aed608811129c6'
- '582dea5671b557f783e18629c2f77b68'
- '118d465095d4a4706eb1d34696a2666a'
- '120f7cf039a40d35fe375e59d6f17adc'
- '336ee037fc2cc1e2350b05097fbdc87c'
- '9471e666797f0b03eb2175ed752a9550'
- 'fb80ccd58cb1e34940f3adf4ce6e4a1e'
- '192a8b161d419a1d0d211169f1d1046e')
-
diff --git a/abs/core-testing/bash/bash.install b/abs/core-testing/bash/bash.install
deleted file mode 100644
index 5c3c435..0000000
--- a/abs/core-testing/bash/bash.install
+++ /dev/null
@@ -1,21 +0,0 @@
-info_dir=/usr/share/info
-info_files=(bash.info)
-
-post_install() {
- [ -x usr/bin/install-info ] || return 0
- for f in ${info_files[@]}; do
- usr/bin/install-info ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- [ -x usr/bin/install-info ] || return 0
- for f in ${info_files[@]}; do
- usr/bin/install-info --delete ${info_dir}/$f.gz ${info_dir}/dir 2> /dev/null
- done
-}
-# vim:set ts=2 sw=2 et:
diff --git a/abs/core-testing/bash/bashrc b/abs/core-testing/bash/bashrc
deleted file mode 100644
index 0963431..0000000
--- a/abs/core-testing/bash/bashrc
+++ /dev/null
@@ -1,6 +0,0 @@
-
-# Check for an interactive session
-[ -z "$PS1" ] && return
-
-alias ls='ls --color=auto'
-PS1='[\u@\h \W]\$ '
diff --git a/abs/core-testing/bash/enable-system-config-files.patch b/abs/core-testing/bash/enable-system-config-files.patch
deleted file mode 100644
index 5295355..0000000
--- a/abs/core-testing/bash/enable-system-config-files.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/bash-4.0/config-top.h 2009-01-04 11:32:23.000000000 -0800
-+++ config-top.h 2009-08-25 08:41:08.000000000 -0700
-@@ -75,10 +75,10 @@
- #define KSH_COMPATIBLE_SELECT
-
- /* System-wide .bashrc file for interactive shells. */
--/* #define SYS_BASHRC "/etc/bash.bashrc" */
-+#define SYS_BASHRC "/etc/bash.bashrc"
-
- /* System-wide .bash_logout for login shells. */
--/* #define SYS_BASH_LOGOUT "/etc/bash.bash_logout" */
-+#define SYS_BASH_LOGOUT "/etc/bash.bash_logout"
-
- /* Define this to make non-interactive shells begun with argv[0][0] == '-'
- run the startup files when not in posix mode. */
diff --git a/abs/core-testing/bash/profile.bash b/abs/core-testing/bash/profile.bash
deleted file mode 100644
index d28f069..0000000
--- a/abs/core-testing/bash/profile.bash
+++ /dev/null
@@ -1,11 +0,0 @@
-#
-# /etc/profile.bash
-# Global settings for bash shells
-#
-
-#In the future we may want to add more ulimit entries here,
-# in the offchance that /etc/security/limits.conf is skipped
-ulimit -Sc 0 #Don't create core files
-
-# Source our global bashrc file, to remove duplication of effort
-[ -r /etc/bash.bashrc ] && . /etc/bash.bashrc
diff --git a/abs/core-testing/bash/system.bashrc b/abs/core-testing/bash/system.bashrc
deleted file mode 100644
index 5430d6b..0000000
--- a/abs/core-testing/bash/system.bashrc
+++ /dev/null
@@ -1,31 +0,0 @@
-#
-# /etc/bash.bashrc
-#
-# This file is the systemwide bashrc file. While most of the
-# environment is preserved when running an interactive shell
-# the PS[1-4] variables, aliases and functions are reset.
-#
-# When running a non-login shell, apply the following settings:
-# - Prompt defaults (PS[1-4], PROMPT_COMMAND)
-# - bash_completion if it exists
-# - source /etc/bash.bashrc.local
-
-PS1='[\u@\h \W]\$ '
-PS2='> '
-PS3='> '
-PS4='+ '
-
-export PS1 PS2 PS3 PS4
-
-if test "$TERM" = "xterm" -o \
- "$TERM" = "xterm-color" -o \
- "$TERM" = "xterm-256color" -o \
- "$TERM" = "rxvt" -o \
- "$TERM" = "rxvt-unicode" -o \
- "$TERM" = "xterm-xfree86"; then
- PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\007"'
- export PROMPT_COMMAND
-fi
-
-[ -r /etc/bash_completion ] && . /etc/bash_completion
-[ -r /etc/bash.bashrc.local ] && . /etc/bash.bashrc.local