summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/dialog
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/dialog')
-rw-r--r--abs/core-testing/dialog/PKGBUILD21
-rw-r--r--abs/core-testing/dialog/timeout.patch11
2 files changed, 0 insertions, 32 deletions
diff --git a/abs/core-testing/dialog/PKGBUILD b/abs/core-testing/dialog/PKGBUILD
deleted file mode 100644
index 0299f6d..0000000
--- a/abs/core-testing/dialog/PKGBUILD
+++ /dev/null
@@ -1,21 +0,0 @@
-# $Id: PKGBUILD 1369 2008-05-06 16:13:12Z andyrtr $
-# Maintainer: dorphell <dorphell@archlinux.org>
-pkgname=dialog
-pkgver=1.1_20080316
-_pkgver=1.1-20080316
-pkgrel=12
-pkgdesc="A tool to display dialog boxes from shell scripts"
-arch=('i686' 'x86_64')
-license=('GPL')
-groups=('base')
-depends=('ncurses>=5.6-6')
-url="http://packages.debian.org/dialog"
-source=(ftp://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_$_pkgver.orig.tar.gz)
-md5sums=('3d262cbc41e4db23251e7be924c4a28b')
-
-build() {
- cd $startdir/src/$pkgname-$_pkgver
- ./configure --prefix=/usr --with-ncursesw --mandir=/usr/share/man
- make || return 1
- make DESTDIR=$startdir/pkg install
-}
diff --git a/abs/core-testing/dialog/timeout.patch b/abs/core-testing/dialog/timeout.patch
deleted file mode 100644
index 257f275..0000000
--- a/abs/core-testing/dialog/timeout.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- dialog-1.1-20070514/ui_getc.c 2007-05-15 00:24:00.000000000 +0200
-+++ dialog-1.1-20070514_fixed/ui_getc.c 2007-05-29 20:20:27.000000000 +0200
-@@ -252,6 +252,8 @@
- ch = wgetch(win);
- /* if error from resizing, wait and try again */
- if (ch == ERR) {
-+ current = time((time_t *) 0);
-+ if (interval > 0 && current >= expired) dlg_exiterr("timeout");
- napms(50);
- continue;
- }