summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/esound
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/esound')
-rw-r--r--abs/core-testing/esound/PKGBUILD34
-rwxr-xr-xabs/core-testing/esound/esd37
-rw-r--r--abs/core-testing/esound/esd-0.2.38-alsa-drain.patch11
3 files changed, 0 insertions, 82 deletions
diff --git a/abs/core-testing/esound/PKGBUILD b/abs/core-testing/esound/PKGBUILD
deleted file mode 100644
index b157aab..0000000
--- a/abs/core-testing/esound/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# $Id: PKGBUILD 19662 2008-11-28 20:35:54Z jgc $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-pkgname=esound
-pkgver=0.2.41
-pkgrel=1
-pkgdesc="Enlightened Sound Daemon"
-arch=(i686 x86_64)
-license=('LGPL')
-depends=('audiofile' 'tcp_wrappers' 'alsa-lib>=1.0.18')
-url="http://www.tux.org/~ricdude/EsounD.html"
-provides=("esd=${pkgver}")
-replaces=('esd')
-conflicts=('esd')
-backup=('etc/esd.conf')
-options=('!libtool')
-source=(http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/0.2/${pkgname}-${pkgver}.tar.bz2
- esd-0.2.38-alsa-drain.patch
- esd)
-md5sums=('8d9aad3d94d15e0d59ba9dc0ea990c6c'
- '3de93efcd1bc196a3585e6aef50eac48'
- 'a4c76e7c7f75b201ea7ab6fb15b47472')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/esd-0.2.38-alsa-drain.patch" || return 1
- ./configure --prefix=/usr --sysconfdir=/etc \
- --localstatedir=/var --disable-static \
- --with-audiofile --with-libwrap \
- --enable-alsa --disable-artstest || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
- install -m755 -d "${pkgdir}/etc/rc.d"
- install -m755 "${srcdir}/esd" "${pkgdir}/etc/rc.d/esd" || return 1
-}
diff --git a/abs/core-testing/esound/esd b/abs/core-testing/esound/esd
deleted file mode 100755
index d90ef55..0000000
--- a/abs/core-testing/esound/esd
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/bin/esd`
-case "$1" in
- start)
- stat_busy "Starting Esound Daemon"
- if [ -z "$PID" ]; then
- /usr/bin/esd -nobeeps &
- fi
- if [ ! -z "$PID" -o $? -gt 0 ]; then
- stat_fail
- else
- add_daemon esd
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping Esound Daemon"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon esd
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
diff --git a/abs/core-testing/esound/esd-0.2.38-alsa-drain.patch b/abs/core-testing/esound/esd-0.2.38-alsa-drain.patch
deleted file mode 100644
index f2fb716..0000000
--- a/abs/core-testing/esound/esd-0.2.38-alsa-drain.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- esound-0.2.38/audio_alsa09.c.old 2007-06-11 12:22:24.000000000 +0200
-+++ esound-0.2.38/audio_alsa09.c 2007-06-11 12:22:49.000000000 +0200
-@@ -486,7 +486,7 @@ void esd_audio_flush(void)
- }
-
- if (alsa_playback_handle != NULL)
-- snd_pcm_drain( alsa_playback_handle );
-+ snd_pcm_drop( alsa_playback_handle );
-
- if (alsadbg)
- print_state();