summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/fbsplash
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/fbsplash')
-rw-r--r--abs/core-testing/fbsplash/PKGBUILD71
-rw-r--r--abs/core-testing/fbsplash/fbcondecor.conf6
-rw-r--r--abs/core-testing/fbsplash/fbcondecor.daemon55
-rw-r--r--abs/core-testing/fbsplash/fbsplash-basic.sh201
-rw-r--r--abs/core-testing/fbsplash/fbsplash.git.patch166
-rw-r--r--abs/core-testing/fbsplash/fbsplash.initcpio_hook102
-rw-r--r--abs/core-testing/fbsplash/fbsplash.initcpio_install114
-rw-r--r--abs/core-testing/fbsplash/fbsplash.install27
-rw-r--r--abs/core-testing/fbsplash/splash.conf63
9 files changed, 0 insertions, 805 deletions
diff --git a/abs/core-testing/fbsplash/PKGBUILD b/abs/core-testing/fbsplash/PKGBUILD
deleted file mode 100644
index dcec71a..0000000
--- a/abs/core-testing/fbsplash/PKGBUILD
+++ /dev/null
@@ -1,71 +0,0 @@
-# Maintainer: Heiko Baums <heiko@baums-on-web.de>
-# Contributor: Kurt J. Bosch <kjb-temp-2009 at alpenjodel.de>
-
-pkgname=fbsplash
-pkgver=1.5.4.3
-pkgrel=33
-pkgdesc="A userspace implementation of a splash screen for Linux (formerly known as gensplash)"
-arch=('i686' 'x86_64')
-url="http://fbsplash.berlios.de"
-license=('GPL')
-depends=('miscsplashutils' 'freetype2' 'libjpeg' 'libpng' 'libmng' 'lcms' 'gpm' 'linhes-splash')
-optdepends=('kernel26-fbcondecor: enable console background images'
- 'fbsplash-extras: additional functionality like daemon icons'
- 'uswsusp-fbsplash: suspend to disk with fbsplash'
- 'python: convert themes from splashy to fbsplash')
-conflicts=('fbsplash-scripts' 'initscripts-extras-fbsplash')
-options=('!makeflags')
-backup=('etc/conf.d/fbcondecor' 'etc/conf.d/splash')
-install=fbsplash.install
-source=(http://dev.gentoo.org/~spock/projects/gensplash/archive/splashutils-${pkgver}.tar.bz2
- fbsplash.git.patch
- splash.conf
- fbsplash-basic.sh
- fbsplash.initcpio_install
- fbsplash.initcpio_hook
- fbcondecor.daemon
- fbcondecor.conf)
-
-build() {
- cd ${srcdir}/splashutils-${pkgver}
-
- # patch for building splashutils with glibc and dynamical linking
- patch -Np0 -i ${srcdir}/fbsplash.git.patch || return 1
- autoreconf
-
- # fix fbcondecor_ctl splash type
- sed -e 's,fbsplash_lib_init(fbspl_bootup),fbsplash_lib_init(fbspl_undef),' -i src/fbcon_decor_ctl.c
-
- ./configure --prefix=/usr --sysconfdir=/etc --without-klibc --enable-fbcondecor --with-gpm --with-mng --with-png --with-ttf --with-ttf-kernel || return 1
- make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
-
- cd ${pkgdir}
-
- # fix duplicate slashes to get splash_cache_cleanup grep to work
- sed -r -e 's,^(export spl_.*="/)/+,\1,' -i sbin/splash-functions.sh
-
- # fix the path to splash_util
- sed -r -e 's,^(export spl_util=)\"/bin/,\1"/sbin/,' -i sbin/splash-functions.sh
-
- # provide the mountpoint needed by splash-functions.sh
- mkdir -p lib/splash/{cache,tmp}
-
- # Install fbsplash scripts and config file
- install -D -m644 ${srcdir}/splash.conf etc/conf.d/splash
- install -D -m644 ${srcdir}/fbsplash-basic.sh etc/rc.d/functions.d/fbsplash-basic.sh
- install -D -m644 ${srcdir}/fbsplash.initcpio_install lib/initcpio/install/fbsplash
- install -D -m644 ${srcdir}/fbsplash.initcpio_hook lib/initcpio/hooks/fbsplash
-
- # Install fbcodecor script and config file
- install -D -m644 ${srcdir}/fbcondecor.conf etc/conf.d/fbcondecor
- install -D -m755 ${srcdir}/fbcondecor.daemon etc/rc.d/fbcondecor
-}
-md5sums=('c722cd4148817b9c50381d9bdc1ea6ef'
- '3a338c60ed0710c8b7e3e08929db521a'
- 'a8f40c99a32d20d505aa24fbbd703008'
- 'e69753dac753b8ba4e2e29ef5a9c46ca'
- 'e29b3db6ee059b9950febe976a0f2881'
- 'ac2351bc918b101bb9249ce8940722be'
- '715926469d05eecd345c052e6248ca32'
- 'b3db9d4fd902b62ac9e38589677e2d16')
diff --git a/abs/core-testing/fbsplash/fbcondecor.conf b/abs/core-testing/fbsplash/fbcondecor.conf
deleted file mode 100644
index 18db844..0000000
--- a/abs/core-testing/fbsplash/fbcondecor.conf
+++ /dev/null
@@ -1,6 +0,0 @@
-
-# /etc/conf.d/fbcondecor
-#
-
-## Virtual terminals to load with fbcondecor backgrounds
-SPLASH_TTYS="1 2 3 4 5 6"
diff --git a/abs/core-testing/fbsplash/fbcondecor.daemon b/abs/core-testing/fbsplash/fbcondecor.daemon
deleted file mode 100644
index 4d78ea4..0000000
--- a/abs/core-testing/fbsplash/fbcondecor.daemon
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/bash
-
-# /etc/rc.d/fbcondecor
-
-# Set FbConDecor backgrounds
-#
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-. /etc/conf.d/fbcondecor
-. /sbin/splash-functions.sh
-
-splash_setup force
-
-retval=0
-[ -z "${SPLASH_TTYS%% }" ] && retval=1
-case "$1"
-in start )
- if [ "${SPLASH_MODE_REQ}" != "off" ]; then
- stat_busy "Setting FBconDecor console images"
- for tty in ${SPLASH_TTYS}; do
- # avoid blinking on boot
- [[ "$( fbcondecor_ctl --tty=${tty} -c getstate )" == *\ on ]] && continue
- fbcondecor_set_theme ${SPLASH_THEME} ${tty} || retval=1
- done
- if [ $retval = 0 ]; then
- stat_done
- else
- stat_fail
- fi
- fi
-;; stop )
- stat_busy "Disabling FBconDecor console images"
- for tty in ${SPLASH_TTYS}; do
- # avoid errors on restart
- [[ "$( fbcondecor_ctl --tty=${tty} -c getstate )" == *\ off ]] && continue
- fbcondecor_ctl --tty=${tty} -c off || retval=1
- done
- if [ $retval = 0 ]; then
- stat_done
- else
- stat_fail
- fi
-;; restart )
- $0 stop
- sleep .1
- echo # don't swallow our status line
- $0 start
-;; * )
- echo "usage: $0 {start|stop|restart}"
-esac
-
-exit 0
-
-# EOF #
diff --git a/abs/core-testing/fbsplash/fbsplash-basic.sh b/abs/core-testing/fbsplash/fbsplash-basic.sh
deleted file mode 100644
index 2834060..0000000
--- a/abs/core-testing/fbsplash/fbsplash-basic.sh
+++ /dev/null
@@ -1,201 +0,0 @@
-
-# /etc/rc.d/functions.d/fbsplash-basic.sh #
-
-# Basic Fbsplash script for Arch Linux initscripts #
-# #
-# Author: Kurt J. Bosch <kjb-temp-2009 at alpenjodel.de> #
-# Based on the work of Greg Helton <gt at fallendusk.org> #
-# Thomas Baechler <thomas at archlinux.org> #
-# and others #
-# #
-# Distributed under the terms of the GNU General Public License (GPL) #
-
-[[ $PREVLEVEL && $RUNLEVEL ]] || return 0
-
-# Do nothing if improved scripts are installed
-[ -r /etc/rc.d/functions.d/fbsplash-extras.sh ] && return
-
-# Only do this where needed
-# Since we use BASH, all important functions and variables are exported
-case ${0#/etc/rc.} in sysinit | multi | shutdown )
- export SPLASH_PUSH_MESSAGES="no"
- export SPLASH_VERBOSE_ON_ERRORS="no"
- . /sbin/splash-functions.sh # /etc/conf.d/splash is also sourced by this
- unset options opt i # eliminate splash_setup non local vars ## FIX ME ##
- declare -ix SPLASH_STEPS=3 # sysinit steps
- declare -ix SPLASH_STEPS_DONE=0
-esac
-
-# Verbose mode is handled by fbcondecor kernel patch and daemon script
-[[ $SPLASH_MODE_REQ = silent ]] || return 0
-
-# Override - Don't try to use /usr/bin/basename
-splash_comm_send() {
- [[ $( /bin/pidof -o %PPID $spl_daemon ) ]] && echo "$@" >$spl_fifo &
-}
-
-case $0 in /etc/rc.sysinit )
- # Prevent splash destruction
- CONSOLEFONT=""
- # Continue to use a splash daamon started in initcpio
- if /bin/mountpoint -q /dev/.splash-cache; then
- /bin/mount --move /dev/.splash-cache $spl_cachedir || return
- splash_comm_send set message "$SPLASH_BOOT_MESSAGE"
- # Mount a tmpfs
- else
- ( splash_cache_prep ) || return
- fi
- add_hook sysinit_udevsettled splash_sysinit_udevsettled
- add_hook sysinit_postfsck splash_sysinit_postfsck
- add_hook sysinit_postfsckloop splash_sysinit_postfsck
- add_hook sysinit_premount splash_sysinit_premount
- add_hook sysinit_end splash_sysinit_end
- splash_sysinit_udevsettled() {
- splash_begin
- splash_progress_init
- splash_progress
- }
- splash_sysinit_premount() {
- splash_progress
- }
- splash_sysinit_postfsck() { # fsck failure emergency exit
- [ ${fsckret} -gt 1 -a ${fsckret} -ne 32 ] && chvt 1
- }
- splash_sysinit_end() {
- splash_progress
- }
-;; /etc/rc.multi )
- add_hook multi_start splash_multi_start
- add_hook multi_end splash_multi_end
- splash_multi_start() {
- SPLASH_STEPS_DONE=$SPLASH_STEPS
- splash_progress_init
- }
- start_daemon() {
- [[ $1 = $SPLASH_XSERVICE ]] && SPLASH_EXIT_TYPE=staysilent splash_stop
- /etc/rc.d/$1 start
- splash_progress
- }
- start_daemon_bkgd() {
- [[ $1 = $SPLASH_XSERVICE ]] && SPLASH_EXIT_TYPE=staysilent splash_stop
- stat_bkgd "Starting $1"
- ( SPLASH_PUSH_MESSAGES="no" SPLASH_VERBOSE_ON_ERRORS="no" \
- /etc/rc.d/$1 start ) &>/dev/null &
- }
- splash_multi_end() {
- if [[ $PREVLEVEL = N ]]; then
- if ! in_array "$SPLASH_XSERVICE" "${DAEMONS[@]}"; then
- if [[ $RUNLEVEL = 5 ]]; then
- SPLASH_EXIT_TYPE=staysilent splash_stop
- else
- splash_stop
- [[ $( $spl_bindir/fgconsole ) = $SPLASH_TTY ]] && chvt 1
- fi
- fi
- # Now do setfont
- set_consolefont
- # Umount the tmpfs
- splash_cache_cleanup
- fi
- }
-;; /etc/rc.shutdown )
- ( splash_cache_prep ) || return
- # Not using XSERVICE here to avoid missing errors - X should chvt back to SPLASH_TTY
- add_hook shutdown_start splash_shutdown_start
- add_hook shutdown_prekillall splash_shutdown_prekillall
- add_hook shutdown_postkillall splash_shutdown_postkillall
- add_hook shutdown_poweroff splash_shutdown_poweroff
- splash_shutdown_start() {
- splash_begin
- }
- ## http://bugs.archlinux.org/task/10536 ## FIX ME ##
- splash_shutdown_prekillall() { /bin/sleep .1; }
- splash_shutdown_postkillall() {
- if [[ $( $spl_bindir/fgconsole ) = $SPLASH_TTY ]]; then
- stat_busy "Restarting Fbsplash daemon"
- PROGRESS=$(( 65535*2/3 )) splash_start
- if [[ -e $spl_cachedir/stop_failed-fbsplash-dummy ]]; then
- splash_comm_send update_svc fbsplash-dummy svc_stop_failed
- fi
- stat_done
- fi
- }
- ##
- splash_shutdown_poweroff() {
- SPLASH_EXIT_TYPE=staysilent splash_stop
- }
-esac
-
-splash_progress_init() {
- for daemon in "${DAEMONS[@]}"; do
- case $daemon in $SPLASH_XSERVICE | @$SPLASH_XSERVICE ) break
- ;; \!* |@* ) continue
- esac
- SPLASH_STEPS+=1
- done
-}
-
-splash_progress() {
- splash_comm_send progress $(( 65535*++SPLASH_STEPS_DONE/SPLASH_STEPS ))
- splash_comm_send paint
-}
-
-# Start the splash daemon - using upstream function
-splash_set_event_dev() { :; } # override - Never grab the keyboard
-splash_begin() {
- if ! [[ $( /bin/pidof -o %PPID $spl_daemon ) ]]; then
- stat_busy "Starting Fbsplash daemon"
- if [ -x /etc/splash/$SPLASH_THEME/scripts/rc_init-pre ]; then
- /etc/splash/$SPLASH_THEME/scripts/rc_init-pre ${0#/etc/rc.d} $RUNLEVEL
- fi &&
- splash_start &&
- stat_done || stat_fail
- fi
-}
-
-# Stop the splash daemon - if any
-splash_stop() {
- if [[ $( /bin/pidof -o %PPID $spl_daemon ) ]]; then
- SPLASH_PUSH_MESSAGES="no" stat_busy "Stopping Fbsplash daemon"
- splash_comm_send progress 65535; splash_comm_send paint; /bin/sleep .1
- splash_comm_send exit $SPLASH_EXIT_TYPE
- # Wait for painting/fadeout
- local -i i=0
- while [[ i++ -lt 100 && $( /bin/pidof -o %PPID $spl_daemon ) ]]; do
- /bin/sleep .1
- done
- stat_done
- fi
-}
-
-stat_busy() {
- printf "${C_OTHER}${PREFIX_REG} ${C_MAIN}${1}${C_CLEAR} "
- printf "${SAVE_POSITION}"
- deltext
- printf " ${C_OTHER}[${C_BUSY}BUSY${C_OTHER}]${C_CLEAR} "
- SPLASH_BUSY_MSG=$1
- if [[ $SPLASH_PUSH_MESSAGES = yes ]]; then
- splash_comm_send set message "${1}"
- splash_comm_send paint
- fi
-}
-
-stat_fail() {
- deltext
- printf " ${C_OTHER}[${C_FAIL}FAIL${C_OTHER}]${C_CLEAR} \n"
- local event=stop_failed; [[ $PREVLEVEL = N ]] && event=start_failed
- # Provide a general failure status event and write to msglog textbox
- splash_comm_send update_svc fbsplash-dummy svc_${event}
- splash_comm_send log "Error $SPLASH_BUSY_MSG"
- splash_comm_send paint
- # Save for daemon restart ## FIX ME ##
- if /bin/mountpoint -q $spl_cachedir; then
- : >|$spl_cachedir/${event}-fbsplash-dummy
- fi
- # Upstream way of error handling
- if [[ $SPLASH_VERBOSE_ON_ERRORS = yes ]]; then
- chvt 1
- fi
-}
-
-# EOF #
diff --git a/abs/core-testing/fbsplash/fbsplash.git.patch b/abs/core-testing/fbsplash/fbsplash.git.patch
deleted file mode 100644
index 15f041c..0000000
--- a/abs/core-testing/fbsplash/fbsplash.git.patch
+++ /dev/null
@@ -1,166 +0,0 @@
-From 4ecac1b2645afc8079aad4067a1aa0e8a96eab12 Mon Sep 17 00:00:00 2001
-From: =?utf8?q?Micha=C5=82=20Januszewski?= <spock@gentoo.org>
-Date: Tue, 16 Feb 2010 23:30:18 +0100
-Subject: [PATCH] Make it possible to build fbcondecor_helper against glibc.
-
----
- configure.ac | 34 ++++++++++++++++++++++++++++++++++
- libs/Makefile.am | 2 ++
- src/Makefile.am | 34 +++++++++++++++++++++++++++++++++-
- 3 files changed, 69 insertions(+), 1 deletions(-)
-
-diff --git configure.ac configure.ac
-index 63b1ff6..8db1498 100644
---- configure.ac
-+++ configure.ac
-@@ -76,6 +76,23 @@ AC_ARG_ENABLE([klibc-shared],
- )
- AM_CONDITIONAL([CONFIG_KLIBC_SHARED], [test "x${config_klibc_shared}" = "xyes"])
-
-+AC_ARG_ENABLE([static-binaries],
-+ AC_HELP_STRING([--disable-static-binaries], [do not build any statically linked binaries]),
-+ [
-+ AS_CASE(["${enableval}"],
-+ [yes], [config_static_binaries="yes"],
-+ [no], [config_static_binaries="no"],
-+ [AC_MSG_ERROR([bad value '${enableval}' for --disable-static-binaries])]
-+ )
-+ ],
-+ [config_static_binaries="yes"]
-+)
-+AM_CONDITIONAL([CONFIG_STATIC_BINARIES], [test "x${config_static_binaries}" = "xyes"])
-+AS_IF(
-+ [test "x${config_static_binaries}" = "xyes"],
-+ [AC_DEFINE([CONFIG_STATIC_BINARIES], [1], [Define to 1 to disable building of statically linked binaries.])]
-+)
-+
- AC_ARG_ENABLE([deprecated],
- AC_HELP_STRING([--enable-deprecated], [include support for deprecated features]),
- [
-@@ -333,6 +350,23 @@ AC_ARG_WITH([themedir],
- )
- AC_SUBST([themedir])
-
-+AC_ARG_WITH([klibc],
-+ AC_HELP_STRING([--without-klibc], [link the kernel helper against glibc instead of klibc]),
-+ [
-+ AS_CASE(["${withval}"],
-+ [yes], [config_klibc="yes"],
-+ [no], [config_klibc="no"],
-+ [AC_MSG_ERROR([bad value ${withval} for --with-klibc])]
-+ )
-+ ],
-+ [config_klibc="yes"]
-+)
-+AM_CONDITIONAL([CONFIG_KLIBC], [test "x${config_klibc}" = "xyes"])
-+AS_IF(
-+ [test "x${config_klibc}" = "xyes"],
-+ [AC_DEFINE([CONFIG_KLIBC], [1], [use klibc])]
-+)
-+
- M_CFLFAGS=
- M_LIBS=
- AC_CHECK_HEADER(
-diff --git libs/Makefile.am b/core/libs/Makefile.am
-index 6675ec1..d070b29 100644
---- libs/Makefile.am
-+++ libs/Makefile.am
-@@ -24,6 +24,7 @@ mostlyclean-local: \
-
- noinst_LIBRARIES =
-
-+if CONFIG_KLIBC
- if CONFIG_HELPER
- noinst_LIBRARIES += libjpeg.a
- if CONFIG_PNG
-@@ -33,6 +34,7 @@ if CONFIG_TTF_KERNEL
- noinst_LIBRARIES += libfreetype.a
- endif
- endif
-+endif
-
- libjpeg_a_SOURCES =
- libpng_a_SOURCES =
-diff --git src/Makefile.am b/core/src/Makefile.am
-index fa6919d..7570b5e 100644
---- src/Makefile.am
-+++ src/Makefile.am
-@@ -167,7 +167,6 @@ sbin_PROGRAMS += fbcondecor_ctl
- endif
- sbin_PROGRAMS += fbsplashd
- bin_PROGRAMS += splash_util
--eexecsbin_PROGRAMS += fbsplashctl
-
- fbcondecor_ctl_SOURCES = fbcon_decor_ctl.c fbcon_decor.h ../include/console_decor.h ../include/fbcondecor.h common.h fbsplash.h
- fbcondecor_ctl_CPPFLAGS = $(AM_CPPFLAGS) -DTARGET_UTIL $(libfbsplashrender_la_CFLAGS)
-@@ -185,6 +184,9 @@ splash_util_CPPFLAGS = $(AM_CPPFLAGS) -DTARGET_UTIL $(libfbsplashrender_l
- splash_util_LDFLAGS = $(AM_LDFLAGS)
- splash_util_LDADD = libfbsplashrender.la libfbsplash.la
-
-+if CONFIG_STATIC_BINARIES
-+eexecsbin_PROGRAMS += fbsplashctl
-+
- fbsplashctl_SOURCES = $(fbsplashd_SOURCES) $(splash_util_SOURCES) fbsplashctl.c
- fbsplashctl_CFLAGS = $(AM_CFLAGS) $(PTHREAD_STATIC_CFLAGS) $(RT_CFLAGS) $(libfbsplashrender_la_CFLAGS) -DUNIFIED_BUILD
- fbsplashctl_CPPFLAGS = $(fbsplashd_CPPFLAGS) $(splash_util_CPPFLAGS)
-@@ -210,6 +212,7 @@ uninstall-hook:
- if CONFIG_FBCON_DECOR
- rm -f $(DESTDIR)$(eexecsbindir)/fbcondecor_ctl.static$(EXEEXT)
- endif
-+endif
-
- ################################################################################
- # Kernel
-@@ -219,6 +222,7 @@ if CONFIG_HELPER
- eexecsbin_PROGRAMS += fbcondecor_helper
- endif
-
-+if CONFIG_KLIBC
- fbcondecor_helper_SOURCES = \
- kernel.c \
- libfbsplash.c \
-@@ -236,10 +240,12 @@ fbcondecor_helper_SOURCES = \
- common.h \
- render.h \
- fbsplash.h
-+
- fbcondecor_helper_CPPFLAGS = -DWITH_ERRLIST -DTARGET_KERNEL -DTT_CONFIG_OPTION_BYTECODE_INTERPRETER
- fbcondecor_helper_CFLAGS = -Os -w -ffunction-sections -fdata-sections -I.@am__isrc@
- fbcondecor_helper_LDFLAGS =
- fbcondecor_helper_LDADD =
-+
- fbcondecor_helper_CFLAGS += -I$(abs_top_builddir)/libs/libjpeg -I$(LIBJPEG_SOURCE)
- fbcondecor_helper_LDADD += $(top_builddir)/libs/libjpeg.a
- if CONFIG_PNG
-@@ -280,3 +286,29 @@ fbcondecor_helper-%.o: %.c
- @$(call infmsg,CC,$@)
- $(Q)$(MKDIR_P) $(@D)
- $(Q)$(KLCC) $(fbcondecor_helper_CPPFLAGS) $(fbcondecor_helper_CFLAGS) $(INCLUDES) -c $< -o $@
-+else
-+fbcondecor_helper_SOURCES = \
-+ kernel.c \
-+ libfbsplash.c \
-+ libfbsplashrender.c \
-+ fbcon_decor.c \
-+ common.c \
-+ parse.c \
-+ list.c \
-+ render.c \
-+ image.c \
-+ effects.c \
-+ fbcon_decor.h \
-+ ../include/console_decor.h \
-+ ../include/fbcondecor.h \
-+ common.h \
-+ render.h \
-+ fbsplash.h
-+if CONFIG_TTF_KERNEL
-+fbcondecor_helper_SOURCES += ttf.c ttf.h
-+endif
-+fbcondecor_helper_CPPFLAGS = $(AM_CPPFLAGS) -DTARGET_KERNEL
-+fbcondecor_helper_CFLAGS = $(AM_CFLAGS) $(libfbsplashrender_la_CFLAGS)
-+fbcondecor_helper_LDFLAGS = $(AM_LDFLAGS)
-+fbcondecor_helper_LDADD = $(libfbsplashrender_la_LIBADD)
-+endif
---
-1.6.5.GIT
diff --git a/abs/core-testing/fbsplash/fbsplash.initcpio_hook b/abs/core-testing/fbsplash/fbsplash.initcpio_hook
deleted file mode 100644
index 62048df..0000000
--- a/abs/core-testing/fbsplash/fbsplash.initcpio_hook
+++ /dev/null
@@ -1,102 +0,0 @@
-run_hook ()
-{
- SPLASH_INIT_MESSAGE="Initializing the kernel"
- SPLASH_MODE_REQ="off"
- SPLASH_THEME="default"
- SPLASH_TTY=16
- SPLASH_TEXTBOX="no"
- SPLASH_AUTOVERBOSE=0
-
- . /etc/conf.d/splash
-
- # Kernel parameters override config file
- local ifs="$IFS"
- IFS=','
- set -- $splash
- IFS="$ifs"
- local arg effects
- for arg in "$@"; do
- case "$arg"
- in off ) SPLASH_MODE_REQ="off"
- ;; silent ) SPLASH_MODE_REQ="silent"
- ;; verbose ) SPLASH_MODE_REQ="verbose"
- ;; theme:?* ) SPLASH_THEME="${arg#theme:}"
- ;; tty:?* ) SPLASH_TTY="${arg#tty:}"
- ;; insane ) SPLASH_SANITY="insane"
- ;; fadein | fadeout ) effects="$effects,$arg"
- esac
- done
- if [ -n "$effects" ]; then
- SPLASH_EFFECTS="${effects#,}"
- fi
-
- if [ "${SPLASH_MODE_REQ}" != "silent" ]; then
- return
- fi
-
- if ! [ "$console" = tty1 -o "$SPLASH_SANITY" = insane ]; then
- err "Fbsplash requires console=tty1 in kernel line!"
- return 1
- fi
-
- # Start the daemon here if possible
- # to show animations early and gain some bootup speed
- if [ -x /sbin/fbsplashd.static ]; then
- if [ -x /etc/splash/"$SPLASH_THEME"/scripts/rc_init-pre ]; then
- msg "Found '/etc/splash/$SPLASH_THEME/scripts/rc_init-pre'"
- msg "Not starting Fbsplash daemon - no theme hook support in initcpio."
- else
- msg "Starting Fbsplash Daemon"
- (
- set -e
- # Hold the cache and fifo within /dev to get it moved to the new root
- mkdir /dev/.splash-cache
- # code line derived from splash-functions.sh
- mount -t tmpfs cachedir /dev/.splash-cache -o rw,mode=0644,size=4096k
- # Take over any existing cache content
- mkdir -p /lib/splash/cache
- mv /lib/splash/cache /lib/splash/.splash-cache
- cp -a /lib/splash/.splash-cache /dev/
- ln -s /dev/.splash-cache /lib/splash/cache
- mkfifo -m 600 /lib/splash/cache/.splash
- # Wait for any fbcondecor fadein - may take very long on some broken systems
- i=0
- while [ -n "$( pidof fbcondecor_helper )" ]; do
- if [ $i -ge 50 ]; then
- err "timeout on waiting for fbcondecor_helper to die!"
- exit 1
- fi
- sleep .1
- i=$(( i + 1 ))
- done
- # Actually start the daemon
- options=""
- [ -n "$SPLASH_THEME" ] && options="$options --theme=$SPLASH_THEME"
- [ -n "$SPLASH_EFFECTS" ] && options="$options --effects=$SPLASH_EFFECTS"
- [ "$SPLASH_TEXTBOX" = yes ] && options="$options --textbox"
- cd /dev/.splash-cache
- BOOT_MSG="${SPLASH_INIT_MESSAGE}" \
- /sbin/fbsplashd.static --type=bootup --pidfile=daemon.pid $options
- (
- echo set tty silent $SPLASH_TTY
- echo set mode silent
- echo repaint
- echo set autoverbose $SPLASH_AUTOVERBOSE
- ) >/lib/splash/cache/.splash &
- )
- return
- fi
- fi
-
- # Start the fbcondecor helper if not already done by fbcondecor kernel
- (
- # code copied from splash-functions.sh
- fbcondecor_supported() {
- [ -e /dev/fbsplash -o -e /dev/fbcondecor ]
- }
- if ! fbcondecor_supported; then
- BOOT_MSG="${SPLASH_INIT_MESSAGE}" \
- /sbin/fbcondecor_helper 2 init 0 0 $SPLASH_THEME
- fi
- )
-}
diff --git a/abs/core-testing/fbsplash/fbsplash.initcpio_install b/abs/core-testing/fbsplash/fbsplash.initcpio_install
deleted file mode 100644
index 4485f91..0000000
--- a/abs/core-testing/fbsplash/fbsplash.initcpio_install
+++ /dev/null
@@ -1,114 +0,0 @@
-
-install() {
- (
- . /etc/conf.d/splash
-
- if /bin/mountpoint -q /lib/splash/cache; then
- /bin/umount /lib/splash/cache
- fi
-
- # Add the helper
- add_binary /sbin/fbcondecor_helper
-
- # Add the daemon for early start
- if [[ $SPLASH_DAEMON = early ]]; then
- add_binary /sbin/fbsplashd.static
- fi
-
- # Add a clean config file avoiding errors when running the hook
- file=$( /usr/bin/mktemp )
- for var in SPLASH_INIT_MESSAGE SPLASH_MODE_REQ SPLASH_THEME SPLASH_TTY \
- SPLASH_AUTOVERBOSE SPLASH_EFFECTS SPLASH_TEXTBOX
- do
- eval value=\"\$$var\"
- [ -n "$value" ] && echo $var="'$value'"
- done >|$file
- add_file $file /etc/conf.d/splash
-
- # List file paths contained in given Fbsplash theme cfg file
- _get_cfg_files() {
- < "$1" /bin/sed -re '
- # convert all whitespace into single blanks
- s,[[:space:]]+, ,g ; t L1
- :L1
- # drop comments, grouping directives and blank lines
- /^ *([#<]|$)/ d
- # get a filepath or drop
- s,.*[ =]([^ ]*/[^ ]+).*,\1, ; t ; d
- ' | /usr/bin/sort -u
- }
-
- # Check if cfg file name or path
- _match_cfg() {
- [[ "$1" =~ (^|/)[0-9]+x[0-9]+\.cfg$ ]]
- }
-
- # Add non-cfg files in given dir
- _add_non_cfg_files() {
- local file dir="$1"
- for file in $( /bin/ls "$dir" ); do
- if [ -f "$dir/$file" ]; then
- _match_cfg "$file" || add_file "$dir/$file"
- fi
- done
- }
-
- # Add global non-cfg files
- _add_non_cfg_files /etc/splash
-
- # Add themes
- dirs=""
- for theme in ${SPLASH_THEMES[*]}; do # string list and array allowed
- [ ${theme:0:1} = / ] || theme=/etc/splash/$theme
- if [ -f $theme ]; then
- if ! _match_cfg $theme; then
- err "Not a valid theme cfg file name: $theme"
- continue
- fi
- add_file $theme || continue
- dir=$( dirname $theme )
- # Add non-cfg files in theme dir
- _add_non_cfg_files $dir
- # Add files refered in cfg file by paths
- for file in $( _get_cfg_files $theme ); do
- if [ ${file:0:1} = / ]; then
- add_file $file
- continue
- fi
- # Path may be relative to theme-dir or to /etc/splash
- [ -e $dir/$file -o ! -f /etc/splash/$file ] && add_file $dir/$file
- [ -e /etc/splash/$file -o ! -f $dir/$file ] && add_file /etc/splash/$file
- done
- elif [ -d $theme ]; then
- dir=$theme
- add_full_dir $dir
- else
- err "Theme not found: $theme"
- continue
- fi
- if [[ " "$dirs" " != *" "$dir" "* ]]; then
- dirs+=" "$dir
- fi
- done
- for dir in $dirs; do
- # Add the rc_init-pre script if we have one
- # Currently this just prevents early daemon start for the theme
- if [[ $SPLASH_DAEMON = early && -x $dir/scripts/rc_init-pre ]]; then
- add_file $dir/scripts/rc_init-pre || continue
- echo "WARNING: rc_init-pre script found - no early daemon with '${dir##*/}'!" >&2
- fi
- done
- )
-
- SCRIPT="fbsplash"
-}
-
-help() {
-cat<<HELPEOF
- This hook adds the FBconDecor helper and Fbsplash themes and maybe the
- Fbsplash daemon as specified in /etc/conf.d/splash. Put it after udev
- for early daemon start or when using a FBconDecor kernel.
-HELPEOF
-}
-
-#EOF
diff --git a/abs/core-testing/fbsplash/fbsplash.install b/abs/core-testing/fbsplash/fbsplash.install
deleted file mode 100644
index 09da219..0000000
--- a/abs/core-testing/fbsplash/fbsplash.install
+++ /dev/null
@@ -1,27 +0,0 @@
-post_install() {
- echo "------------------------------------------------------------"
- echo "> This package doesn't contain a default theme."
- echo "> You need to install one separately."
- echo "> To find some themes, just search AUR for \"fbsplash-theme\","
- echo "> or GNOME-Look.org or KDE-Look.org for \"fbsplash\"."
- echo "------------------------------------------------------------"
- echo "> Configuration for fbsplash: /etc/conf.d/splash"
- echo "> Configuration for fbcondecor: /etc/conf.d/fbcondecor"
- echo "------------------------------------------------------------"
- echo "> Remember to rebuild the initrd after changing the"
- echo "> configuration."
- echo "------------------------------------------------------------"
- echo "> Please read http://wiki.archlinux.org/index.php/Fbsplash"
- echo "> for more details. "
- echo "------------------------------------------------------------"
-}
-
-post_upgrade() {
- post_install
-}
-
-op=$1
-shift
-$op $*
-
-#EOF
diff --git a/abs/core-testing/fbsplash/splash.conf b/abs/core-testing/fbsplash/splash.conf
deleted file mode 100644
index 74cada9..0000000
--- a/abs/core-testing/fbsplash/splash.conf
+++ /dev/null
@@ -1,63 +0,0 @@
-#
-# /etc/conf.d/splash
-#
-
-#### initcpio and Fbsplash daemon ##########################################
-
-## Themes to include into initcpio
-## For a smaller initcpio you may try theme cfg files instead of directories.
-SPLASH_THEMES=(
- linhes
-)
-
-## Override the initial silent splash screen status message defaults.
-## Note: '$progress' will be replaced by Fbsplash itself.
-## * initcpio - (no effect with fbcondecor kernel)
-SPLASH_INIT_MESSAGE="Initializing the kernel"
-## * bootup
-SPLASH_BOOT_MESSAGE="Booting '$HOSTNAME' (\$progress%)"
-## * reboot
-SPLASH_REBOOT_MESSAGE="Rebooting '$HOSTNAME' (\$progress%)"
-## * shutdown
-SPLASH_SHUTDOWN_MESSAGE="Shutting down '$HOSTNAME' (\$progress%)"
-
-## To show animations early, include the Fbsplash daemon (1.5 MiB) into initcpio, too,
-## instead of the small helper only.
-## Note: Themes with 'scripts/rc_init-pre' like 'arch-banner-icons' are not supported.
-SPLASH_DAEMON="early"
-
-## Make the splash daemon use fade effects.
-## Note: The initcpio helper does only use the kernel parameter!
-# SPLASH_EFFECTS="fadein,fadeout"
-## Uggly hack to get that in from the kernel line :p
-SPLASH_EFFECTS=$(e=();IFS=',';for w in $splash;do [[ $w == fade* ]]&&e+=($w);done;echo "${e[*]}")
-
-## Enable the textbox when starting the Fbsplash daemon.
-## Useful if the theme provides a message log or other textbox.
-## The scripts write any initscripts [FAIL] messages to the log.
-## Note: The textbox can also be toggled by pressing F3-key.
-SPLASH_TEXTBOX="yes"
-
-## Splash progress timeout
-## If set to a positive value, Fbsplash will automatically switch to verbose
-## mode if there is no progress for the specified number of seconds.
-SPLASH_AUTOVERBOSE=0
-
-#### scripts behaviour #####################################################
-
-## Change to verbose mode on any initscripts [FAIL] message
-## Useful with very simple themes and also when starting Xorg from DAEMONS
-SPLASH_VERBOSE_ON_ERRORS="no"
-
-## Name of the DAEMONS script starting Xorg if any
-## Set this to avoid virtual terminal change struggle between Xorg and Fbsplash.
-SPLASH_XSERVICE="gdm"
-#SPLASH_XSERVICE="kdm"
-#SPLASH_XSERVICE="xdm"
-#SPLASH_XSERVICE="lxdm"
-#SPLASH_XSERVICE="slim"
-
-## Push initscripts [BUSY] messages to the splash status message line.
-SPLASH_PUSH_MESSAGES="no"
-
-# EOF #