summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/filesystem
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/filesystem')
-rw-r--r--abs/core-testing/filesystem/PKGBUILD114
-rw-r--r--abs/core-testing/filesystem/__CHANGELOG2
-rw-r--r--abs/core-testing/filesystem/crypttab33
-rw-r--r--abs/core-testing/filesystem/filesystem.install74
-rw-r--r--abs/core-testing/filesystem/fstab11
-rw-r--r--abs/core-testing/filesystem/group30
-rw-r--r--abs/core-testing/filesystem/gshadow29
-rw-r--r--abs/core-testing/filesystem/host.conf8
-rw-r--r--abs/core-testing/filesystem/hosts8
-rw-r--r--abs/core-testing/filesystem/issue3
-rw-r--r--abs/core-testing/filesystem/ld.so.conf7
-rw-r--r--abs/core-testing/filesystem/modprobe.d.usb-load-ehci-first2
-rw-r--r--abs/core-testing/filesystem/motd0
-rw-r--r--abs/core-testing/filesystem/nsswitch.conf19
-rw-r--r--abs/core-testing/filesystem/passwd7
-rw-r--r--abs/core-testing/filesystem/profile60
-rw-r--r--abs/core-testing/filesystem/resolv.conf8
-rw-r--r--abs/core-testing/filesystem/securetty14
-rw-r--r--abs/core-testing/filesystem/shadow7
-rw-r--r--abs/core-testing/filesystem/shells9
20 files changed, 0 insertions, 445 deletions
diff --git a/abs/core-testing/filesystem/PKGBUILD b/abs/core-testing/filesystem/PKGBUILD
deleted file mode 100644
index 0345d29..0000000
--- a/abs/core-testing/filesystem/PKGBUILD
+++ /dev/null
@@ -1,114 +0,0 @@
-# $Id: PKGBUILD 90913 2010-09-18 23:00:51Z pierre $
-# Maintainer: Aaron Griffin <aaron@archlinux.org>
-# Contributor: judd <jvinet@zeroflux.org>
-
-pkgname=filesystem
-pkgver=2010.09
-pkgrel=2
-pkgdesc="Base filesystem"
-arch=('any')
-license=('GPL')
-url="http://www.archlinux.org"
-groups=('base')
-install=filesystem.install
-# These dependencies are not needed for initial installation.
-# They are only required on upgrade to create missing groups.
-#depends=('sh' 'coreutils')
-depends=('iana-etc')
-backup=(etc/fstab etc/crypttab etc/group etc/hosts etc/ld.so.conf etc/passwd
- etc/shadow etc/gshadow etc/resolv.conf etc/motd etc/nsswitch.conf
- etc/shells etc/host.conf etc/securetty etc/profile etc/issue)
-source=(group issue nsswitch.conf securetty host.conf ld.so.conf
- passwd shadow fstab crypttab hosts motd resolv.conf shells
- gshadow profile modprobe.d.usb-load-ehci-first)
-md5sums=('75c7e1770305e1f3b75c52785c137611'
- '1bdc5dba66947d74866a5df8ce9ef3b1'
- '13753e4e0964f3652b0cc60a28528bdf'
- '933dee67c58d452334d342c294342910'
- 'f28150d4c0b22a017be51b9f7f9977ed'
- '6e488ffecc8ba142c0cf7e2d7aeb832e'
- '8a9042a2cedf6b6b47eb8973f14289cb'
- 'b8355d9d2782f424f4cedcf682651be0'
- '57c5cc9da249c3b06a70fd7efb8c34a5'
- 'e5d8323a4dbee7a6d0d2a19cbf4b819f'
- '81b3cb42a6ddabc2ed2310511ee9c859'
- 'd41d8cd98f00b204e9800998ecf8427e'
- '6f48288b6fcaf0065fcb7b0e525413e0'
- '40dac0de4c6b99c8ca97effbd7527c84'
- '5340b9287b71ffe9d4d99510bffe933f'
- 'f7ba22b78c5d2b53f86227aa2447e7ea'
- '8098ffd9fbf890468d3198277596b85a')
-
-build()
-{
- cd ${pkgdir}
- mkdir -p bin boot dev etc home lib mnt proc root sbin tmp usr var opt srv sys
- chmod 555 proc
- mkdir -p media/{fl,cd,dvd}
- mkdir -p usr/{bin,include,lib,sbin,share/misc,src}
-
- mkdir -p usr/share/man/man{1,2,3,4,5,6,7,8}
-
- # fhs compliance
- mkdir -p usr/local/{bin,games,include,lib,man,sbin,share,src}
- ln -s ../man ${pkgdir}/usr/local/share/man
- mkdir -p var/{cache/man,local,lock,opt,run,spool/mail,tmp,games}
- chmod 1777 var/lock
- mkdir -p var/log/old
- mkdir -p etc/{ld.so.conf.d,skel,profile.d}
- mkdir -p lib/modules
- mkdir -p var/lib/misc
- (cd ${pkgdir}/var; ln -s spool/mail mail)
-
- # vsftpd won't run with write perms on /srv/ftp
- mkdir -p srv/ftp
- chown root.ftp srv/ftp
- chmod 555 srv/ftp
-
- install -d -o root -g root -m 755 srv/http
-
- chmod 1777 var/spool/mail tmp var/tmp
- chmod 0750 root
-
- #Allow setgid games to write scores:
- chmod 775 ${pkgdir}/var/games
- chown root:50 ${pkgdir}/var/games
-
- cd ${srcdir}
- cp fstab crypttab group host.conf hosts ld.so.conf motd nsswitch.conf \
- passwd resolv.conf securetty shadow shells profile \
- ${pkgdir}/etc/
- install -m 600 ${srcdir}/gshadow ${pkgdir}/etc/gshadow
- chmod 600 ${pkgdir}/etc/shadow
- chmod 600 ${pkgdir}/etc/crypttab
-
- # re-add /etc/arch-release, some software uses it
- # to check whether arch is running
- touch ${pkgdir}/etc/arch-release
-
- # Add /etc/modprobe.d/
- install -D -m644 ${srcdir}/modprobe.d.usb-load-ehci-first \
- ${pkgdir}/etc/modprobe.d/usb-load-ehci-first.conf
-
- # Prevent pacman from removing directory (FS#16886)
- mkdir ${pkgdir}/var/empty
- touch ${pkgdir}/var/empty/.keep
-}
-
-md5sums=('75c7e1770305e1f3b75c52785c137611'
- '1bdc5dba66947d74866a5df8ce9ef3b1'
- '13753e4e0964f3652b0cc60a28528bdf'
- 'f97799ef3d8990f2eda9166122d8d5aa'
- 'f28150d4c0b22a017be51b9f7f9977ed'
- '6e488ffecc8ba142c0cf7e2d7aeb832e'
- '8a9042a2cedf6b6b47eb8973f14289cb'
- 'b8355d9d2782f424f4cedcf682651be0'
- '57c5cc9da249c3b06a70fd7efb8c34a5'
- 'e5d8323a4dbee7a6d0d2a19cbf4b819f'
- '81b3cb42a6ddabc2ed2310511ee9c859'
- 'd41d8cd98f00b204e9800998ecf8427e'
- '6f48288b6fcaf0065fcb7b0e525413e0'
- '40dac0de4c6b99c8ca97effbd7527c84'
- '5340b9287b71ffe9d4d99510bffe933f'
- 'f7ba22b78c5d2b53f86227aa2447e7ea'
- '8098ffd9fbf890468d3198277596b85a')
diff --git a/abs/core-testing/filesystem/__CHANGELOG b/abs/core-testing/filesystem/__CHANGELOG
deleted file mode 100644
index 87707ff..0000000
--- a/abs/core-testing/filesystem/__CHANGELOG
+++ /dev/null
@@ -1,2 +0,0 @@
-removed /etc/issue
-added tty10 to securetty
diff --git a/abs/core-testing/filesystem/crypttab b/abs/core-testing/filesystem/crypttab
deleted file mode 100644
index dd6994b..0000000
--- a/abs/core-testing/filesystem/crypttab
+++ /dev/null
@@ -1,33 +0,0 @@
-# crypttab: Mappings for encrypted partitions
-#
-# Each mapped device will be created in /dev/mapper, so your /etc/fstab
-# should use the /dev/mapper/{NAME} paths for encrypted devices.
-#
-# Each PASSWORD field can be an absolute pathname to a key file (starting
-# with a slash, recommended) or a literal string that will be used as
-# a passphrase. To use special characters in the passphrase, surround it
-# by quotes, the usual bash quoting rules apply.
-# There are two special keywords that cannot be used as passphrases:
-# - ASK ask for a passphrase on boot
-# - SWAP use a random key and create a swapspace afterwards
-# WARNING: use the SWAP keyword carefully, as it overwrites the data
-# on the specified partition
-#
-# To create a key file:
-# hashalot -n 32 ripemd160 >/etc/crytfs.key
-# or
-# dd if=/dev/urandom of=/etc/cryptfs.key bs=256 count=1
-#
-# To pass additional options to cryptsetup for non-LUKS partitions, use the
-# fourth column.
-#
-# NOTE: Do not list your root (/) partition here, it must be set up
-# beforehand by the initramfs (/etc/mkinitcpio.conf).
-
-
-# NAME SOURCE DEVICE PASSWORD OPTIONS
-#home /dev/hda4 mypassword
-#data1 /dev/hda3 "my \"password\""
-#data2 /dev/hda5 /etc/cryptfs.key
-#swap /dev/hdx4 SWAP -c aes-cbc-essiv:sha256 -s 256
-#vol /dev/hdb7 ASK
diff --git a/abs/core-testing/filesystem/filesystem.install b/abs/core-testing/filesystem/filesystem.install
deleted file mode 100644
index e0ce1e2..0000000
--- a/abs/core-testing/filesystem/filesystem.install
+++ /dev/null
@@ -1,74 +0,0 @@
-# arg 1: the new package version
-post_install() {
- [ -f var/log/lastlog ] || : >var/log/lastlog
- [ -f var/log/wtmp ] || : >var/log/wtmp
- [ -f var/run/utmp ] || : >var/run/utmp
- [ -f var/log/btmp ] || (: >var/log/btmp && bin/chmod 600 var/log/btmp)
- # workaround for bug #7194
- # readded due to bug #9465
- # please do not remove!
- chmod 1777 var/spool/mail tmp var/tmp var/lock
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- post_install $1
- if [ ! "`grep ^optical: etc/group`" ]; then
- echo "adding new groups: audio optical"
- usr/sbin/groupadd -g 92 audio >/dev/null
- usr/sbin/groupadd -g 93 optical >/dev/null
- fi
- if [ ! "`grep ^video: etc/group`" ]; then
- echo "adding new groups: video floppy storage"
- usr/sbin/groupadd -g 91 video >/dev/null
- usr/sbin/groupadd -g 94 floppy >/dev/null
- usr/sbin/groupadd -g 95 storage >/dev/null
- fi
- if [ ! "`grep ^log: etc/group`" ]; then
- echo "adding new group: log"
- usr/sbin/groupadd -g 19 log >/dev/null
- fi
- if [ ! "`grep ^power: etc/group`" ]; then
- echo "adding new group: power"
- usr/sbin/groupadd -g 98 power >/dev/null
- fi
- if [ ! "`grep ^network: etc/group`" ]; then
- echo "adding new group: network"
- usr/sbin/groupadd -g 90 network >/dev/null
- fi
- if [ ! "`grep ^games: etc/group`" ]; then
- echo "adding new group: games"
- usr/sbin/groupadd -g 50 games >/dev/null
- fi
- if [ ! "`grep ^uucp: etc/group`" ]; then
- echo "adding new group: uucp"
- usr/sbin/groupadd -g 14 uucp >/dev/null
- fi
- if [ ! "`grep ^http: etc/group`" ]; then
- echo "adding new group: http"
- usr/sbin/groupadd -g 33 http >/dev/null
- fi
- if [ ! "`grep ^http: etc/passwd`" ]; then
- echo "adding new user http"
- usr/sbin/useradd -u 33 -d /srv/http -g http -s /bin/false http >/dev/null
- fi
- if [ ! "`grep ^scanner: etc/group`" ]; then
- echo "adding new group: scanner"
- usr/sbin/groupadd -g 96 scanner >/dev/null
- fi
- if [ ! "`grep ^rfkill: etc/group`" ]; then
- echo "adding new group: rfkill"
- usr/sbin/groupadd -g 24 rfkill >/dev/null
- fi
-
- grep -q '^include /etc/ld.so.conf.d/\*.conf$' etc/ld.so.conf \
- || echo 'include /etc/ld.so.conf.d/*.conf' >> etc/ld.so.conf
-
- # set "Last password change" > 0; otherwise su $user wont work
- for user in bin daemon mail ftp http nobody; do
- if LANG=C chage -l ${user} | grep -q 'password must be changed'; then
- chage -d 14871 ${user}
- fi
- done
-}
diff --git a/abs/core-testing/filesystem/fstab b/abs/core-testing/filesystem/fstab
deleted file mode 100644
index ee16ccc..0000000
--- a/abs/core-testing/filesystem/fstab
+++ /dev/null
@@ -1,11 +0,0 @@
-#
-# /etc/fstab: static file system information
-#
-# <file system> <dir> <type> <options> <dump> <pass>
-devpts /dev/pts devpts defaults 0 0
-shm /dev/shm tmpfs nodev,nosuid 0 0
-
-/dev/cdrom /media/cd auto ro,user,noauto,unhide 0 0
-/dev/dvd /media/dvd auto ro,user,noauto,unhide 0 0
-/dev/fd0 /media/fl auto user,noauto 0 0
-
diff --git a/abs/core-testing/filesystem/group b/abs/core-testing/filesystem/group
deleted file mode 100644
index 4bd635c..0000000
--- a/abs/core-testing/filesystem/group
+++ /dev/null
@@ -1,30 +0,0 @@
-root:x:0:root
-bin:x:1:root,bin,daemon
-daemon:x:2:root,bin,daemon
-sys:x:3:root,bin
-adm:x:4:root,daemon
-tty:x:5:
-disk:x:6:root
-lp:x:7:daemon
-mem:x:8:
-kmem:x:9:
-wheel:x:10:root
-ftp:x:11:
-mail:x:12:
-uucp:x:14:
-log:x:19:root
-locate:x:21:
-rfkill:x:24:
-smmsp:x:25:
-http:x:33:
-games:x:50:
-network:x:90:
-video:x:91:
-audio:x:92:
-optical:x:93:
-floppy:x:94:
-storage:x:95:
-scanner:x:96:
-power:x:98:
-nobody:x:99:
-users:x:100:
diff --git a/abs/core-testing/filesystem/gshadow b/abs/core-testing/filesystem/gshadow
deleted file mode 100644
index a6d78a3..0000000
--- a/abs/core-testing/filesystem/gshadow
+++ /dev/null
@@ -1,29 +0,0 @@
-root:::root
-bin:::root,bin,daemon
-daemon:::root,bin,daemon
-sys:::root,bin
-adm:::root,daemon
-tty:::
-disk:::root
-lp:::daemon
-mem:::
-kmem:::
-wheel:::root
-ftp:::
-mail:::
-uucp:::
-log:::root
-locate:::
-smmsp:::
-http:::
-games:::
-network:x::
-video:x::
-audio:::
-optical:::
-floppy:x::
-storage:x::
-scanner:x::
-power:x::
-nobody:::
-users:::
diff --git a/abs/core-testing/filesystem/host.conf b/abs/core-testing/filesystem/host.conf
deleted file mode 100644
index cf52fe5..0000000
--- a/abs/core-testing/filesystem/host.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-#
-# /etc/host.conf
-#
-
-order hosts,bind
-multi on
-
-# End of file
diff --git a/abs/core-testing/filesystem/hosts b/abs/core-testing/filesystem/hosts
deleted file mode 100644
index ec12849..0000000
--- a/abs/core-testing/filesystem/hosts
+++ /dev/null
@@ -1,8 +0,0 @@
-#
-# /etc/hosts: static lookup table for host names
-#
-
-#<ip-address> <hostname.domain.org> <hostname>
-127.0.0.1 localhost.localdomain localhost
-
-# End of file
diff --git a/abs/core-testing/filesystem/issue b/abs/core-testing/filesystem/issue
deleted file mode 100644
index 3db753d..0000000
--- a/abs/core-testing/filesystem/issue
+++ /dev/null
@@ -1,3 +0,0 @@
-
-Arch Linux \r (\n) (\l)
-
diff --git a/abs/core-testing/filesystem/ld.so.conf b/abs/core-testing/filesystem/ld.so.conf
deleted file mode 100644
index dfac456..0000000
--- a/abs/core-testing/filesystem/ld.so.conf
+++ /dev/null
@@ -1,7 +0,0 @@
-#
-# /etc/ld.so.conf
-#
-
-include /etc/ld.so.conf.d/*.conf
-
-# End of file
diff --git a/abs/core-testing/filesystem/modprobe.d.usb-load-ehci-first b/abs/core-testing/filesystem/modprobe.d.usb-load-ehci-first
deleted file mode 100644
index 3b5db0e..0000000
--- a/abs/core-testing/filesystem/modprobe.d.usb-load-ehci-first
+++ /dev/null
@@ -1,2 +0,0 @@
-install ohci_hcd /sbin/modprobe ehci_hcd ; /sbin/modprobe --ignore-install ohci_hcd $CMDLINE_OPTS
-install uhci_hcd /sbin/modprobe ehci_hcd ; /sbin/modprobe --ignore-install uhci_hcd $CMDLINE_OPTS
diff --git a/abs/core-testing/filesystem/motd b/abs/core-testing/filesystem/motd
deleted file mode 100644
index e69de29..0000000
--- a/abs/core-testing/filesystem/motd
+++ /dev/null
diff --git a/abs/core-testing/filesystem/nsswitch.conf b/abs/core-testing/filesystem/nsswitch.conf
deleted file mode 100644
index 6e459ad..0000000
--- a/abs/core-testing/filesystem/nsswitch.conf
+++ /dev/null
@@ -1,19 +0,0 @@
-# Begin /etc/nsswitch.conf
-
-passwd: files
-group: files
-shadow: files
-
-publickey: files
-
-hosts: files dns
-networks: files
-
-protocols: files
-services: files
-ethers: files
-rpc: files
-
-netgroup: files
-
-# End /etc/nsswitch.conf
diff --git a/abs/core-testing/filesystem/passwd b/abs/core-testing/filesystem/passwd
deleted file mode 100644
index a4a24e3..0000000
--- a/abs/core-testing/filesystem/passwd
+++ /dev/null
@@ -1,7 +0,0 @@
-root:x:0:0:root:/root:/bin/bash
-bin:x:1:1:bin:/bin:/bin/false
-daemon:x:2:2:daemon:/sbin:/bin/false
-mail:x:8:12:mail:/var/spool/mail:/bin/false
-ftp:x:14:11:ftp:/srv/ftp:/bin/false
-http:x:33:33:http:/srv/http:/bin/false
-nobody:x:99:99:nobody:/:/bin/false
diff --git a/abs/core-testing/filesystem/profile b/abs/core-testing/filesystem/profile
deleted file mode 100644
index cf461f7..0000000
--- a/abs/core-testing/filesystem/profile
+++ /dev/null
@@ -1,60 +0,0 @@
-#
-# /etc/profile
-#
-# This file is intended to be used for ALL common
-# Bourne-compatible shells. Shell specifics should be
-# handled in /etc/profile.$SHELL where $SHELL is the name
-# of the binary being run (discounting symlinks)
-#
-# Sections taken from SuSe's /etc/profile
-# Note the explicit use of 'test' to cover all bases
-# and potentially incompatible shells
-
-#Determine our shell without using $SHELL, which may lie
-shell="sh"
-if test -f /proc/mounts; then
- case $(/bin/ls -l /proc/$$/exe) in
- *bash) shell=bash ;;
- *dash) shell=dash ;;
- *ash) shell=ash ;;
- *ksh) shell=ksh ;;
- *zsh) shell=zsh ;;
- esac
-fi
-
-# Load shell specific profile settings
-test -f "/etc/profile.$shell" && . "/etc/profile.$shell"
-
-#Set our umask
-umask 022
-
-# Set our default path
-PATH="/bin:/usr/bin:/sbin:/usr/sbin"
-export PATH
-
-# Export default pkg-config path
-PKG_CONFIG_PATH="/usr/lib/pkgconfig"
-export PKG_CONFIG_PATH
-
-# Some readline stuff that is fairly common
-HISTSIZE=1000
-HISTCONTROL="erasedups"
-
-INPUTRC="/etc/inputrc"
-LESS="-R"
-
-export HISTSIZE HISTCONTROL INPUTRC LESS
-
-# Load profiles from /etc/profile.d
-if test -d /etc/profile.d/; then
- for profile in /etc/profile.d/*.sh; do
- test -x $profile && . $profile
- done
- unset profile
-fi
-
-# Termcap is outdated, old, and crusty, kill it.
-unset TERMCAP
-
-# Man is much better than us at figuring this out
-unset MANPATH
diff --git a/abs/core-testing/filesystem/resolv.conf b/abs/core-testing/filesystem/resolv.conf
deleted file mode 100644
index cecafba..0000000
--- a/abs/core-testing/filesystem/resolv.conf
+++ /dev/null
@@ -1,8 +0,0 @@
-#
-# /etc/resolv.conf
-#
-
-#search <yourdomain.tld>
-#nameserver <ip>
-
-# End of file
diff --git a/abs/core-testing/filesystem/securetty b/abs/core-testing/filesystem/securetty
deleted file mode 100644
index 7fcd451..0000000
--- a/abs/core-testing/filesystem/securetty
+++ /dev/null
@@ -1,14 +0,0 @@
-#
-# /etc/securetty
-#
-
-console
-tty1
-tty2
-tty3
-tty4
-tty5
-tty6
-hvc0
-tty10
-# End of file
diff --git a/abs/core-testing/filesystem/shadow b/abs/core-testing/filesystem/shadow
deleted file mode 100644
index ccab68d..0000000
--- a/abs/core-testing/filesystem/shadow
+++ /dev/null
@@ -1,7 +0,0 @@
-root::14871::::::
-bin:x:14871::::::
-daemon:x:14871::::::
-mail:x:14871::::::
-ftp:x:14871::::::
-http:x:14871::::::
-nobody:x:14871::::::
diff --git a/abs/core-testing/filesystem/shells b/abs/core-testing/filesystem/shells
deleted file mode 100644
index ff9e383..0000000
--- a/abs/core-testing/filesystem/shells
+++ /dev/null
@@ -1,9 +0,0 @@
-#
-# /etc/shells
-#
-
-/bin/sh
-/bin/bash
-/bin/dash
-
-# End of file