summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/fluxbox/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/fluxbox/PKGBUILD')
-rw-r--r--abs/core-testing/fluxbox/PKGBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/abs/core-testing/fluxbox/PKGBUILD b/abs/core-testing/fluxbox/PKGBUILD
deleted file mode 100644
index 3873ff1..0000000
--- a/abs/core-testing/fluxbox/PKGBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# $Id: PKGBUILD 12779 2008-09-20 06:42:07Z eric $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: John Proctor <jproctor@prium.net>
-
-pkgname=fluxbox
-pkgver=1.1.1
-pkgrel=11
-pkgdesc="A lightweight and highly-configurable window manager"
-arch=('i686' 'x86_64')
-url="http://www.fluxbox.org"
-license=('MIT')
-depends=('libxft' 'libxpm' 'libxinerama' 'libxrandr' 'gcc-libs' 'bash' 'imlib2')
-makedepends=('pkgconfig')
-options=('!makeflags')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2 \
- fluxbox.desktop keys fluxbox_fullscreen_focus.patch)
-
-build() {
- echo "==> Patching Fluxbox with fullscreen focus patch..."
- patch < fluxbox_fullscreen_focus.patch ${srcdir}/${pkgname}-${pkgver}/src/Window.cc || return 1
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr \
- --enable-kde --enable-gnome \
- --enable-xft --enable-xinerama \
- --enable-imlib2 --enable-nls || return 1
- make || return 1
- make DESTDIR=${pkgdir} install || return 1
- # this is a fix to allow fluxbox to shutdown, but this can be changed by the user :-(
- sed -i 's|^.*slit\.autoHide.*$|session.screen0.slit.autoHide: True|' ${pkgdir}/usr/share/fluxbox/init || return 1
- install -D -m644 ../fluxbox.desktop ${pkgdir}/etc/X11/sessions/fluxbox.desktop || return 1
- install -D -m644 ../keys ${pkgdir}/usr/share/fluxbox/keys || return 1
- install -D -m644 COPYING ${pkgdir}/usr/share/licenses/$pkgname/COPYING || return 1
-}
-md5sums=('fa9fa8fe9a44f86522de5754f8b285ca'
- 'eeae9c88a2526ac0bd8afcd9ce97f9ed'
- 'bb9f812c559263b4bf1d722628a11ca8'
- '82dac089f2d42bb9592debc93291846d')