summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/freeglut
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/freeglut')
-rw-r--r--abs/core-testing/freeglut/PKGBUILD30
-rw-r--r--abs/core-testing/freeglut/glut-cursor-inherit.patch23
2 files changed, 0 insertions, 53 deletions
diff --git a/abs/core-testing/freeglut/PKGBUILD b/abs/core-testing/freeglut/PKGBUILD
deleted file mode 100644
index 402ef70..0000000
--- a/abs/core-testing/freeglut/PKGBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-
-pkgname=freeglut
-pkgver=2.4.0
-pkgrel=3
-pkgdesc="Provides functionality for small OpenGL programs"
-arch=('i686' 'x86_64')
-url="http://freeglut.sourceforge.net/"
-license=('custom')
-depends=('libxxf86vm' 'mesa')
-replaces=('glut')
-provides=('glut')
-conflicts=('glut')
-options=('!libtool')
-source=(http://downloads.sourceforge.net/freeglut/${pkgname}-${pkgver}.tar.gz \
- glut-cursor-inherit.patch)
-md5sums=('6d16873bd876fbf4980a927cfbc496a1' 'd6ba7e22ebb0fd7904b8e18c97475ba6')
-sha1sums=('91a528aa72758b7288a0d69a964b1b7e3f322a12' '9353d7b811fdfd6f0c5766f0e93924ca63e9d6a9')
-
-build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- patch -Np1 -i ${startdir}/src/glut-cursor-inherit.patch || return 1
- sed -i 's/-Werror//' configure
- ./configure --prefix=/usr
- make all || return 1
- make DESTDIR=${startdir}/pkg install
- install -D -m644 COPYING ${startdir}/pkg/usr/share/licenses/${pkgname}/COPYING
-}
diff --git a/abs/core-testing/freeglut/glut-cursor-inherit.patch b/abs/core-testing/freeglut/glut-cursor-inherit.patch
deleted file mode 100644
index b56a37c..0000000
--- a/abs/core-testing/freeglut/glut-cursor-inherit.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- freeglut-2.4.0.orig/src/freeglut_cursor.c
-+++ freeglut-2.4.0/src/freeglut_cursor.c
-@@ -130,7 +130,9 @@
- XCreateFontCursor( fgDisplay.Display, entry->cursorShape );
- }
- cursor = entry->cachedCursor;
-- } else {
-+ if (cursor == None)
-+ fgError( "Failed to create cursor" );
-+ } else {
- switch( cursorIDToUse )
- {
- case GLUT_CURSOR_NONE:
-@@ -147,9 +149,6 @@
- }
- }
-
-- if ( ( cursorIDToUse != GLUT_CURSOR_NONE ) && ( cursor == None ) ) {
-- fgError( "Failed to create cursor" );
-- }
- XDefineCursor( fgDisplay.Display,
- window->Window.Handle, cursor );
- }