summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/ftgl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/ftgl/PKGBUILD')
-rw-r--r--abs/core-testing/ftgl/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core-testing/ftgl/PKGBUILD b/abs/core-testing/ftgl/PKGBUILD
new file mode 100644
index 0000000..47c9eb4
--- /dev/null
+++ b/abs/core-testing/ftgl/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: tobias <tobias@archlinux.org>
+pkgname=ftgl
+pkgver=2.1.2
+pkgrel=4
+pkgdesc="OpenGL library to use arbitrary fonts"
+arch=(i686 x86_64)
+source=(http://superb-east.dl.sourceforge.net/sourceforge/ftgl/$pkgname-$pkgver.tar.gz ftgl-gcc411.patch)
+url="http://homepages.paradise.net.nz/henryj/code/"
+options=(!libtool)
+depends=(freetype2 glut)
+makedepends=(doxygen)
+
+build() {
+ cd $startdir/src/FTGL/
+ patch -Np1 -i ${startdir}/src/ftgl-gcc411.patch || return 1
+ cd unix
+ sed -i 's|^ \$| $|g' src/Makefile
+ ./configure --prefix=/usr --with-pic
+ make || return 1
+ make prefix=$startdir/pkg/usr install
+
+}
+md5sums=('f81c0a7128192ba11e036186f9a968f2' '2a4ad16c1bfae869a8bf0ddababfd25a')