summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/ftgl
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/ftgl')
-rw-r--r--abs/core-testing/ftgl/PKGBUILD25
-rw-r--r--abs/core-testing/ftgl/ftgl-gcc411.patch12
2 files changed, 0 insertions, 37 deletions
diff --git a/abs/core-testing/ftgl/PKGBUILD b/abs/core-testing/ftgl/PKGBUILD
deleted file mode 100644
index 47c9eb4..0000000
--- a/abs/core-testing/ftgl/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
-# Contributor: tobias <tobias@archlinux.org>
-pkgname=ftgl
-pkgver=2.1.2
-pkgrel=4
-pkgdesc="OpenGL library to use arbitrary fonts"
-arch=(i686 x86_64)
-source=(http://superb-east.dl.sourceforge.net/sourceforge/ftgl/$pkgname-$pkgver.tar.gz ftgl-gcc411.patch)
-url="http://homepages.paradise.net.nz/henryj/code/"
-options=(!libtool)
-depends=(freetype2 glut)
-makedepends=(doxygen)
-
-build() {
- cd $startdir/src/FTGL/
- patch -Np1 -i ${startdir}/src/ftgl-gcc411.patch || return 1
- cd unix
- sed -i 's|^ \$| $|g' src/Makefile
- ./configure --prefix=/usr --with-pic
- make || return 1
- make prefix=$startdir/pkg/usr install
-
-}
-md5sums=('f81c0a7128192ba11e036186f9a968f2' '2a4ad16c1bfae869a8bf0ddababfd25a')
diff --git a/abs/core-testing/ftgl/ftgl-gcc411.patch b/abs/core-testing/ftgl/ftgl-gcc411.patch
deleted file mode 100644
index f52d48b..0000000
--- a/abs/core-testing/ftgl/ftgl-gcc411.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN FTGL.org/include/FTTextureGlyph.h FTGL/include/FTTextureGlyph.h
---- FTGL.org/include/FTTextureGlyph.h 2006-07-11 17:49:42.000000000 +0200
-+++ FTGL/include/FTTextureGlyph.h 2006-07-11 17:50:23.000000000 +0200
-@@ -52,7 +52,7 @@
- * Reset the currently active texture to zero to get into a known state before
- * drawing a string. This is to get round possible threading issues.
- */
-- static void FTTextureGlyph::ResetActiveTexture(){ activeTextureID = 0;}
-+ static void ResetActiveTexture(){ activeTextureID = 0;}
-
- private:
- /**