summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/git
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/git')
-rw-r--r--abs/core-testing/git/ChangeLog36
-rw-r--r--abs/core-testing/git/PKGBUILD78
-rw-r--r--abs/core-testing/git/git-daemon70
-rw-r--r--abs/core-testing/git/git-daemon.conf4
4 files changed, 0 insertions, 188 deletions
diff --git a/abs/core-testing/git/ChangeLog b/abs/core-testing/git/ChangeLog
deleted file mode 100644
index 8ed0884..0000000
--- a/abs/core-testing/git/ChangeLog
+++ /dev/null
@@ -1,36 +0,0 @@
-Simple version bumps are ommitted from the following ChangeLog.
-
-2010-06-29 Dan McGee <dan@archlinux.org>
- Version 1.7.1.1-1
- * Add emacs completion files (FS#17968)
- * Add git-daemon RC scripts (FS#19291)
-
-2009-06-05 Dan McGee <dan@archlinux.org>
- Version 1.6.3.2-1
- * Remove gitweb from /usr/share; it needs customization to be helpful
- * Add NO_CROSS_DIRECTORY_HARDLINKS option to build (FS#13683)
-
-2008-09-14 Dan McGee <dan@archlinux.org>
- Version 1.6.0.2-1
- * Moved optional depends from install file to optdepends array
-
-2008-06-15 Dan McGee <dan@archlinux.org>
- Version 1.5.6-1
- * Removed 'cpio' dependency, clone is now a builtin and no longer needs it
-
-2008-02-02 Dan McGee <dan@archlinux.org>
- Version 1.5.4-1
- * Upstream version 1.5.4
- * Enable pthreads support in pack-objects. To use, set the pack.threads
- git config option. Read manpages of pack-objects and config for more
- details.
- * Changelog added (with entries going back a bit).
-
-2008-01-28 Kevin Piche <kevin@archlinux.org>
- Version 1.5.3.7-2
- * Updated for new perl policy (vendor dirs)
- * Change license to GPL2
-
-2007-11-01 Eric Belanger <eric@archlinux.org>
- Version 1.5.3.5-2
- * Fix Perl module location
diff --git a/abs/core-testing/git/PKGBUILD b/abs/core-testing/git/PKGBUILD
deleted file mode 100644
index 5b281a2..0000000
--- a/abs/core-testing/git/PKGBUILD
+++ /dev/null
@@ -1,78 +0,0 @@
-# $Id: PKGBUILD 90230 2010-09-09 13:16:45Z dan $
-# Maintainer: Dan McGee <dan@archlinux.org>
-
-pkgname=git
-pkgver=1.7.2.3
-pkgrel=2
-pkgdesc="the fast distributed version control system"
-arch=(i686 x86_64)
-url="http://git-scm.com/"
-license=('GPL2')
-depends=('curl' 'expat>=2.0' 'perl-error' 'perl>=5.10.0')
-makedepends=('python2')
-optdepends=('tk: gitk and git gui'
- 'perl-libwww: git svn'
- 'perl-term-readkey: git svn'
- 'perl-net-smtp-ssl: git send-email TLS support'
- 'subversion: git svn'
- 'cvsps: git cvsimport')
-replaces=('git-core')
-provides=('git-core')
-backup=('etc/conf.d/git-daemon.conf')
-source=("http://kernel.org/pub/software/scm/git/${pkgname}-${pkgver}.tar.bz2" \
- "http://kernel.org/pub/software/scm/git/git-manpages-${pkgver}.tar.bz2"
- git-daemon
- git-daemon.conf)
-
-build() {
- export PYTHON_PATH='/usr/bin/python2'
- cd "$srcdir/$pkgname-$pkgver"
- make prefix=/usr gitexecdir=/usr/lib/git-core || return 1
-}
-
-package() {
- export PYTHON_PATH='/usr/bin/python2'
- cd "$srcdir/$pkgname-$pkgver"
- make prefix=/usr gitexecdir=/usr/lib/git-core \
- NO_CROSS_DIRECTORY_HARDLINKS=1 \
- INSTALLDIRS=vendor DESTDIR=${pkgdir} install || return 1
-
- # bash completion
- mkdir -p $pkgdir/etc/bash_completion.d/
- install -m644 ./contrib/completion/git-completion.bash $pkgdir/etc/bash_completion.d/git || return 1
-
- # more contrib stuff
- cp -a ./contrib $pkgdir/usr/share/git/ || return 1
-
- # scripts are for python 2.x
- find "$pkgdir" -name '*.py' | xargs sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|'
- sed -i 's|#!/usr/bin/python|#!/usr/bin/env python2|' "$pkgdir"/usr/lib/git-core/git-remote-testgit
-
- # emacs interface
- mkdir -p $pkgdir/usr/share/emacs/site-lisp
- mv $pkgdir/usr/share/git/emacs $pkgdir/usr/share/emacs/site-lisp/git
- rm $pkgdir/usr/share/emacs/site-lisp/git/.gitignore
-
- # how 'bout some manpages?
- for mansect in man1 man5 man7; do
- for manpage in $srcdir/$mansect/*; do
- install -D -m644 $manpage $pkgdir/usr/share/man/$mansect/$(basename $manpage)
- done
- done
-
- # remove perllocal.pod, .packlist, and empty directories.
- rm -rf $pkgdir/usr/lib/perl5
-
- # git daemon script
- install -D -m755 $srcdir/git-daemon $pkgdir/etc/rc.d/git-daemon
- install -D -m644 $srcdir/git-daemon.conf $pkgdir/etc/conf.d/git-daemon.conf
-}
-
-md5sums=('d88c06f6442156686deb4b4fbab0954c'
- '2ef8d3959c832347c29885627ebc0682'
- 'd777ff1a239b3d810dcf5d89f9d894af'
- '9d065134210aa0dd3f2b40d12d915040')
-sha256sums=('6139ec31d0a79cae04f469e73cc1f912162bb8f84ef7621ecc8630989fc81ba1'
- '87e00245e10472ee5acdd75bb5a6e2e89c12638b498e0df9edca6201439d47d7'
- 'd2741714a477029ca1ed63f8584040bcba6a53b2332028f9005feef4ae500113'
- '6e1475974fae315c55da344c0527923061ad7d9478d39396d147aea497f501b7')
diff --git a/abs/core-testing/git/git-daemon b/abs/core-testing/git/git-daemon
deleted file mode 100644
index 83e41a3..0000000
--- a/abs/core-testing/git/git-daemon
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/bin/bash
-
-daemon_bin="/usr/lib/git-core/git-daemon"
-daemon_name=$(basename $daemon_bin)
-PIDF="/var/run/$daemon_name.pid"
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-. /etc/conf.d/$daemon_name.conf
-
-get_pid() {
- pidof -o %PPID $daemon_name
-}
-
-case "$1" in
- start)
- stat_busy "Starting $daemon_name daemon"
-
- PID=$(get_pid)
- if [ -z "$PID" ]; then
- [ -f $PIDF ] && rm -f $PIDF
- # RUN
- $daemon_bin --pid-file=$PIDF $GIT_DAEMON_ARGS $GIT_REPO
- #
- if [ $? -gt 0 ]; then
- stat_fail
- exit 1
- else
- echo $(get_pid) > $PIDF
- add_daemon $daemon_name
- stat_done
- fi
- else
- stat_fail
- exit 1
- fi
- ;;
-
- stop)
- stat_busy "Stopping $daemon_name daemon"
- PID=$(get_pid)
- # KILL
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- #
- if [ $? -gt 0 ]; then
- stat_fail
- exit 1
- else
- rm -f $PIDF &> /dev/null
- rm_daemon $daemon_name
- stat_done
- fi
- ;;
-
- restart)
- $0 stop
- sleep 3
- $0 start
- ;;
-
- status)
- stat_busy "Checking $daemon_name status";
- ck_status $daemon_name
- ;;
-
- *)
- echo "usage: $0 {start|stop|restart|status}"
-esac
-
-exit 0
diff --git a/abs/core-testing/git/git-daemon.conf b/abs/core-testing/git/git-daemon.conf
deleted file mode 100644
index a183733..0000000
--- a/abs/core-testing/git/git-daemon.conf
+++ /dev/null
@@ -1,4 +0,0 @@
-# path to git repositories served
-GIT_REPO="/srv/git/"
-# see `man git-daemon` for all available options
-GIT_DAEMON_ARGS="--detach --syslog --verbose --base-path=$GIT_REPO"