summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/glib
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/glib')
-rw-r--r--abs/core-testing/glib/PKGBUILD32
-rw-r--r--abs/core-testing/glib/__changelog1
-rw-r--r--abs/core-testing/glib/aclocal-fixes.patch11
-rw-r--r--abs/core-testing/glib/gcc340.patch15
4 files changed, 0 insertions, 59 deletions
diff --git a/abs/core-testing/glib/PKGBUILD b/abs/core-testing/glib/PKGBUILD
deleted file mode 100644
index 42f4420..0000000
--- a/abs/core-testing/glib/PKGBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: dorphell <dorphell@archlinux.org>
-
-pkgname=glib
-pkgver=1.2.10
-pkgrel=10
-pkgdesc="Common C routines used by Gtk+ and other libs"
-arch=('i686' 'x86_64')
-url="http://www.gtk.org/"
-license=('LGPL')
-depends=('glibc')
-options=('!libtool' '!emptydirs' '!docs' )
-source=(ftp://ftp.gtk.org/pub/gtk/v1.2/$pkgname-$pkgver.tar.gz \
- gcc340.patch \
- aclocal-fixes.patch)
-md5sums=('6fe30dad87c77b91b632def29dd69ef9' '877b3330e822a4be69a0f8a8c268cfd7'\
- 'e52c4b88427b9785bb8049dbdc9ff6fb')
-sha1sums=('e5a9361c594608d152d5d9650154c2e3260b87fa'\
- 'a2cc224a66aeffdcac16ebd9e8af18143cf54918'\
- 'ae4438cf56c0c9264ee36f6973fb445f9a820be0')
-
-build() {
- cd $startdir/src/$pkgname-$pkgver
- patch -Np1 -i ../gcc340.patch || return 1
- patch -Np0 -i ../aclocal-fixes.patch || return 1
-
- #Arch64 fixes --build/host
- ./configure --prefix=/usr #--host=i686-pc-linux-gnu
- make || return 1
- make DESTDIR=$startdir/pkg install
-}
diff --git a/abs/core-testing/glib/__changelog b/abs/core-testing/glib/__changelog
deleted file mode 100644
index f2439db..0000000
--- a/abs/core-testing/glib/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-added !emptydir !docs to options
diff --git a/abs/core-testing/glib/aclocal-fixes.patch b/abs/core-testing/glib/aclocal-fixes.patch
deleted file mode 100644
index b064074..0000000
--- a/abs/core-testing/glib/aclocal-fixes.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- glib.m4.orig 2006-03-05 13:13:24.000000000 +0000
-+++ glib.m4 2006-03-05 13:13:35.000000000 +0000
-@@ -5,7 +5,7 @@
- dnl Test for GLIB, and define GLIB_CFLAGS and GLIB_LIBS, if "gmodule" or
- dnl gthread is specified in MODULES, pass to glib-config
- dnl
--AC_DEFUN(AM_PATH_GLIB,
-+AC_DEFUN([AM_PATH_GLIB],
- [dnl
- dnl Get the cflags and libraries from the glib-config script
- dnl
diff --git a/abs/core-testing/glib/gcc340.patch b/abs/core-testing/glib/gcc340.patch
deleted file mode 100644
index 941111a..0000000
--- a/abs/core-testing/glib/gcc340.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -Naur glib-1.2.10.orig/glib.h glib-1.2.10/glib.h
---- glib-1.2.10.orig/glib.h 2001-02-27 04:44:38.000000000 +0100
-+++ glib-1.2.10/glib.h 2004-05-27 15:50:32.436527848 +0200
-@@ -271,8 +271,10 @@
-
- /* Wrap the gcc __PRETTY_FUNCTION__ and __FUNCTION__ variables with
- * macros, so we can refer to them as strings unconditionally.
-+ *
-+ * Unfortunately these are _not_ treated as strings anymore in GCC3.4.
- */
--#ifdef __GNUC__
-+#if defined(__GNUC__) && (__GNUC__ == 3 && __GNUC_MINOR__ < 4)
- #define G_GNUC_FUNCTION __FUNCTION__
- #define G_GNUC_PRETTY_FUNCTION __PRETTY_FUNCTION__
- #else /* !__GNUC__ */