summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/glibc
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/glibc')
-rw-r--r--abs/core-testing/glibc/PKGBUILD138
-rw-r--r--abs/core-testing/glibc/glibc-2.10-bz4781.patch42
-rw-r--r--abs/core-testing/glibc/glibc-2.10-dont-build-timezone.patch13
-rw-r--r--abs/core-testing/glibc/glibc-__i686.patch13
-rw-r--r--abs/core-testing/glibc/glibc.install21
-rwxr-xr-xabs/core-testing/glibc/locale-gen42
-rw-r--r--abs/core-testing/glibc/locale.gen.txt23
-rwxr-xr-xabs/core-testing/glibc/nscd40
8 files changed, 0 insertions, 332 deletions
diff --git a/abs/core-testing/glibc/PKGBUILD b/abs/core-testing/glibc/PKGBUILD
deleted file mode 100644
index 673951b..0000000
--- a/abs/core-testing/glibc/PKGBUILD
+++ /dev/null
@@ -1,138 +0,0 @@
-# $Id: PKGBUILD 87193 2010-08-11 00:55:29Z allan $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Maintainer: Allan McRae <allan@archlinux.org>
-
-# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
-# NOTE: valgrind requires rebuilt with each new glibc version
-
-pkgname=glibc
-pkgver=2.12.1
-pkgrel=1
-_glibcdate=20100811
-pkgdesc="GNU C Library"
-arch=('i686' 'x86_64')
-url="http://www.gnu.org/software/libc"
-license=('GPL' 'LGPL')
-groups=('base')
-depends=('linux-api-headers>=2.6.34' 'tzdata')
-makedepends=('gcc>=4.4')
-replaces=('glibc-xen')
-backup=(etc/locale.gen
- etc/nscd.conf)
-options=('!strip')
-install=glibc.install
-source=(ftp://ftp.archlinux.org/other/glibc/${pkgname}-${pkgver}_${_glibcdate}.tar.xz
- glibc-2.10-dont-build-timezone.patch
- glibc-2.10-bz4781.patch
- glibc-__i686.patch
- nscd
- locale.gen.txt
- locale-gen)
-md5sums=('3f0d64de5a9fc5614d8acc0f1d5846ed'
- '4dadb9203b69a3210d53514bb46f41c3'
- '0c5540efc51c0b93996c51b57a8540ae'
- '40cd342e21f71f5e49e32622b25acc52'
- 'b587ee3a70c9b3713099295609afde49'
- '07ac979b6ab5eeb778d55f041529d623'
- '476e9113489f93b348b21e144b6a8fcf')
-
-mksource() {
- git clone git://sourceware.org/git/glibc.git
- pushd glibc
- git checkout -b glibc-2.12-arch origin/release/2.12/master
- popd
- tar -cvJf glibc-${pkgver}_${_glibcdate}.tar.xz glibc/*
-}
-
-build() {
- cd ${srcdir}/glibc
-
- # timezone data is in separate package (tzdata)
- patch -Np1 -i ${srcdir}/glibc-2.10-dont-build-timezone.patch
-
- # http://sources.redhat.com/bugzilla/show_bug.cgi?id=4781
- patch -Np1 -i ${srcdir}/glibc-2.10-bz4781.patch
-
- # http://sources.redhat.com/bugzilla/show_bug.cgi?id=411
- # http://sourceware.org/ml/libc-alpha/2009-07/msg00072.html
- patch -Np1 -i ${srcdir}/glibc-__i686.patch
-
- install -dm755 ${pkgdir}/etc
- touch ${pkgdir}/etc/ld.so.conf
-
- mkdir glibc-build
- cd glibc-build
-
- if [[ ${CARCH} = "i686" ]]; then
- # Hack to fix NPTL issues with Xen, only required on 32bit platforms
- export CFLAGS="${CFLAGS} -mno-tls-direct-seg-refs"
- fi
-
- echo "slibdir=/lib" >> configparms
-
- ../configure --prefix=/usr \
- --enable-add-ons=nptl,libidn --without-cvs \
- --enable-kernel=2.6.18 --disable-profile \
- --with-headers=/usr/include --libexecdir=/usr/lib \
- --enable-bind-now --with-tls --with-__thread \
- --libdir=/usr/lib --without-gd --disable-multi-arch
-
- make
-}
-
-package() {
- cd ${srcdir}/glibc/glibc-build
- make install_root=${pkgdir} install
-
- # provided by kernel-headers
- rm ${pkgdir}/usr/include/scsi/scsi.h
-
- rm ${pkgdir}/etc/ld.so.conf
-
- install -dm755 ${pkgdir}/etc/rc.d
- install -dm755 ${pkgdir}/usr/sbin
- install -dm755 ${pkgdir}/usr/lib/locale
- install -m644 ${srcdir}/glibc/nscd/nscd.conf ${pkgdir}/etc/nscd.conf
- install -m755 ${srcdir}/nscd ${pkgdir}/etc/rc.d/nscd
- install -m755 ${srcdir}/locale-gen ${pkgdir}/usr/sbin
-
- sed -i -e 's/^\tserver-user/#\tserver-user/' ${pkgdir}/etc/nscd.conf
-
- # create /etc/locale.gen
- install -m644 ${srcdir}/locale.gen.txt ${pkgdir}/etc/locale.gen
- sed -i "s|/| |g" ${srcdir}/glibc/localedata/SUPPORTED
- sed -i 's|\\| |g' ${srcdir}/glibc/localedata/SUPPORTED
- sed -i "s|SUPPORTED-LOCALES=||" ${srcdir}/glibc/localedata/SUPPORTED
- cat ${srcdir}/glibc/localedata/SUPPORTED >> ${pkgdir}/etc/locale.gen
- sed -i "s|^|#|g" ${pkgdir}/etc/locale.gen
-
- if [[ ${CARCH} = "x86_64" ]]; then
- # fix for the linker
- sed -i '/RTLDLIST/s%/ld-linux.so.2 /lib64%%' ${pkgdir}/usr/bin/ldd
- #Comply with multilib binaries, they look for the linker in /lib64
- mkdir ${pkgdir}/lib64
- cd ${pkgdir}/lib64
- ln -v -s ../lib/ld* .
- fi
-
- # manually strip files as stripping libpthread-*.so and libthread_db.so
- # with the default $STRIP_SHARED breaks gdb and stripping ld-*.so breaks
- # valgrind on x86_64
-
- cd $pkgdir
- strip $STRIP_BINARIES sbin/{ldconfig,sln} \
- usr/bin/{gencat,getconf,getent,iconv,locale} \
- usr/bin/{localedef,pcprofiledump,rpcgen,sprof} \
- usr/lib/getconf/* \
- usr/sbin/{iconvconfig,nscd,rpcinfo}
- [[ $CARCH = "i686" ]] && strip $STRIP_BINARIES usr/bin/lddlibc4
-
- strip $STRIP_STATIC usr/lib/*.a \
- lib/{{ld,libpthread}-${pkgver},libthread_db-1.0}.so
-
- strip $STRIP_SHARED lib/{libanl,libBrokenLocale,libc,libcidn,libcrypt}-${pkgver}.so \
- lib/libnss_{compat,dns,files,hesiod,nis,nisplus}-${pkgver}.so \
- lib/{libdl,libm,libnsl,libresolv,librt,libutil}-${pkgver}.so \
- lib/{libmemusage,libpcprofile,libSegFault}.so \
- usr/lib/{pt_chown,gconv/*.so}
-}
diff --git a/abs/core-testing/glibc/glibc-2.10-bz4781.patch b/abs/core-testing/glibc/glibc-2.10-bz4781.patch
deleted file mode 100644
index cf1a97a..0000000
--- a/abs/core-testing/glibc/glibc-2.10-bz4781.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -Naur glibc-old/sysdeps/unix/sysv/linux/i386/clone.S glibc/sysdeps/unix/sysv/linux/i386/clone.S
---- glibc-old/sysdeps/unix/sysv/linux/i386/clone.S 2009-05-09 13:35:30.000000000 +1000
-+++ glibc/sysdeps/unix/sysv/linux/i386/clone.S 2009-05-23 13:27:46.000000000 +1000
-@@ -120,9 +120,6 @@
- ret
-
- L(thread_start):
-- cfi_startproc;
-- /* Clearing frame pointer is insufficient, use CFI. */
-- cfi_undefined (eip);
- /* Note: %esi is zero. */
- movl %esi,%ebp /* terminate the stack frame */
- #ifdef RESET_PID
-@@ -155,7 +152,6 @@
- jmp L(haspid)
- .previous
- #endif
-- cfi_endproc;
-
- cfi_startproc
- PSEUDO_END (BP_SYM (__clone))
-diff -Naur glibc-old/sysdeps/unix/sysv/linux/x86_64/clone.S glibc/sysdeps/unix/sysv/linux/x86_64/clone.S
---- glibc-old/sysdeps/unix/sysv/linux/x86_64/clone.S 2009-05-09 13:35:30.000000000 +1000
-+++ glibc/sysdeps/unix/sysv/linux/x86_64/clone.S 2009-05-23 13:27:46.000000000 +1000
-@@ -89,9 +89,6 @@
- ret
-
- L(thread_start):
-- cfi_startproc;
-- /* Clearing frame pointer is insufficient, use CFI. */
-- cfi_undefined (rip);
- /* Clear the frame pointer. The ABI suggests this be done, to mark
- the outermost frame obviously. */
- xorl %ebp, %ebp
-@@ -116,7 +113,6 @@
- /* Call exit with return value from function call. */
- movq %rax, %rdi
- call HIDDEN_JUMPTARGET (_exit)
-- cfi_endproc;
-
- cfi_startproc;
- PSEUDO_END (BP_SYM (__clone))
diff --git a/abs/core-testing/glibc/glibc-2.10-dont-build-timezone.patch b/abs/core-testing/glibc/glibc-2.10-dont-build-timezone.patch
deleted file mode 100644
index d3abeff..0000000
--- a/abs/core-testing/glibc/glibc-2.10-dont-build-timezone.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-timezone data has been split into the package sys-libs/timezone-data
-
---- glibc-2.4/Makeconfig
-+++ glibc-2.4/Makeconfig
-@@ -931,7 +931,7 @@
- stdlib stdio-common libio malloc string wcsmbs time dirent \
- grp pwd posix io termios resource misc socket sysvipc gmon \
- gnulib iconv iconvdata wctype manual shadow gshadow po argp \
-- crypt nss localedata timezone rt conform debug \
-+ crypt nss localedata rt conform debug \
- $(add-on-subdirs) $(dlfcn) $(binfmt-subdir)
-
- ifndef avoid-generated
diff --git a/abs/core-testing/glibc/glibc-__i686.patch b/abs/core-testing/glibc/glibc-__i686.patch
deleted file mode 100644
index 28d5dd4..0000000
--- a/abs/core-testing/glibc/glibc-__i686.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -Naur glibc-old//sysdeps/i386/Makefile glibc//sysdeps/i386/Makefile
---- glibc-old//sysdeps/i386/Makefile 2010-03-18 11:52:30.000000000 +1000
-+++ glibc//sysdeps/i386/Makefile 2010-04-16 15:05:50.000000000 +1000
-@@ -1,6 +1,7 @@
- # The mpn functions need a #define for asm syntax flavor.
--# Every i386 port in use uses gas syntax (I think).
--asm-CPPFLAGS += -DGAS_SYNTAX
-+# Every i386 port in use uses gas syntax (I think). Don't replace
-+# __i686 in __i686.get_pc_thunk.bx.
-+asm-CPPFLAGS += -DGAS_SYNTAX -U __i686
-
- # The i386 `long double' is a distinct type we support.
- long-double-fcts = yes
diff --git a/abs/core-testing/glibc/glibc.install b/abs/core-testing/glibc/glibc.install
deleted file mode 100644
index 5e15c81..0000000
--- a/abs/core-testing/glibc/glibc.install
+++ /dev/null
@@ -1,21 +0,0 @@
-infodir=/usr/share/info
-filelist=(libc.info libc.info-1 libc.info-2 libc.info-3 libc.info-4 libc.info-5 libc.info-6 libc.info-7
- libc.info-8 libc.info-9 libc.info-10 libc.info-11)
-
-post_upgrade() {
- sbin/ldconfig -r .
- [ -x sbin/init ] && sbin/init u
- usr/sbin/locale-gen
-
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- usr/bin/install-info $infodir/$file.gz $infodir/dir 2> /dev/null
- done
-}
-
-pre_remove() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- usr/bin/install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
- done
-}
diff --git a/abs/core-testing/glibc/locale-gen b/abs/core-testing/glibc/locale-gen
deleted file mode 100755
index 5aff344..0000000
--- a/abs/core-testing/glibc/locale-gen
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/bin/sh
-
-set -e
-
-LOCALEGEN=/etc/locale.gen
-LOCALES=/usr/share/i18n/locales
-if [ -n "$POSIXLY_CORRECT" ]; then
- unset POSIXLY_CORRECT
-fi
-
-
-[ -f $LOCALEGEN -a -s $LOCALEGEN ] || exit 0;
-
-# Remove all old locale dir and locale-archive before generating new
-# locale data.
-rm -rf /usr/lib/locale/* || true
-
-umask 022
-
-is_entry_ok() {
- if [ -n "$locale" -a -n "$charset" ] ; then
- true
- else
- echo "error: Bad entry '$locale $charset'"
- false
- fi
-}
-
-echo "Generating locales..."
-while read locale charset; do \
- case $locale in \#*) continue;; "") continue;; esac; \
- is_entry_ok || continue
- echo -n " `echo $locale | sed 's/\([^.\@]*\).*/\1/'`"; \
- echo -n ".$charset"; \
- echo -n `echo $locale | sed 's/\([^\@]*\)\(\@.*\)*/\2/'`; \
- echo -n '...'; \
- if [ -f $LOCALES/$locale ]; then input=$locale; else \
- input=`echo $locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; fi; \
- localedef -i $input -c -f $charset -A /usr/share/locale/locale.alias $locale; \
- echo ' done'; \
-done < $LOCALEGEN
-echo "Generation complete."
diff --git a/abs/core-testing/glibc/locale.gen.txt b/abs/core-testing/glibc/locale.gen.txt
deleted file mode 100644
index ccdd817..0000000
--- a/abs/core-testing/glibc/locale.gen.txt
+++ /dev/null
@@ -1,23 +0,0 @@
-# Configuration file for locale-gen
-#
-# lists of locales that are to be generated by the locale-gen command.
-#
-# Each line is of the form:
-#
-# <locale> <charset>
-#
-# where <locale> is one of the locales given in /usr/share/i18n/locales
-# and <charset> is one of the character sets listed in /usr/share/i18n/charmaps
-#
-# Examples:
-# en_US ISO-8859-1
-# en_US.UTF-8 UTF-8
-# de_DE ISO-8859-1
-# de_DE@euro ISO-8859-15
-#
-# The locale-gen command will generate all the locales,
-# placing them in /usr/lib/locale.
-#
-# A list of supported locales is included in this file.
-# Uncomment the ones you need.
-#
diff --git a/abs/core-testing/glibc/nscd b/abs/core-testing/glibc/nscd
deleted file mode 100755
index 8b14f2a..0000000
--- a/abs/core-testing/glibc/nscd
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/sbin/nscd`
-case "$1" in
- start)
- stat_busy "Starting nscd"
- # create necessary directories if they don't already exist
- mkdir -p /var/run/nscd /var/db/nscd 2>/dev/null
- # remove stale files
- rm -f /var/db/nscd/* /var/run/nscd/* 2>/dev/null
- [ -z "$PID" ] && /usr/sbin/nscd
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon nscd
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping nscd"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon nscd
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0