summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/imlib2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/imlib2/PKGBUILD')
-rw-r--r--abs/core-testing/imlib2/PKGBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/abs/core-testing/imlib2/PKGBUILD b/abs/core-testing/imlib2/PKGBUILD
deleted file mode 100644
index 0307519..0000000
--- a/abs/core-testing/imlib2/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# $Id: PKGBUILD 79752 2010-05-06 13:39:04Z ronald $
-# Maintainer: Ronald van Haren <ronald.archlinux.org>
-# Contributor: Arjan Timmerman <arjan.archlinux.org>
-# Contributor: Tom Newsom <Jeepster.gmx.co.uk>
-
-pkgname=imlib2
-pkgver=1.4.4
-pkgrel=1
-pkgdesc="Library that does image file loading and saving as well as rendering, manipulation, arbitrary polygon support"
-url="http://sourceforge.net/projects/enlightenment/"
-arch=('i686' 'x86_64')
-license=('BSD')
-depends=('libtiff>=3.9.2-2' 'giflib' 'bzip2' 'freetype2' 'libxext' 'libpng>=1.4.0' 'libid3tag' 'libjpeg>=8')
-options=('!libtool')
-source=("http://downloads.sourceforge.net/enlightenment/$pkgname-$pkgver.tar.bz2")
-sha1sums=('aca2cf5d40ddcd8a3acfde605f319fccce7c2a2b')
-
-build() {
- cd $srcdir/$pkgname-$pkgver
-
- # disable optimizations, they cause problems (e.g. FS#12268)
- [ $CARCH = "i686" ] && EXTRAOPTS="--disable-mmx"
- [ $CARCH = "x86_64" ] && EXTRAOPTS="--disable-amd64"
-
- # Configure and Build
- ./configure --prefix=/usr \
- --sysconfdir=/etc/imlib2 \
- --x-libraries=/usr/lib $EXTRAOPTS || return 1
- make || return 1
- make DESTDIR=$pkgdir install || return 1
-
- # Install License
- install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
-}