summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/libglade
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/libglade')
-rw-r--r--abs/core-testing/libglade/PKGBUILD28
-rw-r--r--abs/core-testing/libglade/glade.install25
-rw-r--r--abs/core-testing/libglade/libglade-2.0.1-nowarning.patch39
3 files changed, 0 insertions, 92 deletions
diff --git a/abs/core-testing/libglade/PKGBUILD b/abs/core-testing/libglade/PKGBUILD
deleted file mode 100644
index 95eff9b..0000000
--- a/abs/core-testing/libglade/PKGBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# $Id: PKGBUILD 30217 2009-03-17 18:11:58Z jgc $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-
-pkgname=libglade
-pkgver=2.6.4
-pkgrel=1
-pkgdesc="Allows you to load glade interface files in a program at runtime"
-arch=(i686 x86_64)
-license=('LGPL')
-depends=('gtk2>=2.16.0' 'libxml2>=2.7.3')
-makedepends=('python' 'pkgconfig')
-optdepends=('python: libglade-convert script')
-options=('!libtool')
-install=glade.install
-source=(http://ftp.gnome.org/pub/gnome/sources/${pkgname}/2.6/${pkgname}-${pkgver}.tar.bz2
- libglade-2.0.1-nowarning.patch)
-url="http://www.gnome.org"
-md5sums=('d1776b40f4e166b5e9c107f1c8fe4139'
- '4f879c0ce550004905aa0fb24f25c353')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/libglade-2.0.1-nowarning.patch" || return 1
- ./configure --sysconfdir=/etc --prefix=/usr --localstatedir=/var || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
- install -m755 libglade-convert "${pkgdir}/usr/bin/" || return 1
-}
diff --git a/abs/core-testing/libglade/glade.install b/abs/core-testing/libglade/glade.install
deleted file mode 100644
index a7f05c5..0000000
--- a/abs/core-testing/libglade/glade.install
+++ /dev/null
@@ -1,25 +0,0 @@
-post_install() {
- if [ ! -d etc/xml ]; then
- mkdir -p etc/xml
- fi
- if [ ! -e etc/xml/catalog ]; then
- xmlcatalog --noout --create etc/xml/catalog
- fi
- xmlcatalog --noout --add "system" \
- "http://glade.gnome.org/glade-2.0.dtd" \
- /usr/share/xml/libglade/glade-2.0.dtd etc/xml/catalog
-}
-
-pre_upgrade() {
- post_remove
-}
-
-post_upgrade() {
- post_install $1
-}
-
-# arg 1: the old package version
-post_remove() {
- xmlcatalog --noout --del \
- /usr/share/xml/libglade/glade-2.0.dtd etc/xml/catalog
-}
diff --git a/abs/core-testing/libglade/libglade-2.0.1-nowarning.patch b/abs/core-testing/libglade/libglade-2.0.1-nowarning.patch
deleted file mode 100644
index fd07121..0000000
--- a/abs/core-testing/libglade/libglade-2.0.1-nowarning.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- libglade-2.0.1/glade/glade-gtk.c.nowarning 2003-08-29 14:50:10.000000000 -0400
-+++ libglade-2.0.1/glade/glade-gtk.c 2003-08-29 14:58:41.000000000 -0400
-@@ -639,9 +639,8 @@
- if (!strcmp (childinfo->properties[j].name, "label")) {
- label = childinfo->properties[j].value;
- break;
-- } else {
-- g_warning ("Unknown CList child property: %s", childinfo->properties[j].name);
- }
-+ /* Ignore all other properties */
- }
-
- if (label) {
-@@ -683,6 +682,7 @@
- char *icon = NULL;
- gboolean use_stock = FALSE, active = FALSE, new_group = FALSE;
- gboolean use_underline = FALSE;
-+ gboolean sensitive = TRUE;
- GtkWidget *iconw = NULL;
- int j;
-
-@@ -708,6 +708,8 @@
- group_name = value;
- } else if (!strcmp (name, "new_group")) {
- new_group = BOOL (value);
-+ } else if (!strcmp (name, "sensitive")) {
-+ sensitive = BOOL (value);
- } else if (!strcmp (name, "visible")) {
- /* ignore for now */
- } else if (!strcmp (name, "tooltip")) {
-@@ -785,6 +787,8 @@
- gtk_label_set_use_underline (GTK_LABEL (toolbar_child->label),
- TRUE);
- }
-+
-+ gtk_widget_set_sensitive (child, sensitive);
-
- glade_xml_set_common_params (xml, child, childinfo->child);
- } else {