summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/lighttpd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/lighttpd/PKGBUILD')
-rw-r--r--abs/core-testing/lighttpd/PKGBUILD44
1 files changed, 20 insertions, 24 deletions
diff --git a/abs/core-testing/lighttpd/PKGBUILD b/abs/core-testing/lighttpd/PKGBUILD
index db98bc4..ee4d780 100644
--- a/abs/core-testing/lighttpd/PKGBUILD
+++ b/abs/core-testing/lighttpd/PKGBUILD
@@ -1,13 +1,15 @@
+# $Id: PKGBUILD 17048 2008-10-24 16:27:19Z pierre $
+# Maintainer: Pierre Schmitz <pierre@archlinux.de>
+
pkgname=lighttpd
pkgver=1.4.20
-pkgrel=12
+pkgrel=2
pkgdesc='a secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
url="http://www.lighttpd.net/"
-#depends=('pcre' 'openssl' 'zlib' 'bzip2' 'attr' 'libldap')
-depends=('pcre' 'openssl' 'zlib' 'bzip2' 'attr' )
-makedepends=('fcgi' 'libmysqlclient' 'libxml2' 'e2fsprogs' 'sqlite3' 'gdbm' 'pkgconfig')
+depends=('pcre' 'openssl' 'zlib' 'bzip2' 'attr' 'libldap')
+makedepends=('fcgi' 'libmysqlclient' 'lua' 'libxml2' 'e2fsprogs' 'sqlite3' 'gdbm' 'pkgconfig')
optdepends=('libxml2: mod_webdav' \
'e2fsprogs: mod_webdav' \
'lua: mod_cml/mod_magnet' \
@@ -15,11 +17,10 @@ optdepends=('libxml2: mod_webdav' \
'sqlite3: mod_webdav' \
'gdbm: mod_trigger_b4_dl' \
)
-backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd' 'etc/lighttpd/auth-inc.conf')
+backup=('etc/lighttpd/lighttpd.conf' 'etc/logrotate.d/lighttpd')
options=('!libtool' 'emptydirs')
-install='lighttpd.install'
source=("http://www.lighttpd.net/download/lighttpd-${pkgver}.tar.bz2" \
- 'lighttpd.rc.d' 'lighttpd.logrotate.d' lighttpd.conf auth-inc.conf)
+ 'lighttpd.rc.d' 'lighttpd.logrotate.d')
md5sums=('ed6ee0bb714f393219a32768d86984d8'
'bd690eee0d9e51857448770a151023b0'
@@ -34,8 +35,8 @@ build() {
--localstatedir=/var \
--libdir=/usr/lib/lighttpd \
--includedir=/usr/include/lighttpd \
- --with-mysql --without-sqlite3 \
- --without-ldap \
+ --with-mysql \
+ --with-ldap \
--with-attr \
--with-openssl \
--with-kerberos5 \
@@ -44,7 +45,7 @@ build() {
--with-webdav-locks \
--with-gdbm \
--with-memcache \
- --without-lua || return 1
+ --with-lua || return 1
make || return 1
make DESTDIR=$pkgdir install || return 1
@@ -52,22 +53,17 @@ build() {
install -D -m644 ../lighttpd.logrotate.d $pkgdir/etc/logrotate.d/lighttpd
install -d -m755 -o http -g http $pkgdir/var/run/lighttpd/
install -d -m755 -o http -g http $pkgdir/var/log/lighttpd/
-
+ install -D -m644 doc/lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
# set sane defaults
- #sed -e 's|/srv/www/htdocs/|/srv/http/|' \
- # -e 's|/srv/www/|/srv/http/|' \
- # -e 's|#server.username = "wwwrun"|server.username = "http"|' \
- # -e 's|#server.groupname = "wwwrun"|server.groupname = "http"|' \
- # -e 's|#server.pid-file = "/var/run/lighttpd.pid"|server.pid-file = "/var/run/lighttpd/lighttpd.pid"|' \
- # -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
- # -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
- install -D -m644 $startdir/src/lighttpd.conf $pkgdir/etc/lighttpd/lighttpd.conf
- install -D -m644 $startdir/src/auth-inc.conf $pkgdir/etc/lighttpd/auth-inc.conf
+ sed -e 's|/srv/www/htdocs/|/srv/http/|' \
+ -e 's|/srv/www/|/srv/http/|' \
+ -e 's|#server.username = "wwwrun"|server.username = "http"|' \
+ -e 's|#server.groupname = "wwwrun"|server.groupname = "http"|' \
+ -e 's|#server.pid-file = "/var/run/lighttpd.pid"|server.pid-file = "/var/run/lighttpd/lighttpd.pid"|' \
+ -e 's|/usr/local/bin/php-cgi|/usr/bin/php-cgi|' \
+ -i ${pkgdir}/etc/lighttpd/lighttpd.conf || return 1
+
install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
}
-
-#changelog
-#remove ldap
-#add custom lighttpd.conf