summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/linhes-splash/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/linhes-splash/PKGBUILD')
-rw-r--r--abs/core-testing/linhes-splash/PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/abs/core-testing/linhes-splash/PKGBUILD b/abs/core-testing/linhes-splash/PKGBUILD
index db29493..a19575d 100644
--- a/abs/core-testing/linhes-splash/PKGBUILD
+++ b/abs/core-testing/linhes-splash/PKGBUILD
@@ -3,15 +3,27 @@
pkgname=linhes-splash
pkgver=1
-pkgrel=4
+pkgrel=5
pkgdesc="FBSplash theme for LinHES."
arch=('i686' 'x86_64')
license=('GPL2')
url="http://linhes.org/"
-source=(ftp://ftp.knoppmyth.net/R6/sources/linhes-splash.tar.bz2)
+#source=(ftp://ftp.knoppmyth.net/R6/sources/linhes-splash.tar.bz2)
+source=('1024x768.cfg' 'Vera.ttf' 'background-800x600.png' 'verbose-1024x768.png' '800x600.cfg' 'Vera.copyright' 'background-1024x768.png' 'verbose-800x600.png')
+
build() {
cd $startdir/src/
- mkdir -p $startdir/pkg/etc/splash
- cp -a linhes $startdir/pkg/etc/splash
+ mkdir -p $startdir/pkg/etc/splash/linhes/images
+ #cp -a linhes $startdir/pkg/etc/splash
+ for i in *
+ do
+ echo $i | grep -q .png
+ if [ $? = 0 ]
+ then
+ install -m755 $i $startdir/pkg/etc/splash/linhes/images/$i
+ else
+ install -m755 $i $startdir/pkg/etc/splash/linhes/$i
+ fi
+ done
}