summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mjpegtools
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/mjpegtools')
-rw-r--r--abs/core-testing/mjpegtools/1.9.patch147
-rw-r--r--abs/core-testing/mjpegtools/PKGBUILD29
-rw-r--r--abs/core-testing/mjpegtools/__changelog2
-rw-r--r--abs/core-testing/mjpegtools/mjpegtools-1.8.0-gcc41.patch12
-rw-r--r--abs/core-testing/mjpegtools/mjpegtools-1.8.0-libc.patch154
-rw-r--r--abs/core-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch30
6 files changed, 0 insertions, 374 deletions
diff --git a/abs/core-testing/mjpegtools/1.9.patch b/abs/core-testing/mjpegtools/1.9.patch
deleted file mode 100644
index ae3fc90..0000000
--- a/abs/core-testing/mjpegtools/1.9.patch
+++ /dev/null
@@ -1,147 +0,0 @@
-http://bugs.gentoo.org/200767
-http://sourceforge.net/tracker/index.php?func=detail&aid=1947059&group_id=5776&atid=305776
-
---- mjpegtools-1.9.0rc3/mpeg2enc/encodertypes.h
-+++ mjpegtools-1.9.0rc3/mpeg2enc/encodertypes.h
-@@ -25,6 +25,8 @@
- */
-
-
-+#include <stdlib.h>
-+
- class Parity
- {
- public:
---- mjpegtools-1.9.0rc3/mpeg2enc/macroblock.cc
-+++ mjpegtools-1.9.0rc3/mpeg2enc/macroblock.cc
-@@ -21,6 +21,7 @@
-
- #include <stdio.h>
- #include <cassert>
-+#include <limits.h>
-
- #include "macroblock.hh"
- #include "mpeg2syntaxcodes.h"
---- mjpegtools-1.9.0rc3/mpeg2enc/picturereader.cc
-+++ mjpegtools-1.9.0rc3/mpeg2enc/picturereader.cc
-@@ -23,6 +23,7 @@
- #include "picturereader.hh"
- #include "mpeg2encoder.hh"
- #include "imageplanes.hh"
-+#include <limits.h>
- //#include <stdio.h>
- //#include <stdlib.h>
- //#include <unistd.h>
---- mjpegtools-1.9.0rc3/mplex/inputstrm.cpp
-+++ mjpegtools-1.9.0rc3/mplex/inputstrm.cpp
-@@ -23,6 +23,7 @@
-
- #include <config.h>
- #include <assert.h>
-+#include <limits.h>
-
- #include "mjpeg_types.h"
- #include "inputstrm.hpp"
---- mjpegtools-1.9.0rc3/mplex/padstrm.cpp
-+++ mjpegtools-1.9.0rc3/mplex/padstrm.cpp
-@@ -24,6 +24,7 @@
- #include "config.h"
- #endif
-
-+#include <string.h>
- #include "padstrm.hpp"
-
-
---- mjpegtools-1.9.0rc3/mplex/multiplexor.cpp
-+++ mjpegtools-1.9.0rc3/mplex/multiplexor.cpp
-@@ -22,6 +22,7 @@
- #include <config.h>
- #include <math.h>
- #include <stdlib.h>
-+#include <string.h>
-
- #include <mjpeg_types.h>
- #include <mjpeg_logging.h>
---- mjpegtools-1.9.0rc3/mplex/main.cpp
-+++ mjpegtools-1.9.0rc3/mplex/main.cpp
-@@ -31,6 +31,7 @@
- #include <getopt.h>
- #endif
- #include <string>
-+#include <string.h>
- #include <memory>
- #include <sys/stat.h>
- #ifndef _WIN32
---- mjpegtools-1.9.0rc3/y4mdenoise/Set.hh
-+++ mjpegtools-1.9.0rc3/y4mdenoise/Set.hh
-@@ -23,7 +23,7 @@
- // How we implement ourselves.
-
- public:
-- typedef typename Imp::Allocator Allocator;
-+ typedef typename Imp::Allocator_t Allocator;
- // The type of allocator to use to allocate items in the set.
-
- Set (const PRED &a_rPred = PRED(),
---- mjpegtools-1.9.0rc3/y4mdenoise/SkipList.hh
-+++ mjpegtools-1.9.0rc3/y4mdenoise/SkipList.hh
-@@ -57,19 +57,19 @@
- // Will give good sorting for up to e^10 items.
-
- public:
-- typedef Allocator<Node,HEADERCHUNK> Allocator;
-+ typedef Allocator<Node,HEADERCHUNK> Allocator_t;
- // The type of node allocator to use.
-
-- static Allocator sm_oNodeAllocator;
-+ static Allocator_t sm_oNodeAllocator;
- // The default node allocator.
-
- SkipList (const PRED &a_rPred = PRED(),
-- Allocator &a_rAlloc = sm_oNodeAllocator);
-+ Allocator_t &a_rAlloc = sm_oNodeAllocator);
- // Default constructor. Must be followed by Init().
-
- SkipList (Status_t &a_reStatus, bool a_bAllowDuplicates,
- uint32_t a_nRandSeed, const PRED &a_rPred = PRED(),
-- Allocator &a_rAlloc = sm_oNodeAllocator);
-+ Allocator_t &a_rAlloc = sm_oNodeAllocator);
- // Constructor. Specify whether or not duplicates are allowed,
- // and provide a random number seed.
-
-@@ -255,7 +255,7 @@
-
- private:
-
-- Allocator &m_rNodeAllocator;
-+ Allocator_t &m_rNodeAllocator;
- // Where we get memory to allocate nodes.
-
- bool m_bAllowDuplicates;
-@@ -337,7 +337,7 @@
-
- // The default node allocator. Allocates 64K at a time.
- template <class KEY, class VALUE, class KEYFN, class PRED>
--typename SkipList<KEY,VALUE,KEYFN,PRED>::Allocator
-+typename SkipList<KEY,VALUE,KEYFN,PRED>::Allocator_t
- SkipList<KEY,VALUE,KEYFN,PRED>::sm_oNodeAllocator (65536);
-
-
-@@ -345,7 +345,7 @@
- // Default constructor. Must be followed by Init().
- template <class KEY, class VALUE, class KEYFN, class PRED>
- SkipList<KEY,VALUE,KEYFN,PRED>::SkipList (const PRED &a_rPred,
-- Allocator &a_rAlloc)
-+ Allocator_t &a_rAlloc)
- : m_rNodeAllocator (a_rAlloc), m_oPred (a_rPred)
- {
- // Set up some defaults.
-@@ -371,7 +371,7 @@
- template <class KEY, class VALUE, class KEYFN, class PRED>
- SkipList<KEY,VALUE,KEYFN,PRED>::SkipList (Status_t &a_reStatus,
- bool a_bAllowDuplicates, uint32_t a_nRandSeed,
-- const PRED &a_rPred, Allocator &a_rAlloc)
-+ const PRED &a_rPred, Allocator_t &a_rAlloc)
- : m_rNodeAllocator (a_rAlloc), m_oPred (a_rPred)
- {
- // Make sure they didn't start us off with an error.
diff --git a/abs/core-testing/mjpegtools/PKGBUILD b/abs/core-testing/mjpegtools/PKGBUILD
deleted file mode 100644
index 13c9061..0000000
--- a/abs/core-testing/mjpegtools/PKGBUILD
+++ /dev/null
@@ -1,29 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
-# Mantainer: Roberto Carvajal <roberto@archlinux.org>
-
-pkgname=mjpegtools
-pkgver=1.9.0
-pkgrel=11
-pkgdesc="The mjpeg programs are a set of tools that can do recording of videos and playback, simple cut-and-paste editing and the MPEG compression of audio and video under Linux. "
-arch=(i686 x86_64)
-license=('GPL')
-url="http://mjpeg.sourceforge.net/"
-depends=('libpng' 'sdl' 'gcc' 'libdv' 'libjpeg6')
-makedepends=('gtk2' 'libjpeg6')
-options=('!makeflags' '!libtool')
-source=(http://downloads.sourceforge.net/sourceforge/mjpeg/${pkgname}-${pkgver}.tar.gz
- mjpegtools-1.8.0-gcc41.patch)
-
-build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- # patch -Np1 -i ${startdir}/src/mjpegtools-1.8.0-gcc41.patch || return 1
-env CPPFLAGS="-I/opt/libjpeg6/include" LDFLAGS="-L/opt/libjpeg6/lib" ./configure --prefix=/usr --enable-static-build
- find -name Makefile -exec sed -i -e 's:-march=k8 -mtune=k8::' -e 's:-march=pentium3 -mtune=pentium3::' {} \;
-
- make || return 1
- make DESTDIR=${startdir}/pkg install
-
- install -m644 mpeg2enc/mpeg2syntaxcodes.h \
- ${startdir}/pkg/usr/include/mjpegtools/mpeg2enc/
-}
diff --git a/abs/core-testing/mjpegtools/__changelog b/abs/core-testing/mjpegtools/__changelog
deleted file mode 100644
index aa74d17..0000000
--- a/abs/core-testing/mjpegtools/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-change to build against libjpeg6
- env CPPFLAGS="-I/opt/libjpeg6/include" LDFLAGS="-L/opt/libjpeg6/lib" ./configure -
diff --git a/abs/core-testing/mjpegtools/mjpegtools-1.8.0-gcc41.patch b/abs/core-testing/mjpegtools/mjpegtools-1.8.0-gcc41.patch
deleted file mode 100644
index 77d556f..0000000
--- a/abs/core-testing/mjpegtools/mjpegtools-1.8.0-gcc41.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur mjpegtools-1.8.0-orig/y4mdenoise/Region2D.hh mjpegtools-1.8.0/y4mdenoise/Region2D.hh
---- mjpegtools-1.8.0-orig/y4mdenoise/Region2D.hh 2005-12-19 12:36:54.000000000 +0300
-+++ mjpegtools-1.8.0/y4mdenoise/Region2D.hh 2005-12-19 12:44:36.000000000 +0300
-@@ -16,7 +16,7 @@
-
- #include "Status_t.h"
- #include <iostream>
--
-+#include <cassert>
-
-
- // The 2-dimensional region class. Parameterized by the numeric type
diff --git a/abs/core-testing/mjpegtools/mjpegtools-1.8.0-libc.patch b/abs/core-testing/mjpegtools/mjpegtools-1.8.0-libc.patch
deleted file mode 100644
index 7cffada..0000000
--- a/abs/core-testing/mjpegtools/mjpegtools-1.8.0-libc.patch
+++ /dev/null
@@ -1,154 +0,0 @@
-diff -Naur mjpegtools-1.8.0.orig/mpeg2enc/encodertypes.h mjpegtools-1.8.0/mpeg2enc/encodertypes.h
---- mjpegtools-1.8.0.orig/mpeg2enc/encodertypes.h 2008-12-10 10:57:56.000000000 -0600
-+++ mjpegtools-1.8.0/mpeg2enc/encodertypes.h 2008-12-10 11:02:08.000000000 -0600
-@@ -26,7 +26,7 @@
-
- #include "config.h"
-
--
-+#include <stdlib.h>
-
- class Parity
- {
-diff -Naur mjpegtools-1.8.0.orig/mpeg2enc/macroblock.cc mjpegtools-1.8.0/mpeg2enc/macroblock.cc
---- mjpegtools-1.8.0.orig/mpeg2enc/macroblock.cc 2008-12-10 10:57:56.000000000 -0600
-+++ mjpegtools-1.8.0/mpeg2enc/macroblock.cc 2008-12-10 11:02:41.000000000 -0600
-@@ -20,6 +20,7 @@
- */
-
- #include <stdio.h>
-+#include <limits.h>
-
- #include "macroblock.hh"
- #include "mpeg2syntaxcodes.h"
-diff -Naur mjpegtools-1.8.0.orig/mpeg2enc/picturereader.cc mjpegtools-1.8.0/mpeg2enc/picturereader.cc
---- mjpegtools-1.8.0.orig/mpeg2enc/picturereader.cc 2008-12-10 10:57:56.000000000 -0600
-+++ mjpegtools-1.8.0/mpeg2enc/picturereader.cc 2008-12-10 11:03:04.000000000 -0600
-@@ -25,6 +25,7 @@
- #include <stdlib.h>
- #include <unistd.h>
- #include <string.h>
-+#include <limits.h>
- #include <errno.h>
- #include "simd.h"
- #include "mpeg2encoder.hh"
-diff -Naur mjpegtools-1.8.0.orig/mplex/inputstrm.cpp mjpegtools-1.8.0/mplex/inputstrm.cpp
---- mjpegtools-1.8.0.orig/mplex/inputstrm.cpp 2008-12-10 10:58:55.000000000 -0600
-+++ mjpegtools-1.8.0/mplex/inputstrm.cpp 2008-12-10 11:03:36.000000000 -0600
-@@ -23,6 +23,7 @@
-
- #include <config.h>
- #include <assert.h>
-+#include <limits.h>
-
- #include "mjpeg_types.h"
- #include "inputstrm.hpp"
-diff -Naur mjpegtools-1.8.0.orig/mplex/padstrm.cpp mjpegtools-1.8.0/mplex/padstrm.cpp
---- mjpegtools-1.8.0.orig/mplex/padstrm.cpp 2008-12-10 10:58:55.000000000 -0600
-+++ mjpegtools-1.8.0/mplex/padstrm.cpp 2008-12-10 11:04:06.000000000 -0600
-@@ -24,6 +24,7 @@
- #include "config.h"
- #endif
-
-+#include <string.h>
- #include "padstrm.hpp"
-
-
-diff -Naur mjpegtools-1.8.0.orig/mplex/multiplexor.cpp mjpegtools-1.8.0/mplex/multiplexor.cpp
---- mjpegtools-1.8.0.orig/mplex/multiplexor.cpp 2008-12-10 10:58:55.000000000 -0600
-+++ mjpegtools-1.8.0/mplex/multiplexor.cpp 2008-12-10 11:04:53.000000000 -0600
-@@ -22,6 +22,7 @@
- #include <config.h>
- #include <math.h>
- #include <stdlib.h>
-+#include <string.h>
-
- #include <mjpeg_types.h>
- #include <mjpeg_logging.h>
-diff -Naur mjpegtools-1.8.0.orig/mplex/main.cpp mjpegtools-1.8.0/mplex/main.cpp
---- mjpegtools-1.8.0.orig/mplex/main.cpp 2008-12-10 10:58:55.000000000 -0600
-+++ mjpegtools-1.8.0/mplex/main.cpp 2008-12-10 11:05:20.000000000 -0600
-@@ -31,6 +31,7 @@
- #include <getopt.h>
- #endif
- #include <string>
-+#include <string.h>
- #include <memory>
- #include <sys/stat.h>
- #ifndef _WIN32
-diff -Naur mjpegtools-1.8.0.orig/y4mdenoise/Set.hh mjpegtools-1.8.0/y4mdenoise/Set.hh
---- mjpegtools-1.8.0.orig/y4mdenoise/Set.hh 2008-12-10 11:00:49.000000000 -0600
-+++ mjpegtools-1.8.0/y4mdenoise/Set.hh 2008-12-10 11:06:30.000000000 -0600
-@@ -23,7 +23,7 @@
- // How we implement ourselves.
-
- public:
-- typedef typename Imp::Allocator Allocator;
-+ typedef typename Imp::Allocator_t Allocator;
- // The type of allocator to use to allocate items in the set.
-
- Set (const PRED &a_rPred = PRED(),
-diff -Naur mjpegtools-1.8.0.orig/y4mdenoise/SkipList.hh mjpegtools-1.8.0/y4mdenoise/SkipList.hh
---- mjpegtools-1.8.0.orig/y4mdenoise/SkipList.hh 2008-12-10 11:00:49.000000000 -0600
-+++ mjpegtools-1.8.0/y4mdenoise/SkipList.hh 2008-12-10 11:09:34.000000000 -0600
-@@ -57,19 +57,19 @@
- // Will give good sorting for up to e^10 items.
-
- public:
-- typedef Allocator<Node,HEADERCHUNK> Allocator;
-+ typedef Allocator<Node,HEADERCHUNK> Allocator_t;
- // The type of node allocator to use.
-
-- static Allocator sm_oNodeAllocator;
-+ static Allocator_t sm_oNodeAllocator;
- // The default node allocator.
-
- SkipList (const PRED &a_rPred = PRED(),
-- Allocator &a_rAlloc = sm_oNodeAllocator);
-+ Allocator_t &a_rAlloc = sm_oNodeAllocator);
- // Default constructor. Must be followed by Init().
-
- SkipList (Status_t &a_reStatus, bool a_bAllowDuplicates,
- uint32_t a_nRandSeed, const PRED &a_rPred = PRED(),
-- Allocator &a_rAlloc = sm_oNodeAllocator);
-+ Allocator_t &a_rAlloc = sm_oNodeAllocator);
- // Constructor. Specify whether or not duplicates are allowed,
- // and provide a random number seed.
-
-@@ -255,7 +255,7 @@
-
- private:
-
-- Allocator &m_rNodeAllocator;
-+ Allocator_t &m_rNodeAllocator;
- // Where we get memory to allocate nodes.
-
- bool m_bAllowDuplicates;
-@@ -337,7 +337,7 @@
-
- // The default node allocator. Allocates 64K at a time.
- template <class KEY, class VALUE, class KEYFN, class PRED>
--typename SkipList<KEY,VALUE,KEYFN,PRED>::Allocator
-+typename SkipList<KEY,VALUE,KEYFN,PRED>::Allocator_t
- SkipList<KEY,VALUE,KEYFN,PRED>::sm_oNodeAllocator (65536);
-
-
-@@ -345,7 +345,7 @@
- // Default constructor. Must be followed by Init().
- template <class KEY, class VALUE, class KEYFN, class PRED>
- SkipList<KEY,VALUE,KEYFN,PRED>::SkipList (const PRED &a_rPred,
-- Allocator &a_rAlloc)
-+ Allocator_t &a_rAlloc)
- : m_rNodeAllocator (a_rAlloc), m_oPred (a_rPred)
- {
- // Set up some defaults.
-@@ -371,7 +371,7 @@
- template <class KEY, class VALUE, class KEYFN, class PRED>
- SkipList<KEY,VALUE,KEYFN,PRED>::SkipList (Status_t &a_reStatus,
- bool a_bAllowDuplicates, uint32_t a_nRandSeed,
-- const PRED &a_rPred, Allocator &a_rAlloc)
-+ const PRED &a_rPred, Allocator_t &a_rAlloc)
- : m_rNodeAllocator (a_rAlloc), m_oPred (a_rPred)
- {
- // Make sure they didn't start us off with an error.
-
diff --git a/abs/core-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch b/abs/core-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch
deleted file mode 100644
index 41a59ca..0000000
--- a/abs/core-testing/mjpegtools/mjpegtools-1.8.0-limits.h.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- mjpegtools-1.8.0.orig/mpeg2enc/macroblock.cc 2007-11-29 19:45:06 +0000
-+++ mjpegtools-1.8.0.orig/mpeg2enc/macroblock.cc 2007-11-29 19:45:33 +0000
-@@ -20,6 +20,7 @@
- */
-
- #include <stdio.h>
-+#include <limits.h>
-
- #include "macroblock.hh"
- #include "mpeg2syntaxcodes.h"
---- mjpegtools-1.8.0.orig/mpeg2enc/picturereader.cc 2007-11-29 19:45:06 +0000
-+++ mjpegtools-1.8.0.orig/mpeg2enc/picturereader.cc 2007-11-29 19:45:52 +0000
-@@ -26,6 +26,7 @@
- #include <unistd.h>
- #include <string.h>
- #include <errno.h>
-+#include <limits.h>
- #include "simd.h"
- #include "mpeg2encoder.hh"
-
---- mjpegtools-1.8.0.orig/mplex/inputstrm.cpp 2007-11-29 19:45:06 +0000
-+++ mjpegtools-1.8.0.orig/mplex/inputstrm.cpp 2007-11-29 19:46:15 +0000
-@@ -23,6 +23,7 @@
-
- #include <config.h>
- #include <assert.h>
-+#include <limits.h>
-
- #include "mjpeg_types.h"
- #include "inputstrm.hpp"