summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable-0.23/mythmovies/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/mythtv/stable-0.23/mythmovies/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/stable-0.23/mythmovies/PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/stable-0.23/mythmovies/PKGBUILD b/abs/core-testing/mythtv/stable-0.23/mythmovies/PKGBUILD
new file mode 100644
index 0000000..dd8cc34
--- /dev/null
+++ b/abs/core-testing/mythtv/stable-0.23/mythmovies/PKGBUILD
@@ -0,0 +1,48 @@
+pkgname=mythmovies
+pkgver=0.23
+pkgrel=1
+pkgdesc="Displays information about movies playing in the area."
+url="http://www.mythtv.org"
+license="GPL"
+arch=('i686' 'x86_64')
+
+depends=('mythtv>=0.23')
+conflicts=('mythmovies')
+groups=('mythtv-extras')
+
+patches=()
+source=('ftp://ftp.knoppmyth.net/R6/sources/mythplugins-0.23-fixes.tar.bz2' `echo ${patches[@]:0}`)
+
+md5sums=('590c6e72c72e10d4c7edf72d7fb6b940')
+
+build() {
+
+ cd $startdir/src/mythplugins
+ svn update
+
+ echo "--------------------------applying patches----------------------------------------------------"
+ for i in `echo ${patches[@]:0} `
+ do
+ echo applying $i
+ echo "-----------------------------"
+ patch -Np0 -i ${startdir}/src/$i || return 1
+ done
+ echo "--------------------------done applying patches-----------------------------------------------"
+
+ [ "$CARCH" = "i686" ] && ARCH="i686"
+ [ "$CARCH" = "x86_64" ] && ARCH="x86-64"
+
+ # clean up
+ make distclean
+
+ # configure
+ ./configure --prefix=/usr --cpu=${ARCH} --disable-all --enable-opengl \
+ --enable-mythmovies || return 1
+
+ # build and install
+ . /etc/profile
+ make || return 1
+ make INSTALL_ROOT=$startdir/pkg install || return 1
+
+}
+