summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD b/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
new file mode 100644
index 0000000..52fb732
--- /dev/null
+++ b/abs/core-testing/mythtv/trunk/mythgallery/PKGBUILD
@@ -0,0 +1,36 @@
+pkgname=mythgallery-svn
+pkgver=16153
+pkgrel=3
+pkgdesc="Image gallery plugin for MythTV"
+url="http://www.mythtv.org"
+arch=('i686')
+depends=('mythtv-svn' 'libexif' 'libtiff')
+conflicts=('mythtv-plugins-svn')
+groups=('mythtv-all-plugins-svn')
+license="GPL"
+source=()
+_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
+_svnmod=mythplugins
+
+
+build() {
+ cd $startdir/src/
+ echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ cd $startdir/src/mythplugins
+ export QMAKESPEC='linux-g++'
+ PLUGIN=mythgallery
+ grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
+ if [ $? != 0 ]
+ then
+ echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
+ msg "appending program lib"
+ fi
+ make distclean
+ ./configure --disable-all --enable-opengl --enable-mythgallery --enable-exif
+
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+