summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/net-tools
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/net-tools')
-rw-r--r--abs/core-testing/net-tools/PKGBUILD36
-rw-r--r--abs/core-testing/net-tools/gcc340.patch46
-rw-r--r--abs/core-testing/net-tools/net-tools-1.60-2.6-compilefix.patch23
-rw-r--r--abs/core-testing/net-tools/net-tools-1.60-miiioctl.patch17
-rw-r--r--abs/core-testing/net-tools/net-tools-1.60-nameif.patch58
-rw-r--r--abs/core-testing/net-tools/net-tools-1.60-nameif_strncpy.patch13
-rw-r--r--abs/core-testing/net-tools/net-tools.patch52
-rw-r--r--abs/core-testing/net-tools/nisdomainname.conf.d3
8 files changed, 0 insertions, 248 deletions
diff --git a/abs/core-testing/net-tools/PKGBUILD b/abs/core-testing/net-tools/PKGBUILD
deleted file mode 100644
index da2a710..0000000
--- a/abs/core-testing/net-tools/PKGBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: judd <jvinet@zeroflux.org>
-pkgname=net-tools
-pkgver=1.60
-pkgrel=22
-pkgdesc="Configuration tools for Linux networking"
-arch=(i686 x86_64)
-license=('GPL')
-url="http://www.tazenda.demon.co.uk/phil/net-tools"
-groups=('base')
-depends=('glibc')
-backup=('etc/conf.d/nisdomainname')
-source=(http://www.tazenda.demon.co.uk/phil/$pkgname/$pkgname-$pkgver.tar.bz2
- net-tools.patch gcc340.patch net-tools-1.60-2.6-compilefix.patch
- net-tools-1.60-miiioctl.patch nisdomainname.conf.d
- net-tools-1.60-nameif.patch
- net-tools-1.60-nameif_strncpy.patch)
-md5sums=('888774accab40217dde927e21979c165' '7ef8d0c6818faa0fdeea94970a20e3fb'
- 'b52d899cba9956bb0055150506f41ac1' '51de6eabe2d6d6dc860f72c41cee636b'
- 'c16109863bc63f3dad4ef35305a340bb' 'af3eef5d4837939f7858eec692aa4671'
- '29a32617382fab1735acba4d920f1fcd' 'e66466b9304dac85eb42b32f1ec3b284')
-
-build() {
- cd $startdir/src/$pkgname-$pkgver
- export MAKEFLAGS="-j1"
- patch -Np1 -i ../net-tools.patch || return 1
- patch -Np1 -i ../net-tools-1.60-2.6-compilefix.patch || return 1
- patch -Np1 -i ../net-tools-1.60-miiioctl.patch || return 1
- patch -Np1 -i ../gcc340.patch || return 1
- patch -Np1 -i ${startdir}/src/net-tools-1.60-nameif.patch || return 1
- patch -Np1 -i ${startdir}/src/net-tools-1.60-nameif_strncpy.patch || return 1
- yes "" | make || return 1
- make BASEDIR=$startdir/pkg update
- install -D -m644 ../nisdomainname.conf.d \
- $startdir/pkg/etc/conf.d/nisdomainname
-}
diff --git a/abs/core-testing/net-tools/gcc340.patch b/abs/core-testing/net-tools/gcc340.patch
deleted file mode 100644
index 8089bf2..0000000
--- a/abs/core-testing/net-tools/gcc340.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -Naur net-tools-1.60-orig/hostname.c net-tools-1.60/hostname.c
---- net-tools-1.60-orig/hostname.c 2001-04-08 10:04:23.000000000 -0700
-+++ net-tools-1.60/hostname.c 2004-05-07 17:22:14.000000000 -0700
-@@ -78,6 +78,7 @@
- fprintf(stderr, _("%s: name too long\n"), program_name);
- break;
- default:
-+ ;
- }
- exit(1);
- }
-@@ -98,6 +99,7 @@
- fprintf(stderr, _("%s: name too long\n"), program_name);
- break;
- default:
-+ ;
- }
- exit(1);
- };
-@@ -117,6 +119,7 @@
- fprintf(stderr, _("%s: name too long\n"), program_name);
- break;
- default:
-+ ;
- }
- exit(1);
- };
-@@ -174,6 +177,7 @@
- printf("%s\n", hp->h_name);
- break;
- default:
-+ ;
- }
- }
-
-diff -Naur net-tools-1.60-orig/lib/inet_sr.c net-tools-1.60/lib/inet_sr.c
---- net-tools-1.60-orig/lib/inet_sr.c 2000-02-20 13:46:45.000000000 -0800
-+++ net-tools-1.60/lib/inet_sr.c 2004-05-07 17:20:14.000000000 -0700
-@@ -105,6 +105,7 @@
- case 2:
- isnet = 0; break;
- default:
-+ ;
- }
-
- /* Fill in the other fields. */
diff --git a/abs/core-testing/net-tools/net-tools-1.60-2.6-compilefix.patch b/abs/core-testing/net-tools/net-tools-1.60-2.6-compilefix.patch
deleted file mode 100644
index 92ce901..0000000
--- a/abs/core-testing/net-tools/net-tools-1.60-2.6-compilefix.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -ruN net-tools-1.60.orig/lib/x25_sr.c net-tools-1.60/lib/x25_sr.c
---- net-tools-1.60.orig/lib/x25_sr.c 2000-05-20 15:38:10.000000000 +0200
-+++ net-tools-1.60/lib/x25_sr.c 2003-10-18 20:33:31.927574928 +0200
-@@ -22,6 +22,7 @@
- #include <sys/socket.h>
- #include <sys/ioctl.h>
- #include <linux/x25.h>
-+#include <linux/version.h>
- #include <ctype.h>
- #include <errno.h>
- #include <netdb.h>
-@@ -77,7 +78,11 @@
- rt.sigdigits=sigdigits;
-
- /* x25_route_struct.address isn't type struct sockaddr_x25, Why? */
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
- memcpy(&rt.address, &sx25.sx25_addr, sizeof(x25_address));
-+#else
-+ memcpy(&rt.address, &sx25.sx25_addr, sizeof(struct x25_address));
-+#endif
-
- while (*args) {
- if (!strcmp(*args,"device") || !strcmp(*args,"dev")) {
diff --git a/abs/core-testing/net-tools/net-tools-1.60-miiioctl.patch b/abs/core-testing/net-tools/net-tools-1.60-miiioctl.patch
deleted file mode 100644
index 4859273..0000000
--- a/abs/core-testing/net-tools/net-tools-1.60-miiioctl.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- net-tools-1.60/include/mii.h.bar Tue Jul 31 11:49:39 2001
-+++ net-tools-1.60/include/mii.h Tue Jul 31 11:49:33 2001
-@@ -11,11 +11,9 @@
-
- /* network interface ioctl's for MII commands */
- #ifndef SIOCGMIIPHY
--#define SIOCGMIIPHY (SIOCDEVPRIVATE) /* Read from current PHY */
--#define SIOCGMIIREG (SIOCDEVPRIVATE+1) /* Read any PHY register */
--#define SIOCSMIIREG (SIOCDEVPRIVATE+2) /* Write any PHY register */
--#define SIOCGPARAMS (SIOCDEVPRIVATE+3) /* Read operational parameters */
--#define SIOCSPARAMS (SIOCDEVPRIVATE+4) /* Set operational parameters */
-+#define SIOCGMIIPHY 0x8947 /* Read from current PHY */
-+#define SIOCGMIIREG 0x8948 /* Read any PHY register */
-+#define SIOCSMIIREG 0x8949 /* Write any PHY register */
- #endif
-
- #include <linux/types.h>
diff --git a/abs/core-testing/net-tools/net-tools-1.60-nameif.patch b/abs/core-testing/net-tools/net-tools-1.60-nameif.patch
deleted file mode 100644
index 54def00..0000000
--- a/abs/core-testing/net-tools/net-tools-1.60-nameif.patch
+++ /dev/null
@@ -1,58 +0,0 @@
---- net-tools-1.60/nameif.c.nameif 2000-10-18 19:26:29.000000000 +0200
-+++ net-tools-1.60/nameif.c 2003-03-19 11:02:01.000000000 +0100
-@@ -117,7 +117,8 @@
- }
-
- struct change {
-- struct change *next,**pprev;
-+ struct change *next;
-+ int found;
- char ifname[IFNAMSIZ+1];
- unsigned char mac[6];
- };
-@@ -139,10 +140,7 @@
- ch->ifname, pos);
- if (parsemac(p,ch->mac) < 0)
- complain(_("cannot parse MAC `%s' at %s"), p, pos);
-- if (clist)
-- clist->pprev = &ch->next;
- ch->next = clist;
-- ch->pprev = &clist;
- clist = ch;
- return 0;
- }
-@@ -200,7 +198,7 @@
-
- void usage(void)
- {
-- fprintf(stderr, _("usage: nameif [-c configurationfile] [-s] {ifname macaddress}"));
-+ fprintf(stderr, _("usage: nameif [-c configurationfile] [-s] {ifname macaddress}\n"));
- exit(1);
- }
-
-@@ -277,21 +275,21 @@
- ch = lookupmac(mac);
- if (!ch)
- continue;
--
-- *ch->pprev = ch->next;
-+
-+ ch->found = 1;
- if (strcmp(p, ch->ifname)) {
- if (setname(p, ch->ifname) < 0)
- complain(_("cannot change name of %s to %s: %s"),
- p, ch->ifname, strerror(errno));
- }
-- free(ch);
- }
- fclose(ifh);
-
- while (clist) {
- struct change *ch = clist;
- clist = clist->next;
-- warning(_("interface '%s' not found"), ch->ifname);
-+ if (!ch->found)
-+ warning(_("interface '%s' not found"), ch->ifname);
- free(ch);
- }
-
diff --git a/abs/core-testing/net-tools/net-tools-1.60-nameif_strncpy.patch b/abs/core-testing/net-tools/net-tools-1.60-nameif_strncpy.patch
deleted file mode 100644
index 7568e21..0000000
--- a/abs/core-testing/net-tools/net-tools-1.60-nameif_strncpy.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- net-tools-1.60/nameif.c.ncpy 2006-10-03 14:24:21.000000000 +0200
-+++ net-tools-1.60/nameif.c 2006-10-03 14:22:43.000000000 +0200
-@@ -100,8 +100,8 @@
- struct ifreq ifr;
- opensock();
- memset(&ifr,0,sizeof(struct ifreq));
-- strcpy(ifr.ifr_name, oldname);
-- strcpy(ifr.ifr_newname, newname);
-+ strncpy(ifr.ifr_name, oldname, IF_NAMESIZE);
-+ strncpy(ifr.ifr_newname, newname, IF_NAMESIZE);
- return ioctl(ctl_sk, SIOCSIFNAME, &ifr);
- }
-
diff --git a/abs/core-testing/net-tools/net-tools.patch b/abs/core-testing/net-tools/net-tools.patch
deleted file mode 100644
index 87e062e..0000000
--- a/abs/core-testing/net-tools/net-tools.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff -Naur net-tools-1.60-orig/config.in net-tools-1.60/config.in
---- net-tools-1.60-orig/config.in 2000-05-21 07:32:12.000000000 -0700
-+++ net-tools-1.60/config.in 2004-05-31 12:36:00.000000000 -0700
-@@ -49,7 +49,7 @@
- *
- bool 'UNIX protocol family' HAVE_AFUNIX y
- bool 'INET (TCP/IP) protocol family' HAVE_AFINET y
--bool 'INET6 (IPv6) protocol family' HAVE_AFINET6 n
-+bool 'INET6 (IPv6) protocol family' HAVE_AFINET6 y
- bool 'Novell IPX/SPX protocol family' HAVE_AFIPX y
- bool 'Appletalk DDP protocol family' HAVE_AFATALK y
- bool 'AX25 (packet radio) protocol family' HAVE_AFAX25 y
-@@ -86,6 +86,6 @@
- *
- * Other Features.
- *
--bool 'IP Masquerading support' HAVE_FW_MASQUERADE n
--bool 'Build iptunnel and ipmaddr' HAVE_IP_TOOLS n
--bool 'Build mii-tool' HAVE_MII n
-+bool 'IP Masquerading support' HAVE_FW_MASQUERADE y
-+bool 'Build iptunnel and ipmaddr' HAVE_IP_TOOLS y
-+bool 'Build mii-tool' HAVE_MII y
-diff -Naur net-tools-1.60-orig/mii-tool.c net-tools-1.60/mii-tool.c
---- net-tools-1.60-orig/mii-tool.c 2000-05-21 07:31:17.000000000 -0700
-+++ net-tools-1.60/mii-tool.c 2004-05-31 12:35:21.000000000 -0700
-@@ -379,16 +379,16 @@
- /*--------------------------------------------------------------------*/
-
- const char *usage =
--"usage: %s [-VvRrwl] [-A media,... | -F media] [interface ...]
-- -V, --version display version information
-- -v, --verbose more verbose output
-- -R, --reset reset MII to poweron state
-- -r, --restart restart autonegotiation
-- -w, --watch monitor for link status changes
-- -l, --log with -w, write events to syslog
-- -A, --advertise=media,... advertise only specified media
-- -F, --force=media force specified media technology
--media: 100baseT4, 100baseTx-FD, 100baseTx-HD, 10baseT-FD, 10baseT-HD,
-+"usage: %s [-VvRrwl] [-A media,... | -F media] [interface ...]\n\
-+ -V, --version display version information\n\
-+ -v, --verbose more verbose output\n\
-+ -R, --reset reset MII to poweron state\n\
-+ -r, --restart restart autonegotiation\n\
-+ -w, --watch monitor for link status changes\n\
-+ -l, --log with -w, write events to syslog\n\
-+ -A, --advertise=media,... advertise only specified media\n\
-+ -F, --force=media force specified media technology\n\
-+media: 100baseT4, 100baseTx-FD, 100baseTx-HD, 10baseT-FD, 10baseT-HD,\n\
- (to advertise both HD and FD) 100baseTx, 10baseT\n";
-
- int main(int argc, char **argv)
diff --git a/abs/core-testing/net-tools/nisdomainname.conf.d b/abs/core-testing/net-tools/nisdomainname.conf.d
deleted file mode 100644
index 6033ecf..0000000
--- a/abs/core-testing/net-tools/nisdomainname.conf.d
+++ /dev/null
@@ -1,3 +0,0 @@
-# Set your NIS domain name here
-NISDOMAINNAME=""
-