summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/openexr
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/openexr')
-rw-r--r--abs/core-testing/openexr/PKGBUILD23
-rw-r--r--abs/core-testing/openexr/gcc43.patch22
-rw-r--r--abs/core-testing/openexr/openexr-gcc4.patch11
3 files changed, 0 insertions, 56 deletions
diff --git a/abs/core-testing/openexr/PKGBUILD b/abs/core-testing/openexr/PKGBUILD
deleted file mode 100644
index c71f10b..0000000
--- a/abs/core-testing/openexr/PKGBUILD
+++ /dev/null
@@ -1,23 +0,0 @@
-# $Id: PKGBUILD 17480 2008-10-30 16:52:29Z pierre $
-# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
-
-pkgname=openexr
-pkgver=1.6.1
-pkgrel=1
-depends=('zlib' 'ilmbase')
-pkgdesc="openexr library for EXR images"
-arch=(i686 x86_64)
-options=('!libtool')
-license=('custom')
-source=("http://savannah.nongnu.org/download/$pkgname/$pkgname-$pkgver.tar.gz" 'gcc43.patch')
-url="http://www.openexr.org"
-md5sums=('11951f164f9c872b183df75e66de145a' '7c83ee3d69ad688142e7de63cb68e70a')
-
-build() {
- cd $startdir/src/$pkgname-$pkgver
- patch -p1 -i $srcdir/gcc43.patch || return 1
- ./configure --prefix=/usr
- make || return 1
- make DESTDIR=$startdir/pkg install
- install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
-}
diff --git a/abs/core-testing/openexr/gcc43.patch b/abs/core-testing/openexr/gcc43.patch
deleted file mode 100644
index 3624872..0000000
--- a/abs/core-testing/openexr/gcc43.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Nura openexr-1.6.1/exrenvmap/main.cpp openexr-1.6.1.new/exrenvmap/main.cpp
---- openexr-1.6.1/exrenvmap/main.cpp 2007-04-25 03:07:51.000000000 +0200
-+++ openexr-1.6.1.new/exrenvmap/main.cpp 2008-10-30 17:18:13.000000000 +0100
-@@ -45,6 +45,7 @@
- #include <iostream>
- #include <exception>
- #include <stdlib.h>
-+#include <string.h>
-
- using namespace Imf;
- using namespace std;
-diff -Nura openexr-1.6.1/exrmaketiled/main.cpp openexr-1.6.1.new/exrmaketiled/main.cpp
---- openexr-1.6.1/exrmaketiled/main.cpp 2007-04-25 03:08:45.000000000 +0200
-+++ openexr-1.6.1.new/exrmaketiled/main.cpp 2008-10-30 17:18:40.000000000 +0100
-@@ -46,6 +46,7 @@
- #include <exception>
- #include <string>
- #include <stdlib.h>
-+#include <string.h>
-
- using namespace Imf;
- using namespace std;
diff --git a/abs/core-testing/openexr/openexr-gcc4.patch b/abs/core-testing/openexr/openexr-gcc4.patch
deleted file mode 100644
index ff63681..0000000
--- a/abs/core-testing/openexr/openexr-gcc4.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- OpenEXR-1.2.2/exrmaketiled/Image.h~ 2004-06-04 06:11:23.000000000 +0200
-+++ OpenEXR-1.2.2/exrmaketiled/Image.h 2005-07-15 07:02:08.000000000 +0200
-@@ -50,6 +50,8 @@
- #include <map>
-
-
-+class Image;
-+
- class ImageChannel
- {
- public: