summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/openssh
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/openssh')
-rw-r--r--abs/core-testing/openssh/PKGBUILD64
-rwxr-xr-xabs/core-testing/openssh/sshd41
-rw-r--r--abs/core-testing/openssh/sshd.confd4
-rw-r--r--abs/core-testing/openssh/sshd.pam10
4 files changed, 0 insertions, 119 deletions
diff --git a/abs/core-testing/openssh/PKGBUILD b/abs/core-testing/openssh/PKGBUILD
deleted file mode 100644
index 36a82bd..0000000
--- a/abs/core-testing/openssh/PKGBUILD
+++ /dev/null
@@ -1,64 +0,0 @@
-# $Id: PKGBUILD 89278 2010-08-30 21:38:00Z thomas $
-# Maintainer: Aaron Griffin <aaron@archlinux.org>
-# Contributor: judd <jvinet@zeroflux.org>
-
-pkgname=openssh
-pkgver=5.6p1
-pkgrel=1
-pkgdesc='A Secure SHell server/client'
-arch=('i686' 'x86_64')
-license=('custom')
-url="http://www.openssh.org/portable.html"
-backup=('etc/ssh/ssh_config' 'etc/ssh/sshd_config' 'etc/pam.d/sshd')
-depends=('openssl' 'zlib' 'pam' 'tcp_wrappers' 'heimdal')
-source=("ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/${pkgname}-${pkgver}.tar.gz"
- 'sshd' 'sshd.confd' 'sshd.pam')
-md5sums=('e6ee52e47c768bf0ec42a232b5d18fb0'
- '17b1b1bf0f578a55945ee204bd4462af'
- 'e2cea70ac13af7e63d40eb04415eacd5'
- '1c7c2ea8734ec7e3ca58d820634dc73a')
-
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- #NOTE we disable-strip so that makepkg can decide whether to strip or not
- ./configure --prefix=/usr --libexecdir=/usr/lib/ssh \
- --sysconfdir=/etc/ssh --with-tcp-wrappers --with-privsep-user=nobody \
- --with-md5-passwords --with-pam --with-mantype=man --mandir=/usr/share/man \
- --with-xauth=/usr/bin/xauth --with-kerberos5=/usr --with-ssl-engine \
- --disable-strip
- make || return 1
-}
-
-package() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make DESTDIR=${pkgdir} install
-
- install -Dm755 ${srcdir}/sshd ${pkgdir}/etc/rc.d/sshd
-
- install -Dm644 LICENCE ${pkgdir}/usr/share/licenses/${pkgname}/LICENCE
- install -Dm644 ${srcdir}/sshd.pam ${pkgdir}/etc/pam.d/sshd
- install -Dm644 ${srcdir}/sshd.confd ${pkgdir}/etc/conf.d/sshd
-
- rm ${pkgdir}/usr/share/man/man1/slogin.1
- ln -sf ssh.1.gz ${pkgdir}/usr/share/man/man1/slogin.1.gz
-
- #additional contrib scripts that we like
- install -Dm755 contrib/findssl.sh ${pkgdir}/usr/bin/findssl.sh
- install -Dm755 contrib/ssh-copy-id ${pkgdir}/usr/bin/ssh-copy-id
- install -Dm644 contrib/ssh-copy-id.1 ${pkgdir}/usr/share/man/man1/ssh-copy-id.1
-
- # sshd_config
- sed -i \
- -e 's|^#ListenAddress 0.0.0.0|ListenAddress 0.0.0.0|g' \
- -e 's|^#UsePAM no|UsePAM yes|g' \
- -e 's|^#ChallengeResponseAuthentication yes|ChallengeResponseAuthentication no|g' \
- ${pkgdir}/etc/ssh/sshd_config
- echo "HashKnownHosts yes" >> ${pkgdir}/etc/ssh/ssh_config
- echo "StrictHostKeyChecking ask" >> ${pkgdir}/etc/ssh/ssh_config
-
- #ssh_config
- sed -i \
- -e 's|^# Host \*|Host *|g' \
- ${pkgdir}/etc/ssh/ssh_config
-}
diff --git a/abs/core-testing/openssh/sshd b/abs/core-testing/openssh/sshd
deleted file mode 100755
index bc0e453..0000000
--- a/abs/core-testing/openssh/sshd
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-. /etc/conf.d/sshd
-
-PID="$(cat /var/run/sshd.pid 2>/dev/null)"
-case "$1" in
- start)
- stat_busy "Starting Secure Shell Daemon"
- [ -f /etc/ssh/ssh_host_key ] || { /usr/bin/ssh-keygen -t rsa1 -N "" -f /etc/ssh/ssh_host_key >/dev/null; }
- [ -f /etc/ssh/ssh_host_rsa_key ] || { /usr/bin/ssh-keygen -t rsa -N "" -f /etc/ssh/ssh_host_rsa_key >/dev/null; }
- [ -f /etc/ssh/ssh_host_dsa_key ] || { /usr/bin/ssh-keygen -t dsa -N "" -f /etc/ssh/ssh_host_dsa_key >/dev/null; }
- [ -d /var/empty ] || mkdir -p /var/empty
- [ -z "$PID" ] && /usr/sbin/sshd $SSHD_ARGS
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon sshd
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping Secure Shell Daemon"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon sshd
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
diff --git a/abs/core-testing/openssh/sshd.confd b/abs/core-testing/openssh/sshd.confd
deleted file mode 100644
index 5ce7c00..0000000
--- a/abs/core-testing/openssh/sshd.confd
+++ /dev/null
@@ -1,4 +0,0 @@
-#
-# Parameters to be passed to sshd
-#
-SSHD_ARGS=""
diff --git a/abs/core-testing/openssh/sshd.pam b/abs/core-testing/openssh/sshd.pam
deleted file mode 100644
index dc70815..0000000
--- a/abs/core-testing/openssh/sshd.pam
+++ /dev/null
@@ -1,10 +0,0 @@
-#%PAM-1.0
-#auth required pam_securetty.so #Disable remote root
-auth required pam_unix.so
-auth required pam_nologin.so
-auth required pam_env.so
-account required pam_unix.so
-account required pam_time.so
-password required pam_unix.so
-session required pam_unix_session.so
-session required pam_limits.so