summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/pacman
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/pacman')
-rw-r--r--abs/core-testing/pacman/0001-makepkg-fallback-to-sane-defaults-for-library-stripp.patch32
-rw-r--r--abs/core-testing/pacman/PKGBUILD30
-rw-r--r--abs/core-testing/pacman/makepkg.conf10
-rw-r--r--abs/core-testing/pacman/pacman.conf4
-rw-r--r--abs/core-testing/pacman/pacman.install10
5 files changed, 66 insertions, 20 deletions
diff --git a/abs/core-testing/pacman/0001-makepkg-fallback-to-sane-defaults-for-library-stripp.patch b/abs/core-testing/pacman/0001-makepkg-fallback-to-sane-defaults-for-library-stripp.patch
new file mode 100644
index 0000000..8baa35e
--- /dev/null
+++ b/abs/core-testing/pacman/0001-makepkg-fallback-to-sane-defaults-for-library-stripp.patch
@@ -0,0 +1,32 @@
+From dc817a2061699cd1f33ca93f0d93a1fbc2f33ea1 Mon Sep 17 00:00:00 2001
+From: Allan McRae <allan@archlinux.org>
+Date: Thu, 17 Jun 2010 14:32:08 +1000
+Subject: [PATCH] makepkg: fallback to sane defaults for library stripping
+
+If the library stripping variables are not defined in makepkg.conf,
+libraries will be fully stripped and become broken. Fallback to a
+sane default stripping level.
+
+Signed-off-by: Allan McRae <allan@archlinux.org>
+Signed-off-by: Dan McGee <dan@archlinux.org>
+---
+ scripts/makepkg.sh.in | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/scripts/makepkg.sh.in b/scripts/makepkg.sh.in
+index d986701..e64b564 100644
+--- a/scripts/makepkg.sh.in
++++ b/scripts/makepkg.sh.in
+@@ -864,6 +864,9 @@ tidy_install() {
+
+ if [[ $(check_option strip) = y && -n ${STRIP_DIRS[*]} ]]; then
+ msg2 "$(gettext "Stripping unneeded symbols from binaries and libraries...")"
++ # make sure library stripping variables are defined to prevent excess stripping
++ [[ -z ${STRIP_SHARED+x} ]] && STRIP_SHARED="-S"
++ [[ -z ${STRIP_STATIC+x} ]] && STRIP_STATIC="-S"
+ local binary
+ find ${STRIP_DIRS[@]} -type f -perm -u+w 2>/dev/null | while read binary ; do
+ case "$(file -bi "$binary")" in
+--
+1.7.1
+
diff --git a/abs/core-testing/pacman/PKGBUILD b/abs/core-testing/pacman/PKGBUILD
index 239abb8..b18009b 100644
--- a/abs/core-testing/pacman/PKGBUILD
+++ b/abs/core-testing/pacman/PKGBUILD
@@ -1,32 +1,40 @@
-# $Id: PKGBUILD 58635 2009-11-11 00:00:52Z dan $
+# $Id: PKGBUILD 83376 2010-06-21 12:52:09Z dan $
# Maintainer: Aaron Griffin <aaron@archlinux.org>
# Maintainer: Dan McGee <dan@archlinux.org>
pkgname=pacman
-pkgver=3.3.3
-pkgrel=10
+pkgver=3.4.0
+pkgrel=2
pkgdesc="A library-based package manager with dependency support"
arch=('i686' 'x86_64')
url="http://www.archlinux.org/pacman/"
license=('GPL')
groups=('base')
depends=('bash' 'libarchive>=2.7.1' 'libfetch>=2.25' 'pacman-mirrorlist')
-optdepends=('fakeroot: for makepkg usage as normal user'
- 'python: for rankmirrors script usage')
+optdepends=('fakeroot: for makepkg usage as normal user')
backup=(etc/pacman.conf etc/makepkg.conf)
install=pacman.install
options=(!libtool)
source=(ftp://ftp.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz
pacman.conf
- makepkg.conf)
-md5sums=('a8cef73d68e2a4c3a46fb46c33210719'
- 'abe70dabacee7036368c7afeb686eb10'
- '52c7bc651b107d73f9902755b7594458')
+ makepkg.conf
+ 0001-makepkg-fallback-to-sane-defaults-for-library-stripp.patch)
+md5sums=('50ad71be1faaad84842c576e239d1bb5'
+ '80f5bb2a606553512d0db857f78d9ac2'
+ 'aef317285c7d16ac495b0e53deeb948d'
+ 'f8c4a3cc7702a7a70d177659441495c5')
+sha256sums=('cd80e206ee653ce337555c73b7064088e672e9341245317fe09dc52d06bff3c3'
+ '97fb68536c1179a7de52dfb8a107c6e9bf3a71eaa6a98d6ae74dc224d4ca5838'
+ '3a60e1f895c90c8e74f5ca389fa05fb3328745e9873c5452b8cd1b2e68bee418'
+ '99f1d108f930b134cfb4c1ca8c86cd282fe9efb69de39cd747218f3d448dda44')
+
+# keep an upgrade path for older installations
+PKGEXT='.pkg.tar.gz'
build() {
cd $srcdir/$pkgname-$pkgver
-
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ patch -Np1 < $srcdir/0001-makepkg-fallback-to-sane-defaults-for-library-stripp.patch
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc
make || return 1
}
diff --git a/abs/core-testing/pacman/makepkg.conf b/abs/core-testing/pacman/makepkg.conf
index 12cfebd..ff08a0f 100644
--- a/abs/core-testing/pacman/makepkg.conf
+++ b/abs/core-testing/pacman/makepkg.conf
@@ -72,6 +72,12 @@ OPTIONS=(strip docs libtool emptydirs zipman purge)
#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
INTEGRITY_CHECK=(md5)
+#-- Options to be used when stripping binaries. See `man strip' for details.
+STRIP_BINARIES="--strip-all"
+#-- Options to be used when stripping shared libraries. See `man strip' for details.
+STRIP_SHARED="--strip-unneeded"
+#-- Options to be used when stripping static libraries. See `man strip' for details.
+STRIP_STATIC="--strip-debug"
#-- Manual (man and info) directories to compress (if zipman is specified)
MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
#-- Doc directories to remove (if !docs is specified)
@@ -91,6 +97,8 @@ PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
#PKGDEST=/home/packages
#-- Source cache: specify a fixed directory where source files will be cached
#SRCDEST=/home/sources
+#-- Source packages: specify a fixed directory where all src packages will be placed
+#SRCPKGDEST=/home/srcpackages
#-- Packager: name/email of the person or organization building packages
#PACKAGER="John Doe <john@doe.com>"
@@ -101,7 +109,7 @@ PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
# WARNING: Do NOT modify these variables unless you know what you are
# doing.
#
-PKGEXT='.pkg.tar.gz'
+PKGEXT='.pkg.tar.xz'
SRCEXT='.src.tar.gz'
# vim: set ft=sh ts=2 sw=2 et:
diff --git a/abs/core-testing/pacman/pacman.conf b/abs/core-testing/pacman/pacman.conf
index de7e17d..911c23d 100644
--- a/abs/core-testing/pacman/pacman.conf
+++ b/abs/core-testing/pacman/pacman.conf
@@ -17,8 +17,9 @@ HoldPkg = pacman glibc
# If upgrades are available for these packages they will be asked for first
SyncFirst = pacman
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
-#XferCommand = /usr/bin/curl %u > %o
+#XferCommand = /usr/bin/curl -C - %u > %o
#CleanMethod = KeepInstalled
+Architecture = auto
# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg =
@@ -41,6 +42,7 @@ SyncFirst = pacman
# - repositories listed first will take precedence when packages
# have identical names, regardless of version number
# - URLs will have $repo replaced by the name of the current repo
+# - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
# [repo-name]
diff --git a/abs/core-testing/pacman/pacman.install b/abs/core-testing/pacman/pacman.install
index ed10f0d..294222e 100644
--- a/abs/core-testing/pacman/pacman.install
+++ b/abs/core-testing/pacman/pacman.install
@@ -3,13 +3,9 @@
# arg 2: the old package version
post_upgrade() {
# one time stuff for md5sum issue with older pacman versions
- if [ -f /usr/bin/vercmp ]
- then
- if [ "$(vercmp $2 3.0.2)" -lt 0 ]
- then
- _resetbackups
- fi
- fi
+ if [ "$(vercmp $2 3.0.2)" -lt 0 ]; then
+ _resetbackups
+ fi
}
_resetbackups() {