summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/pcre
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/pcre')
-rw-r--r--abs/core-testing/pcre/ChangeLog40
-rw-r--r--abs/core-testing/pcre/PKGBUILD36
-rw-r--r--abs/core-testing/pcre/libpcre-7.7-buffer-overflow.patch16
3 files changed, 0 insertions, 92 deletions
diff --git a/abs/core-testing/pcre/ChangeLog b/abs/core-testing/pcre/ChangeLog
deleted file mode 100644
index cdff568..0000000
--- a/abs/core-testing/pcre/ChangeLog
+++ /dev/null
@@ -1,40 +0,0 @@
-2010-03-24 Eric Belanger <eric@archlinux.org>
-
- * pcre 8.02-1
- * Upstream update
-
-2010-01-23 Eric Belanger <eric@archlinux.org>
-
- * pcre 8.01-1
- * Upstream update
-
-2009-10-26 Eric Belanger <eric@archlinux.org>
-
- * pcre 8.00-1
- * Upstream update
-
-2009-04-13 Eric Belanger <eric@archlinux.org>
-
- * pcre 7.9-1
- * Upstream update
-
-2008-10-19 Eric Belanger <eric@archlinux.org>
-
- * Updated url
-
-2008-09-05 Eric Belanger <eric@archlinux.org>
-
- * pcre 7.8-1
- * Upstream update
- * Fixed license
-
-2008-07-07 Eric Belanger <eric@archlinux.org>
-
- * pcre 7.7-2
- * Added libpcre-7.7-buffer-overflow.patch to fix buffer overflow (close FS#10845)
-
-2008-05-10 Eric Belanger <eric@archlinux.org>
-
- * pcre 7.7-1
- * Upstream update
- * Added ChangeLog
diff --git a/abs/core-testing/pcre/PKGBUILD b/abs/core-testing/pcre/PKGBUILD
deleted file mode 100644
index d31e23c..0000000
--- a/abs/core-testing/pcre/PKGBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# $Id: PKGBUILD 84661 2010-07-03 04:01:39Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
-# Contributor: Eric Belanger <eric@archlinux.org>
-# Contributor: John Proctor <jproctor@prium.net>
-
-pkgname=pcre
-pkgver=8.10
-pkgrel=1
-pkgdesc="A library that implements Perl 5-style regular expressions"
-arch=('i686' 'x86_64')
-url="http://www.pcre.org/"
-license=('BSD')
-depends=('gcc-libs')
-options=('!libtool')
-source=(ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('780867a700e9d4e4b9cb47aa5453e4b2')
-sha1sums=('8b345da0f835b2caabff071b0b5bab40564652be')
-
-build() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- [ "${CARCH}" = "x86_64" ] && export CFLAGS="${CFLAGS} -fPIC"
- ./configure --prefix=/usr --enable-utf8 --enable-unicode-properties
- make
-}
-
-package() {
- cd "${srcdir}"/${pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
-
- # grep uses pcre, so we need the libs in /lib
- install -dm755 "${pkgdir}"/lib
- mv "${pkgdir}"/usr/lib/libpcre.so.* "${pkgdir}"/lib/
- ln -sf ../../lib/libpcre.so.0 "${pkgdir}"/usr/lib/libpcre.so
-
- install -Dm644 LICENCE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
-}
diff --git a/abs/core-testing/pcre/libpcre-7.7-buffer-overflow.patch b/abs/core-testing/pcre/libpcre-7.7-buffer-overflow.patch
deleted file mode 100644
index a27987f..0000000
--- a/abs/core-testing/pcre/libpcre-7.7-buffer-overflow.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -NrU5 pcre-7.7.orig/pcre_compile.c pcre-7.7/pcre_compile.c
---- pcre-7.7.orig/pcre_compile.c 2008-06-18 17:08:49.000000000 +0200
-+++ pcre-7.7/pcre_compile.c 2008-06-18 17:11:04.000000000 +0200
-@@ -4929,11 +4929,11 @@
- {
- if (code == cd->start_code + 1 + LINK_SIZE &&
- (lengthptr == NULL || *lengthptr == 2 + 2*LINK_SIZE))
- {
- cd->external_options = newoptions;
-- options = newoptions;
-+ options = *optionsptr = newoptions;
- }
- else
- {
- if ((options & PCRE_IMS) != (newoptions & PCRE_IMS))
- {