summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/perl_modules/perl-date-manip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/perl_modules/perl-date-manip/PKGBUILD')
-rw-r--r--abs/core-testing/perl_modules/perl-date-manip/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core-testing/perl_modules/perl-date-manip/PKGBUILD b/abs/core-testing/perl_modules/perl-date-manip/PKGBUILD
new file mode 100644
index 0000000..be50d1a
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-date-manip/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Kevin Piche <kevin@archlinux.org>
+# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
+
+pkgname=perl-date-manip
+_realname=Date-Manip
+pkgver=5.54
+pkgrel=1
+pkgdesc="Date::Manip - date manipulation routines"
+arch=(i686 x86_64)
+license=('PerlArtistic')
+url="http://search.cpan.org/dist/${_realname}/"
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/S/SB/SBECK/${_realname}-${pkgver}.tar.gz)
+md5sums=('16c343329bad644b17f4f8ec5fb243cf')
+
+build() {
+ cd ${startdir}/src/${_realname}-${pkgver}
+ # install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=${startdir}/pkg || return 1
+
+ # remove perllocal.pod and .packlist
+ find ${startdir}/pkg -name perllocal.pod -delete
+ find ${startdir}/pkg -name .packlist -delete
+}