summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/perl_modules/perl-unicode-utf8simple/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/perl_modules/perl-unicode-utf8simple/PKGBUILD')
-rw-r--r--abs/core-testing/perl_modules/perl-unicode-utf8simple/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core-testing/perl_modules/perl-unicode-utf8simple/PKGBUILD b/abs/core-testing/perl_modules/perl-unicode-utf8simple/PKGBUILD
new file mode 100644
index 0000000..a5b9dfb
--- /dev/null
+++ b/abs/core-testing/perl_modules/perl-unicode-utf8simple/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Allan McRae <mcrae_allan@hotmail.com>
+# Contributor: François Charette <firmicus ατ gmx δοτ net>
+
+pkgname=perl-unicode-utf8simple
+pkgver=1.06
+pkgrel=2
+pkgdesc="Conversions to/from UTF8 from/to characterse"
+arch=('i686' 'x86_64')
+url="http://search.cpan.org/~GUS/Unicode-UTF8simple"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=('!emptydirs')
+source=(http://www.cpan.org/authors/id/G/GU/GUS/Unicode-UTF8simple-$pkgver.tar.gz)
+md5sums=('1d90907170ed41690a572a2d6ed6e7da')
+
+build() {
+ cd $startdir/src/Unicode-UTF8simple-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=$startdir/pkg || return 1
+ find $startdir/pkg -name '.packlist' -delete
+ find $startdir/pkg -name '*.pod' -delete
+}