summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/pm-utils
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/pm-utils')
-rw-r--r--abs/core-testing/pm-utils/11netcfg26
-rw-r--r--abs/core-testing/pm-utils/PKGBUILD31
-rw-r--r--abs/core-testing/pm-utils/pm-utils.install15
-rw-r--r--abs/core-testing/pm-utils/service.patch15
4 files changed, 0 insertions, 87 deletions
diff --git a/abs/core-testing/pm-utils/11netcfg b/abs/core-testing/pm-utils/11netcfg
deleted file mode 100644
index 1b4d05e..0000000
--- a/abs/core-testing/pm-utils/11netcfg
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/bash
-
-. /usr/lib/pm-utils/functions
-
-suspend_netcfg() {
- netcfg2 all-suspend
-}
-
-resume_netcfg() {
- netcfg2 all-resume
-}
-
-if [ -x /usr/bin/netcfg2 ]; then
- case "$1" in
- hibernate|suspend)
- suspend_netcfg
- ;;
- thaw|resume)
- resume_netcfg
- ;;
- *)
- ;;
- esac
-fi
-
-exit $?
diff --git a/abs/core-testing/pm-utils/PKGBUILD b/abs/core-testing/pm-utils/PKGBUILD
deleted file mode 100644
index 0d87a34..0000000
--- a/abs/core-testing/pm-utils/PKGBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# $Id: PKGBUILD 83839 2010-06-23 08:36:02Z jgc $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-# Contributor: Thayer Williams <thayer@archlinux.org>
-# Contributor: Giovanni Scafora <giovanni@archlinux.org>
-
-pkgname=pm-utils
-pkgver=1.4.0
-pkgrel=1
-pkgdesc="Utilities and scripts for suspend and hibernate power management"
-arch=('i686' 'x86_64')
-url="http://pm-utils.freedesktop.org"
-license=('GPL')
-depends=('bash' 'procps' 'vbetool' 'pm-quirks')
-optdepends=('upower')
-makedepends=('xmlto' 'docbook-xml' 'docbook-xsl')
-source=(http://pm-utils.freedesktop.org/releases/${pkgname}-${pkgver}.tar.gz
- 11netcfg)
-md5sums=('132005cf1d33e33802eb78121a6ceb22'
- '9839687c8787d99fd4ff36aa3238c27b')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var
- make
- make DESTDIR="${pkgdir}" install
-
- # install additional hooks
- install -m755 "${srcdir}/11netcfg" "${pkgdir}/usr/lib/pm-utils/sleep.d/"
-}
diff --git a/abs/core-testing/pm-utils/pm-utils.install b/abs/core-testing/pm-utils/pm-utils.install
deleted file mode 100644
index 5e8232d..0000000
--- a/abs/core-testing/pm-utils/pm-utils.install
+++ /dev/null
@@ -1,15 +0,0 @@
-# arg 1: the new package version
-post_install() {
- cat << _EOF
-
-Powersave has been deprecated as suspend/resume framework and has been replaced
-by pm-utils. Pm-utils provides everything you need for suspend/resume, but does
-not load your cpufreq modules like powersaved does. You have to load these
-modules by hand if you want to use them.
-
-_EOF
-}
-
-op=$1
-shift
-$op $*
diff --git a/abs/core-testing/pm-utils/service.patch b/abs/core-testing/pm-utils/service.patch
deleted file mode 100644
index 422b3f5..0000000
--- a/abs/core-testing/pm-utils/service.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- pm/functions.in~ 2008-04-10 17:39:48.000000000 +0000
-+++ pm/functions.in 2008-04-10 17:39:58.000000000 +0000
-@@ -138,10 +138,10 @@
- if ! command_exists service; then
- service()
- {
-- if [ -x "/etc/init.d/$1" ]; then
-+ if [ -x "/etc/rc.d/$1" ]; then
- svc="$1"
- shift
-- "/etc/init.d/$svc" "$@"
-+ "/etc/rc.d/$svc" "$@"
- else
- log "$1" $": unrecognized service" 1>&2
- return 1