summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/ppl
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/ppl')
-rw-r--r--abs/core-testing/ppl/PKGBUILD27
-rw-r--r--abs/core-testing/ppl/ppl-0.10.2-gmp-5.0.patch30
2 files changed, 0 insertions, 57 deletions
diff --git a/abs/core-testing/ppl/PKGBUILD b/abs/core-testing/ppl/PKGBUILD
deleted file mode 100644
index ee5979a..0000000
--- a/abs/core-testing/ppl/PKGBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# $Id: PKGBUILD 87232 2010-08-11 12:07:18Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
-# Contributor: ezzetabi <ezzetabi at gawab dot com>
-
-pkgname=ppl
-pkgver=0.11
-pkgrel=1
-pkgdesc="A modern library for convex polyhedra and other numerical abstractions."
-arch=('i686' 'x86_64')
-url="http://www.cs.unipr.it/ppl"
-license=('GPL3')
-depends=('gmp>=5.0')
-options=('!docs' '!libtool')
-source=(http://www.cs.unipr.it/ppl/Download/ftp/releases/$pkgver/ppl-$pkgver.tar.gz)
-md5sums=('ba527ec0ffc830ce16fad8a4195a337e')
-
-build() {
- cd $srcdir/ppl-$pkgver
- ./configure --prefix=/usr --enable-interfaces="c,cxx"
- make
- make check
-}
-
-package() {
- cd $srcdir/ppl-$pkgver
- make DESTDIR=$pkgdir install
-}
diff --git a/abs/core-testing/ppl/ppl-0.10.2-gmp-5.0.patch b/abs/core-testing/ppl/ppl-0.10.2-gmp-5.0.patch
deleted file mode 100644
index 4d6964a..0000000
--- a/abs/core-testing/ppl/ppl-0.10.2-gmp-5.0.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff --git a/m4/ac_check_gmp.m4 b/m4/ac_check_gmp.m4
-index 60cecdc..15acb18 100644
---- a/m4/ac_check_gmp.m4
-+++ b/m4/ac_check_gmp.m4
-@@ -71,6 +71,10 @@ AC_RUN_IFELSE([AC_LANG_SOURCE([[
- #GMP version 4.1.3 or higher is required
- #endif
-
-+#ifndef BITS_PER_MP_LIMB
-+#define BITS_PER_MP_LIMB GMP_LIMB_BITS
-+#endif
-+
- int
- main() {
- std::string header_version;
-@@ -97,11 +101,11 @@ main() {
- return 1;
- }
-
-- if (sizeof(mp_limb_t)*CHAR_BIT != GMP_LIMB_BITS
-- || GMP_LIMB_BITS != mp_bits_per_limb) {
-+ if (sizeof(mp_limb_t)*CHAR_BIT != BITS_PER_MP_LIMB
-+ || BITS_PER_MP_LIMB != mp_bits_per_limb) {
- std::cerr
- << "GMP header (gmp.h) and library (ligmp.*) bits-per-limb mismatch:\n"
-- << "header gives " << __GMP_BITS_PER_MP_LIMB << ";\n"
-+ << "header gives " << BITS_PER_MP_LIMB << ";\n"
- << "library gives " << mp_bits_per_limb << ".\n"
- << "This probably means you are on a bi-arch system and\n"
- << "you are compiling with the wrong header or linking with\n"