summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/rsync
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/rsync')
-rw-r--r--abs/core-testing/rsync/PKGBUILD27
-rw-r--r--abs/core-testing/rsync/__changelog1
-rw-r--r--abs/core-testing/rsync/rsync.xinetd11
-rw-r--r--abs/core-testing/rsync/rsyncd37
-rw-r--r--abs/core-testing/rsync/rsyncd.conf16
5 files changed, 0 insertions, 92 deletions
diff --git a/abs/core-testing/rsync/PKGBUILD b/abs/core-testing/rsync/PKGBUILD
deleted file mode 100644
index 23fb9d0..0000000
--- a/abs/core-testing/rsync/PKGBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-pkgname=rsync
-pkgver=3.0.7
-pkgrel=1
-pkgdesc="A file transfer program to keep remote files in sync"
-arch=('i686' 'x86_64')
-url="http://samba.anu.edu.au/rsync/"
-license=('GPL3')
-depends=('acl')
-backup=('etc/rsyncd.conf' 'etc/xinetd.d/rsync')
-source=(http://rsync.samba.org/ftp/rsync/${pkgname}-${pkgver}.tar.gz \
- rsyncd.conf rsyncd rsync.xinetd)
-
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- ./prepare-source || return 1
- ./configure --prefix=/usr --with-included-popt \
- --enable-acl-support --enable-xattr-support || return 1
- make || return 1
- make DESTDIR=${pkgdir} install || return 1
- install -D -m 755 ../rsyncd ${pkgdir}/etc/rc.d/rsyncd || return 1
- install -D -m 644 ../rsyncd.conf ${pkgdir}/etc/rsyncd.conf || return 1
- install -D -m 644 ../rsync.xinetd ${pkgdir}/etc/xinetd.d/rsync || return 1
-}
-md5sums=('b53525900817cf1ba7ad3a516ab5bfe9'
- '4395c0591638349b1a7aeaaa4da1f03a'
- '9de4d03d49f4b5c73ffd67d452716a49'
- 'ea3e9277dc908bc51f9eddc0f6b935c1')
diff --git a/abs/core-testing/rsync/__changelog b/abs/core-testing/rsync/__changelog
deleted file mode 100644
index e07c296..0000000
--- a/abs/core-testing/rsync/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-update to 3.0.7
diff --git a/abs/core-testing/rsync/rsync.xinetd b/abs/core-testing/rsync/rsync.xinetd
deleted file mode 100644
index f5b6b1e..0000000
--- a/abs/core-testing/rsync/rsync.xinetd
+++ /dev/null
@@ -1,11 +0,0 @@
-service rsync
-{
- socket_type = stream
- wait = no
- user = root
- server = /usr/bin/rsync
- server_args = --daemon
- log_on_success += HOST DURATION
- log_on_failure += HOST
- disable = yes
-}
diff --git a/abs/core-testing/rsync/rsyncd b/abs/core-testing/rsync/rsyncd
deleted file mode 100644
index e1313dc..0000000
--- a/abs/core-testing/rsync/rsyncd
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-case "$1" in
- start)
- stat_busy "Starting rsyncd"
- [ ! -f /var/run/daemons/rsyncd ] && /usr/bin/rsync --daemon
- if [ $? -gt 0 ]; then
- stat_fail
- else
- pgrep -of "/usr/bin/rsync --daemon" > /var/run/rsyncd.pid
- add_daemon rsyncd
- stat_done
- fi
- ;;
-
- stop)
- stat_busy "Stopping rsyncd"
- [ -f /var/run/rsyncd.pid ] && kill `cat /var/run/rsyncd.pid`
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon rsyncd
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
diff --git a/abs/core-testing/rsync/rsyncd.conf b/abs/core-testing/rsync/rsyncd.conf
deleted file mode 100644
index f7161f3..0000000
--- a/abs/core-testing/rsync/rsyncd.conf
+++ /dev/null
@@ -1,16 +0,0 @@
-uid = nobody
-gid = nobody
-use chroot = no
-max connections = 4
-syslog facility = local5
-pid file = /var/run/rsyncd.pid
-
-[ftp]
- path = /home/ftp
- comment = ftp area
-
-#[cvs]
-# path = /data/cvs
-# comment = CVS repository (requires authentication)
-# auth users = tridge, susan
-# secrets file = /etc/rsyncd.secrets