summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/runit-scripts/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/runit-scripts/PKGBUILD')
-rwxr-xr-xabs/core-testing/runit-scripts/PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index 474e15e..d94fc91 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=1.8.0
-pkgrel=51
+pkgrel=77
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
@@ -10,19 +10,21 @@ conflicts=()
replaces=()
backup=(etc/runit/1.local)
install=runit.install
-source=()
+source=(fbsplash-runit.sh)
arch=('i686')
build() {
- rsync -a --exclude=.svn $startdir/runitscripts $startdir/src
+ rsync -a --exclude=.svn --exclude=*~ $startdir/runitscripts $startdir/src
cd $startdir/src/runitscripts
install -d $startdir/pkg/etc/
install -d $startdir/pkg/etc/runit/
install -d $startdir/pkg/var/service
install -d $startdir/pkg/etc/sv
install -d $startdir/pkg/sbin
- install -m0700 1 2 3 1.local ctrlaltdel $startdir/pkg/etc/runit
+ install -d $startdir/pkg/etc/rc.d/functions.d
+ install -m0700 1 2 3 1.local ctrlaltdel $startdir/pkg/etc/runit
+ install -m755 $startdir/src/fbsplash-runit.sh $startdir/pkg/etc/rc.d/functions.d/fbsplash-runit.sh
install -m0755 reboot-runit halt-runit logger $startdir/pkg/sbin
rsync -a --exclude=.svn services/* $startdir/pkg/etc/sv
}