summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/sqlite3
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/sqlite3')
-rw-r--r--abs/core-testing/sqlite3/PKGBUILD43
-rw-r--r--abs/core-testing/sqlite3/build_fts_as_part_of_libsqlite.patch139
-rw-r--r--abs/core-testing/sqlite3/license.txt33
-rw-r--r--abs/core-testing/sqlite3/sqlite-3.5.8-pkgconfig-version.patch12
4 files changed, 0 insertions, 227 deletions
diff --git a/abs/core-testing/sqlite3/PKGBUILD b/abs/core-testing/sqlite3/PKGBUILD
deleted file mode 100644
index 0a6fc93..0000000
--- a/abs/core-testing/sqlite3/PKGBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# $Id: PKGBUILD 86812 2010-08-04 21:15:20Z andyrtr $
-# Maintainer: Andreas Radke <andyrtr@archlinux.org>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-
-pkgname=sqlite3
-pkgver=3.7.0.1
-pkgrel=1
-pkgdesc="A C library that implements an SQL database engine"
-arch=('i686' 'x86_64')
-license=('custom')
-url="http://www.sqlite.org/"
-depends=('readline>=6.0.00')
-makedepends=('tcl')
-conflicts=('sqlite')
-replaces=('sqlite')
-source=(http://www.sqlite.org/sqlite-$pkgver.tar.gz
- license.txt)
-options=(!libtool)
-md5sums=('d25d7551ba6bb310362cb0e7d4906f25'
- 'c1cdbc5544034d9012e421e75a5e4890')
-
-build() {
- cd ${srcdir}/sqlite-${pkgver}
- export LTLINK_EXTRAS="-ldl"
- export CFLAGS="$CFLAGS -DSQLITE_ENABLE_FTS3=1 -DSQLITE_ENABLE_COLUMN_METADATA=1"
- ./configure --prefix=/usr \
- --enable-threadsafe \
- --enable-threads-override-locks \
- --enable-cross-thread-connections \
- --disable-static \
- --enable-load-extension || return 1
-
- # rpath removal
- sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
- sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
-
- make || return 1
- make DESTDIR=${pkgdir} install || return 1
- install -Dm0644 sqlite3.1 ${pkgdir}/usr/share/man/man1/sqlite3.1
-
- # license
- install -Dm644 ${srcdir}/license.txt ${pkgdir}/usr/share/licenses/${pkgname}/license.txt
-}
diff --git a/abs/core-testing/sqlite3/build_fts_as_part_of_libsqlite.patch b/abs/core-testing/sqlite3/build_fts_as_part_of_libsqlite.patch
deleted file mode 100644
index 54b04f0..0000000
--- a/abs/core-testing/sqlite3/build_fts_as_part_of_libsqlite.patch
+++ /dev/null
@@ -1,139 +0,0 @@
-Index: Makefile.in
-===================================================================
-RCS file: /sqlite/sqlite/Makefile.in,v
-retrieving revision 1.186
-diff -u -3 -p -r1.186 Makefile.in
---- Makefile.in 23 Nov 2007 15:12:44 -0000 1.186
-+++ Makefile.in 23 Nov 2007 19:27:56 -0000
-@@ -114,6 +114,23 @@ LTINSTALL = $(LIBTOOL) --mode=install $(
- # nawk compatible awk.
- NAWK = @AWK@
-
-+# Need these defined unconditionally, as non-fts builds with
-+# fts object files without using -DSQLITE_ENABLE_FTS[123]
-+# will not work without it.
-+#
-+TCC += -DSQLITE_CORE
-+TCC += -DSQLITE_ENABLE_BROKEN_FTS1
-+TCC += -DSQLITE_ENABLE_BROKEN_FTS2
-+
-+# uncomment to build fts1 as part of library
-+# TCC += -DSQLITE_ENABLE_FTS1=1
-+
-+# uncomment to build fts2 as part of library
-+# TCC += -DSQLITE_ENABLE_FTS2=1
-+
-+# uncomment to build fts3 as part of library
-+# TCC += -DSQLITE_ENABLE_FTS3=1
-+
- # You should not have to change anything below this line
- ###############################################################################
- TCC += -DSQLITE_OMIT_LOAD_EXTENSION=1
-@@ -132,6 +149,17 @@ LIBOBJ = alter.lo analyze.lo attach.lo a
- vdbe.lo vdbeapi.lo vdbeaux.lo vdbeblob.lo vdbefifo.lo vdbemem.lo \
- where.lo utf.lo legacy.lo vtab.lo
-
-+# Object files for FTS
-+#
-+LIBOBJ += \
-+ fts1.lo fts1_hash.lo fts1_porter.lo fts1_tokenizer1.lo
-+
-+LIBOBJ += \
-+ fts2.lo fts2_hash.lo fts2_porter.lo fts2_tokenizer.lo fts2_tokenizer1.lo
-+
-+LIBOBJ += \
-+ fts3.lo fts3_hash.lo fts3_porter.lo fts3_tokenizer.lo fts3_tokenizer1.lo
-+
- # All of the source code files.
- #
- SRC = \
-@@ -209,6 +237,23 @@ SRC += \
- $(TOP)/ext/fts1/fts1_tokenizer.h \
- $(TOP)/ext/fts1/fts1_tokenizer1.c
-
-+SRC += \
-+ $(TOP)/ext/fts2/fts2.c \
-+ $(TOP)/ext/fts2/fts2.h \
-+ $(TOP)/ext/fts2/fts2_hash.c \
-+ $(TOP)/ext/fts2/fts2_hash.h \
-+ $(TOP)/ext/fts2/fts2_porter.c \
-+ $(TOP)/ext/fts2/fts2_tokenizer.h \
-+ $(TOP)/ext/fts2/fts2_tokenizer1.c
-+
-+SRC += \
-+ $(TOP)/ext/fts3/fts3.c \
-+ $(TOP)/ext/fts3/fts3.h \
-+ $(TOP)/ext/fts3/fts3_hash.c \
-+ $(TOP)/ext/fts3/fts3_hash.h \
-+ $(TOP)/ext/fts3/fts3_porter.c \
-+ $(TOP)/ext/fts3/fts3_tokenizer.h \
-+ $(TOP)/ext/fts3/fts3_tokenizer1.c
-
- # Source code to the test files.
- #
-@@ -285,6 +330,16 @@ HDR += \
- $(TOP)/ext/fts1/fts1_hash.h \
- $(TOP)/ext/fts1/fts1_tokenizer.h
-
-+HDR += \
-+ $(TOP)/ext/fts2/fts2.h \
-+ $(TOP)/ext/fts2/fts2_hash.h \
-+ $(TOP)/ext/fts2/fts2_tokenizer.h
-+
-+HDR += \
-+ $(TOP)/ext/fts3/fts3.h \
-+ $(TOP)/ext/fts3/fts3_hash.h \
-+ $(TOP)/ext/fts3/fts3_tokenizer.h
-+
- # Header files used by the VDBE submodule
- #
- VDBEHDR = \
-@@ -616,3 +671,48 @@ sqlite3.def: $(REAL_LIBOBJ)
- sqlite3.dll: $(REAL_LIBOBJ) sqlite3.def
- $(TCC) -shared -o sqlite3.dll sqlite3.def \
- -Wl,"--strip-all" $(REAL_LIBOBJ)
-+
-+#
-+# FTS
-+#
-+fts1.lo: $(TOP)/ext/fts1/fts1.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts1/fts1.c
-+
-+fts1_hash.lo: $(TOP)/ext/fts1/fts1_hash.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts1/fts1_hash.c
-+
-+fts1_porter.lo: $(TOP)/ext/fts1/fts1_porter.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts1/fts1_porter.c
-+
-+fts1_tokenizer1.lo: $(TOP)/ext/fts1/fts1_tokenizer1.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts1/fts1_tokenizer1.c
-+
-+fts2.lo: $(TOP)/ext/fts2/fts2.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2.c
-+
-+fts2_hash.lo: $(TOP)/ext/fts2/fts2_hash.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2_hash.c
-+
-+fts2_porter.lo: $(TOP)/ext/fts2/fts2_porter.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2_porter.c
-+
-+fts2_tokenizer.lo: $(TOP)/ext/fts2/fts2_tokenizer.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2_tokenizer.c
-+
-+fts2_tokenizer1.lo: $(TOP)/ext/fts2/fts2_tokenizer1.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts2/fts2_tokenizer1.c
-+
-+fts3.lo: $(TOP)/ext/fts3/fts3.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3.c
-+
-+fts3_hash.lo: $(TOP)/ext/fts3/fts3_hash.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3_hash.c
-+
-+fts3_porter.lo: $(TOP)/ext/fts3/fts3_porter.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3_porter.c
-+
-+fts3_tokenizer.lo: $(TOP)/ext/fts3/fts3_tokenizer.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3_tokenizer.c
-+
-+fts3_tokenizer1.lo: $(TOP)/ext/fts3/fts3_tokenizer1.c $(HDR)
-+ $(LTCOMPILE) -c $(TOP)/ext/fts3/fts3_tokenizer1.c
diff --git a/abs/core-testing/sqlite3/license.txt b/abs/core-testing/sqlite3/license.txt
deleted file mode 100644
index 118c5d5..0000000
--- a/abs/core-testing/sqlite3/license.txt
+++ /dev/null
@@ -1,33 +0,0 @@
-SQLite Copyright
-SQLite is in the
-Public Domain
-
-
-All of the deliverable code in SQLite has been dedicated to the public domain by the authors. All code authors, and representatives of the companies they work for, have signed affidavits dedicating their contributions to the public domain and originals of those signed affidavits are stored in a firesafe at the main offices of Hwaci. Anyone is free to copy, modify, publish, use, compile, sell, or distribute the original SQLite code, either in source code form or as a compiled binary, for any purpose, commercial or non-commercial, and by any means.
-
-The previous paragraph applies to the deliverable code in SQLite - those parts of the SQLite library that you actually bundle and ship with a larger application. Portions of the documentation and some code used as part of the build process might fall under other licenses. The details here are unclear. We do not worry about the licensing of the documentation and build code so much because none of these things are part of the core deliverable SQLite library.
-
-All of the deliverable code in SQLite has been written from scratch. No code has been taken from other projects or from the open internet. Every line of code can be traced back to its original author, and all of those authors have public domain dedications on file. So the SQLite code base is clean and is uncontaminated with licensed code from other projects.
-Obtaining An Explicit License To Use SQLite
-
-Even though SQLite is in the public domain and does not require a license, some users want to obtain a license anyway. Some reasons for obtaining a license include:
-You are using SQLite in a jurisdiction that does not recognize the public domain.
-You are using SQLite in a jurisdiction that does not recognize the right of an author to dedicate their work to the public domain.
-You want to hold a tangible legal document as evidence that you have the legal right to use and distribute SQLite.
-Your legal department tells you that you have to purchase a license.
-
-If you feel like you really have to purchase a license for SQLite, Hwaci, the company that employs the architect and principal developers of SQLite, will sell you one.
-Contributed Code
-
-In order to keep SQLite completely free and unencumbered by copyright, all new contributors to the SQLite code base are asked to dedicate their contributions to the public domain. If you want to send a patch or enhancement for possible inclusion in the SQLite source tree, please accompany the patch with the following statement:
-The author or authors of this code dedicate any and all copyright interest in this code to the public domain. We make this dedication for the benefit of the public at large and to the detriment of our heirs and successors. We intend this dedication to be an overt act of relinquishment in perpetuity of all present and future rights to this code under copyright law.
-
-We are not able to accept patches or changes to SQLite that are not accompanied by a statement such as the above. In addition, if you make changes or enhancements as an employee, then a simple statement such as the above is insufficient. You must also send by surface mail a copyright release signed by a company officer. A signed original of the copyright release should be mailed to:
-Hwaci
-6200 Maple Cove Lane
-Charlotte, NC 28269
-USA
-
-A template copyright release is available in PDF or HTML. You can use this release to make future changes.
-
-see http://www.sqlite.org/copyright.html \ No newline at end of file
diff --git a/abs/core-testing/sqlite3/sqlite-3.5.8-pkgconfig-version.patch b/abs/core-testing/sqlite3/sqlite-3.5.8-pkgconfig-version.patch
deleted file mode 100644
index cb5b5ef..0000000
--- a/abs/core-testing/sqlite3/sqlite-3.5.8-pkgconfig-version.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up sqlite-3.5.8/sqlite3.pc.in.release sqlite-3.5.8/sqlite3.pc.in
---- sqlite-3.5.8/sqlite3.pc.in.release 2008-04-23 09:11:38.000000000 +0300
-+++ sqlite-3.5.8/sqlite3.pc.in 2008-04-23 09:11:48.000000000 +0300
-@@ -7,7 +7,7 @@ includedir=@includedir@
-
- Name: SQLite
- Description: SQL database engine
--Version: @VERSION@
-+Version: @RELEASE@
- Libs: -L${libdir} -lsqlite3
- Libs.private: @LIBS@
- Cflags: -I${includedir}