summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tdb
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/tdb')
-rw-r--r--abs/core-testing/tdb/PKGBUILD26
-rw-r--r--abs/core-testing/tdb/gcc3.patch41
2 files changed, 0 insertions, 67 deletions
diff --git a/abs/core-testing/tdb/PKGBUILD b/abs/core-testing/tdb/PKGBUILD
deleted file mode 100644
index 4bf2af6..0000000
--- a/abs/core-testing/tdb/PKGBUILD
+++ /dev/null
@@ -1,26 +0,0 @@
-# $Id: PKGBUILD 63109 2010-01-14 18:55:16Z tpowa $
-# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
-# Contributorr: eric <eric@archlinux.org>
-# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-
-pkgname=tdb
-pkgver=1.2.0
-pkgrel=1
-pkgdesc="A Trivia Database similar to GDBM but allows simultaneous commits"
-arch=(i686 x86_64)
-license=('GPL3')
-url="http://tdb.samba.org/"
-source=(http://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-makedepends=('python')
-optdepends=('python: for python bindings')
-options=(force)
-
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- ./configure --prefix=/usr \
- --localstatedir=/var \
- --sysconfdir=/etc/samba
- make || return 1
- make DESTDIR=$pkgdir/ install
-}
-md5sums=('4115849d2ef431a10bc1f1933eafb9b6')
diff --git a/abs/core-testing/tdb/gcc3.patch b/abs/core-testing/tdb/gcc3.patch
deleted file mode 100644
index c88c2e7..0000000
--- a/abs/core-testing/tdb/gcc3.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- tdb-1.0.6/tdbtool.c 2001-12-10 22:45:47.000000000 -0500
-+++ ./tdbtool.c 2003-12-31 19:44:50.000000000 -0500
-@@ -169,22 +169,22 @@
-
- static void help(void)
- {
-- printf("
--tdbtool:
-- create dbname : create a database
-- open dbname : open an existing database
-- erase : erase the database
-- dump dumpname : dump the database as strings
-- insert key data : insert a record
-- store key data : store a record (replace)
-- show key : show a record by key
-- delete key : delete a record by key
-- list : print the database hash table and freelist
-- free : print the database freelist
-- 1 | first : print the first record
-- n | next : print the next record
-- q | quit : terminate
-- \\n : repeat 'next' command
-+ printf("\
-+tdbtool: \
-+ create dbname : create a database\
-+ open dbname : open an existing database\
-+ erase : erase the database\
-+ dump dumpname : dump the database as strings\
-+ insert key data : insert a record\
-+ store key data : store a record (replace)\
-+ show key : show a record by key\
-+ delete key : delete a record by key\
-+ list : print the database hash table and freelist\
-+ free : print the database freelist\
-+ 1 | first : print the first record\
-+ n | next : print the next record\
-+ q | quit : terminate\
-+ \\n : repeat 'next' command\
- ");
- }
-