summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tweaker/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/tweaker/PKGBUILD')
-rw-r--r--abs/core-testing/tweaker/PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/abs/core-testing/tweaker/PKGBUILD b/abs/core-testing/tweaker/PKGBUILD
index ebd3ed4..377edda 100644
--- a/abs/core-testing/tweaker/PKGBUILD
+++ b/abs/core-testing/tweaker/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=tweaker
pkgver=1
-pkgrel=38
-pkgdesc=""
+pkgrel=40
+pkgdesc="applies tweaks to the baseline configuration and attempts to optimize settings for the hardware it finds"
arch=('i686' 'x86_64')
depends=('bash' 'perl' 'perl-dbi' 'perl-exception-class' 'perl-log-log4perl' 'perl-log-dispatch' 'perl-getopt-lucid' 'perl-list-member' 'perl-class-data-inheritable' 'perl-devel-stacktrace' 'perl-xml-twig')
@@ -16,19 +16,18 @@ install=tweaker.install
build() {
TWEAKER_ROOT=usr/LH/tweaker
mkdir -p $startdir/pkg/$TWEAKER_ROOT
- mkdir -p $startdir/pkg/$TWEAKER_ROOT/{bin,fs,tcf}
+ mkdir -p $startdir/pkg/$TWEAKER_ROOT/{bin,fs,tcf}
mkdir -p $startdir/pkg/etc/profile.d
mkdir -p $startdir/pkg/usr/lib/perl5/vendor_perl/Tweaker/
cd $startdir
# executables
install -m0777 -D bin/* $startdir/pkg/$TWEAKER_ROOT/bin
-
# parallel root directory structure used for seeding configuration files
-# install -m0777 -D fs/ $startdir/pkg/$TWEAKER_ROOT/fs
- cp -rp fs $startdir/pkg/$TWEAKER_ROOT/
- chmod -R 0777 $startdir/pkg/$TWEAKER_ROOT/
+ # Ensure shell variables are configured at start; ensure $TWEAKER_ROOT/bin is in $PATH
+ cp -rp fs $startdir/pkg/$TWEAKER_ROOT/
+ chmod -R 0777 $startdir/pkg/$TWEAKER_ROOT/
# Tweaker configuration files
install -m0555 -D tcf/* $startdir/pkg/$TWEAKER_ROOT/tcf
@@ -37,7 +36,6 @@ build() {
#install -m0755 log4perl.conf $startdir/pkg/etc/log4perl.conf
install -m0755 log4perl.conf $startdir/pkg/$TWEAKER_ROOT
- # Ensure shell variables are configured at start; ensure $TWEAKER_ROOT/bin is in $PATH
install -m0755 tweaker.sh $startdir/pkg/etc/profile.d/tweaker.sh
# Copy our tweaker Perl modules for general use