summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base')
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/Makefile.svn-base56
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/capturefrm.txt.svn-base233
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/config.debug.svn-base90
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/config.linux-wlan-ng.svn-base264
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/releasepolicy.txt.svn-base37
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/rh71notes.svn-base61
6 files changed, 741 insertions, 0 deletions
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/Makefile.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..9dfce56
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,56 @@
+# doc/Makefile
+#
+# Copyright (C) 1999 AbsoluteValue Systems, Inc. All Rights Reserved.
+# --------------------------------------------------------------------
+#
+# linux-wlan
+#
+# The contents of this file are subject to the Mozilla Public
+# License Version 1.1 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.mozilla.org/MPL/
+#
+# Software distributed under the License is distributed on an "AS
+# IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
+# implied. See the License for the specific language governing
+# rights and limitations under the License.
+#
+# Alternatively, the contents of this file may be used under the
+# terms of the GNU Public License version 2 (the "GPL"), in which
+# case the provisions of the GPL are applicable instead of the
+# above. If you wish to allow the use of your version of this file
+# only under the terms of the GPL and not to allow others to use
+# your version of this file under the MPL, indicate your decision
+# by deleting the provisions above and replace them with the notice
+# and other provisions required by the GPL. If you do not delete
+# the provisions above, a recipient may use your version of this
+# file under either the MPL or the GPL.
+#
+# --------------------------------------------------------------------
+#
+# Inquiries regarding the linux-wlan Open Source project can be
+# made directly to:
+#
+# AbsoluteValue Systems Inc.
+# info@linux-wlan.com
+# http://www.linux-wlan.com
+#
+# --------------------------------------------------------------------
+#
+# Portions of the development of this software were funded by
+# Intersil Corporation as part of PRISM(R) chipset product development.
+#
+# --------------------------------------------------------------------
+
+-include ../config.mk
+
+all:
+ @echo "Nothing to do..."
+
+install:
+ @echo "Nothing to do..."
+
+clean:
+ rm -f core core.* *.o .*.o *.s *.a .depend tmp_make *~ tags
+ for i in *_obj; do if [ -d $$i ]; then rm -fr $$i; fi; done
+
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/capturefrm.txt.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/capturefrm.txt.svn-base
new file mode 100644
index 0000000..9ea908d
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/capturefrm.txt.svn-base
@@ -0,0 +1,233 @@
+AVS Capture Frame Format
+Version 2.1.1
+
+1. Introduction
+The original header format for "monitor mode" or capturing frames was
+a considerable hack. The document covers a redesign of that format.
+
+ Any questions, corrections, or proposed changes go to info@linux-wlan.com
+
+2. Frame Format
+All sniff frames follow the same format:
+
+ Offset Name Size Description
+ --------------------------------------------------------------------
+ 0 CaptureHeader AVS capture metadata header
+ 64 802.11Header [10-30] 802.11 frame header
+ ?? 802.11Payload [0-2312] 802.11 frame payload
+ ?? 802.11FCS 4 802.11 frame check sequence
+
+Note that the header and payload are variable length and the payload
+may be empty.
+
+If the hardware does not supply the FCS to the driver, then the frame shall
+have a FCS of 0xFFFFFFFF.
+
+3. Byte Order
+All multibyte fields of the capture header are in "network" byte
+order. The "host to network" and "network to host" functions should
+work just fine. All the remaining multibyte fields are ordered
+according to their respective standards.
+
+4. Capture Header Format
+The following fields make up the AVS capture header:
+
+ Offset Name Type
+ ------------------------------
+ 0 version uint32
+ 4 length uint32
+ 8 mactime uint64
+ 16 hosttime uint64
+ 24 phytype uint32
+ 28 frequency uint32
+ 32 datarate uint32
+ 36 antenna uint32
+ 40 priority uint32
+ 44 ssi_type uint32
+ 48 ssi_signal int32
+ 52 ssi_noise int32
+ 56 preamble uint32
+ 60 encoding uint32
+ 64 sequence uint32
+ 68 drops uint32
+ 72 receiver_addr uint8[6]
+ 78 padding uint8[2]
+ ------------------------------
+ 80
+
+The following subsections detail the fields of the capture header.
+
+4.1 version
+The version field identifies this type of frame as a subtype of
+ETH_P_802111_CAPTURE as received by an ARPHRD_IEEE80211_PRISM or
+an ARPHRD_IEEE80211_CAPTURE device. The value of this field shall be
+0x80211002. As new revisions of this header are necessary, we can
+increment the version appropriately.
+
+4.2 length
+The length field contains the length of the entire AVS capture header,
+in bytes.
+
+4.3 mactime
+Many WLAN devices supply a relatively high resolution frame reception
+time value. This field contains the value supplied by the device. If
+the device does not supply a receive time value, this field shall be
+set to zero. The units for this field are microseconds.
+
+If possible, this time value should be absolute, representing the number
+of microseconds elapsed since the UNIX epoch.
+
+4.4 hosttime
+The hosttime field is set to the current value of the host maintained
+clock variable when the frame is received by the host.
+
+If possible, this time value should be absolute, representing the number
+of microseconds elapsed since the UNIX epoch.
+
+4.5 phytype
+The phytype field identifies what type of PHY is employed by the WLAN
+device used to capture this frame. The valid values are:
+
+ PhyType Value
+ -------------------------------------
+ phytype_fhss_dot11_97 1
+ phytype_dsss_dot11_97 2
+ phytype_irbaseband 3
+ phytype_dsss_dot11_b 4
+ phytype_pbcc_dot11_b 5
+ phytype_ofdm_dot11_g 6
+ phytype_pbcc_dot11_g 7
+ phytype_ofdm_dot11_a 8
+ phytype_dss_ofdm_dot11_g 9
+
+4.6 frequency
+
+This represents the frequency or channel number of the receiver at the
+time the frame was received. It is interpreted as follows:
+
+For frequency hopping radios, this field is broken in to the
+following subfields:
+
+ Byte Subfield
+ ------------------------
+ Byte0 Hop Set
+ Byte1 Hop Pattern
+ Byte2 Hop Index
+ Byte3 reserved
+
+For non-hopping radios, the frequency is interpreted as follows:
+
+ Value Meaning
+ -----------------------------------------
+ < 256 Channel number (using externally-defined
+ channelization)
+ < 10000 Center frequency, in MHz
+ >= 10000 Center frequency, in KHz
+
+4.7 datarate
+The data rate field contains the rate at which the frame was received
+in units of 100kbps.
+
+4.8 antenna
+For WLAN devices that indicate the receive antenna for each frame, the
+antenna field shall contain an index value into the dot11AntennaList.
+If the device does not indicate a receive antenna value, this field
+shall be set to zero.
+
+4.9 priority
+The priority field indicates the receive priority of the frame. The
+value is in the range [0-15] with the value 0 reserved to indicate
+contention period and the value 6 reserved to indicate contention free
+period.
+
+4.10 ssi_type
+The ssi_type field is used to indicate what type of signal strength
+information is present: "None", "Normalized RSSI" or "dBm". "None"
+indicates that the underlying WLAN device does not supply any signal
+strength at all and the ssi_* values are unset. "Normalized RSSI"
+values are integers in the range [0-1000] where higher numbers
+indicate stronger signal. "dBm" values indicate an actual signal
+strength measurement quantity and are usually in the range [-108 - 10].
+The following values indicate the three types:
+
+ Value Description
+ ---------------------------------------------
+ 0 None
+ 1 Normalized RSSI
+ 2 dBm
+ 3 Raw RSSI
+
+4.11 ssi_signal
+The ssi_signal field contains the signal strength value reported by
+the WLAN device for this frame. Note that this is a signed quantity
+and if the ssi_type value is "dBm" that the value may be negative.
+
+4.12 ssi_noise
+The ssi_noise field contains the noise or "silence" value reported by
+the WLAN device. This value is commonly defined to be the "signal
+strength reported immediately prior to the baseband processor lock on
+the frame preamble". If the hardware does not provide noise data, this
+shall equal 0xffffffff.
+
+4.12 preamble
+For PHYs that support variable preamble lengths, the preamble field
+indicates the preamble type used for this frame. The values are:
+
+ Value Description
+ ---------------------------------------------
+ 0 Undefined
+ 1 Short Preamble
+ 2 Long Preamble
+
+4.13 encoding
+This specifies the encoding of the received packet. For PHYs that support
+multiple encoding types, this will tell us which one was used.
+
+ Value Description
+ ---------------------------------------------
+ 0 Unknown
+ 1 CCK
+ 2 PBCC
+ 3 OFDM
+ 4 DSSS-OFDM
+ 5 BPSK
+ 6 QPSK
+ 7 16QAM
+ 8 64QAM
+
+4.14 sequence
+This is a receive frame sequence counter. The sniff host shall
+increment this by one for every valid frame received off the medium.
+By watching for gaps in the sequence numbers we can determine when
+packets are lost due to unreliable transport, rather than a frame never
+being received to begin with.
+
+4.15 drops
+This is a counter of the number of known frame drops that occured. This
+is particularly useful when the system or hardware cannot keep up with
+the sniffer load.
+
+4.16 receiver_addr
+This specifies the MAC address of the receiver of this frame.
+It is six octets in length. This field is followed by two octets of
+padding to keep the structure 32-bit word aligned.
+
+================================
+
+Changes: v2->v2.1
+
+ * Added contact e-mail address to introduction
+ * Added sniffer_addr, drop count, and sequence fields, bringing total
+ length to 80 bytes
+ * Bumped version to 0x80211002
+ * Mactime is specified in microseconds, not nanoseconds
+ * Added 64QAM, 16QAM, BPSK, QPSK encodings
+
+================================
+
+Changes: v2.1->v2.1.1
+
+ * Renamed 'channel' to 'frequency'
+ * Clarified the interpretation of the frequency/channel field.
+ * Renamed 'sniffer address' to 'receiver address'
+ * Clarified timestamp fields.
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/config.debug.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/config.debug.svn-base
new file mode 100644
index 0000000..d37c18b
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/config.debug.svn-base
@@ -0,0 +1,90 @@
+* doc/config.debug
+*
+* Copyright (C) 1999 AbsoluteValue Systems, Inc. All Rights Reserved.
+* --------------------------------------------------------------------
+*
+* linux-wlan
+*
+* The contents of this file are subject to the Mozilla Public
+* License Version 1.1 (the "License"); you may not use this file
+* except in compliance with the License. You may obtain a copy of
+* the License at http://www.mozilla.org/MPL/
+*
+* Software distributed under the License is distributed on an "AS
+* IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
+* implied. See the License for the specific language governing
+* rights and limitations under the License.
+*
+* Alternatively, the contents of this file may be used under the
+* terms of the GNU Public License version 2 (the "GPL"), in which
+* case the provisions of the GPL are applicable instead of the
+* above. If you wish to allow the use of your version of this file
+* only under the terms of the GPL and not to allow others to use
+* your version of this file under the MPL, indicate your decision
+* by deleting the provisions above and replace them with the notice
+* and other provisions required by the GPL. If you do not delete
+* the provisions above, a recipient may use your version of this
+* file under either the MPL or the GPL.
+*
+* --------------------------------------------------------------------
+*
+* Inquiries regarding the linux-wlan Open Source project can be
+* made directly to:
+*
+* AbsoluteValue Systems Inc.
+* info@linux-wlan.com
+* http://www.linux-wlan.com
+*
+* --------------------------------------------------------------------
+*
+* Portions of the development of this software were funded by
+* Intersil Corporation as part of PRISM(R) chipset product development.
+*
+* --------------------------------------------------------------------
+
+The kernel components of linux-wlan currently have debugging code
+that can be enabled via a "make config" option. If debug output
+has been compiled into a driver, enable it by setting the value of the
+module parameter xxx_debug
+where xxx is the name of the component. There are five levels of
+debugging (1-5). Here's a summary of the levels and their usage:
+ 1 - Enables most error messages for exception (but rare) conditions
+ 2 - Enables more exceptions
+ 3 - Enables MAC status output
+ 4 - More status
+ 5 - Function entry and exit
+
+The levels are additive. For example, level 3 includes level 3
+messages plus levels 1 and 2.
+
+To configure p80211.o for debug output, put the following line (with
+your own level number) in your modutils configuration file (usually
+/etc/conf.modules or /etc/modules.conf):
+
+ options p80211 wlan_debug=2
+
+To configure the prism2_cs driver for debug output, put the following
+line (with your own level number) in your /etc/pcmcia/config.opts
+file:
+
+ module "prism2_cs" opts "prism2_debug=2"
+
+To configure the PCI, PLX, or USB driver for debug output, put the following
+line (with your own level number) in your modutils configuration file (usually
+/etc/conf.modules or /etc/modules.conf):
+
+ options prism2_pci prism2_debug=3
+ options prism2_plx prism2_debug=3
+ options prism2_usb prism2_debug=3
+
+
+Then configure the collection and display of your kernel output. This
+is usually done using syslog. Here are the relevant entries from the
+/etc/syslog.conf file on one of our test machines:
+
+kern.* /var/log/kernel
+kern.* /dev/tty9
+*.info;mail.none;news.none;authpriv.none /var/log/messages
+*.info;mail.none;news.none;authpriv.none /dev/tty10
+
+
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/config.linux-wlan-ng.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/config.linux-wlan-ng.svn-base
new file mode 100644
index 0000000..c6ec9d8
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/config.linux-wlan-ng.svn-base
@@ -0,0 +1,264 @@
+* doc/config.linux-wlan-ng
+*
+* Copyright (C) 1999 AbsoluteValue Systems, Inc. All Rights Reserved.
+* --------------------------------------------------------------------
+*
+* linux-wlan
+*
+* The contents of this file are subject to the Mozilla Public
+* License Version 1.1 (the "License"); you may not use this file
+* except in compliance with the License. You may obtain a copy of
+* the License at http://www.mozilla.org/MPL/
+*
+* Software distributed under the License is distributed on an "AS
+* IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
+* implied. See the License for the specific language governing
+* rights and limitations under the License.
+*
+* Alternatively, the contents of this file may be used under the
+* terms of the GNU Public License version 2 (the "GPL"), in which
+* case the provisions of the GPL are applicable instead of the
+* above. If you wish to allow the use of your version of this file
+* only under the terms of the GPL and not to allow others to use
+* your version of this file under the MPL, indicate your decision
+* by deleting the provisions above and replace them with the notice
+* and other provisions required by the GPL. If you do not delete
+* the provisions above, a recipient may use your version of this
+* file under either the MPL or the GPL.
+*
+* --------------------------------------------------------------------
+*
+* Inquiries regarding the linux-wlan Open Source project can be
+* made directly to:
+*
+* AbsoluteValue Systems Inc.
+* info@linux-wlan.com
+* http://www.linux-wlan.com
+*
+* --------------------------------------------------------------------
+*
+* Portions of the development of this software were funded by
+* Intersil Corporation as part of PRISM(R) chipset product development.
+*
+* --------------------------------------------------------------------
+
+1. Summary
+
+This document describes a little more of the detail behind configuring the
+linux-wlan system.
+
+2. Installed Componenents
+
+The linux-wlan-ng package consists of the following components:
+
+ p80211.o Kernel module for 802.11 services
+ prism2sta_cs.o Kernel module for the Prism2 PCMCIA device
+ driver.
+ wlanctl-ng User-mode utility for sending commands to
+ 802.11 services and MAC-specific drivers.
+ wland User-mode daemon for receiving and handling
+ events from 802.11 services and MAC-specific
+ drivers (not used in this version).
+ /etc/pcmcia/wlan-ng* PCMCIA event and configuration scripts
+
+ *prism2dl This utility is used for loading firmware
+ images into prism2 cards. DO NOT USE IT!
+ UNLESS YOU KNOW EXACTLY WHAT YOU ARE DOING.
+ This utility has the capability to damage a
+ card in a way that can only be repaired by the
+ manufacturer.
+
+When a 'make install' is performed, the modules are copied to the
+/usr/lib/modules/<kernelver>/net and /usr/lib/modules/pcmcia directory,
+the user-mode utilities are copied to /sbin, and the contents of
+linux-wlan-ng/etc/pcmcia are copied to the /etc/pcmcia directory. If
+necessary, the pcmcia config files are altered to include a reference to
+the wlan-ng.conf file containing the information cardmgr uses to match
+card CIS information to specific device drivers at card insertion time.
+
+NOTE: It is very important that you restart your pcmcia services after
+installing linux-wlan-ng. cardmgr will not recognize the information
+in the wlan-ng.conf file until after it has been restarted.
+
+
+3. Configuration Variables
+
+To configure your installation for use, it will probably be necessary
+to edit the /etc/pcmcia/wlan-ng.opts file. This file contains a
+collection of variable assignments that are used by the wlan-ng script
+to intialize your card at insertion time. The variables are broken
+into groups: ENABLE, DOWNLOAD, USER MIB, WEP, STA, and AP START.
+
+Many of the choices involved in choosing configuration variable
+settings are dependent on whether you are setting up your system as a
+Station (STA) or an Access Point (AP). STA configuration is most
+common. If you are using a mobile station that will connect to one or
+more APs, STA configuration is all you will need.
+
+3.1 ENABLE Group
+The only variable is this group is:
+
+WLAN_ENABLE=y
+ This variable determines whether the card will be intialized,
+ configured for operation, and your protocol stack configured.
+ Generally, you always want this set to 'y'. For some cards,
+ you will set this variable to 'n' when performing card
+ maintenance like firmware upgrades.
+
+3.2 DOWNLOAD Group
+
+The DOWNLOAD group contains variables that indicate if code or data
+needs to be downloaded to the card prior to initialization and normal
+operation. Currently, this is only required for the Prism2 card when
+running in AP mode.
+
+WLAN_DOWNLOAD=n
+ Set this variable to 'y' if code or data must be downloaded
+ into the card prior to operation.
+
+WLAN_DOWNLOADER=/sbin/prism2dl
+ This variable contains the name of the program used to
+ download the code into the card.
+
+WLAN_DLIMAGE=/etc/wlan/apfw.hex
+ This variable contains the name of the file you wish to
+ download.
+
+3.3 USER MIB Group
+
+There is only one variable in this group, USER_MIBS. You may add your
+own local MIB item assignments assignments to this variable. The
+wlan-ng script will loop through the assignments found in this
+variable and configure the card with each one prior to final
+configuration and enable.
+
+3.4 WEP Group
+
+The variables in the WEP group are used to configure the 802.11 "Wired
+Equivalent Privacy" element of the MAC if it is supported. The driver
+is queried for WEP support prior to attempting WEP configuration. If
+the driver states that WEP is NOT supported, these variables are
+ignored. Note that you may need to set some of these variables even if
+you are not using the privacy service. If shared-key authentication
+is used, the WEP keys must be present.
+
+dot11PrivacyInvoked=false
+ Set this variable to "true" to enable the WEP support.
+
+lnxreq_hostWEPEncrypt=false
+lnxreq_hostWEPDecrypt=false
+ Set these to true if you want WEP to be handled by the driver
+ instead of the hardware. The only downside of this is that it
+ takes a bit of CPU time and you lose the ability to handle
+ fragmentation. However, with prism2 cards, you should see a
+ performance boost, and with prism2.5 cards, this may avoid lockups.
+
+dot11WEPDefaultKeyID=1
+ This variable identifies which of the WEP keys is the default
+ key used for all transmits from this station. In some
+ implementations, this can be changed (or rotated) later.
+
+dot11ExcludeUnencrypted=true
+ Setting this variable to "true" and dot11PrivacyInvoked to
+ true, has the effect of making WEP completely required for this
+ station (or AP). If set to "true", this STA will discard any
+ received frames that are not encrypted.
+
+PRIV_GENERATOR=/sbin/nwepgen
+ Some vendors include "WEP Key Generator" programs as part of
+ their windows or AP implementations. This is purely a
+ convenience to prevent you from having to type in 40
+ hexadecimal digits. It does not contribute to the secrity of
+ your system at all. In some cases, we've included small
+ programs that generate keys in a manner compatible with the
+ vendor's method. If you wish to use this capability, include
+ the name of the generator program here.
+
+PRIV_GENSTR="12345"
+ Every generator implementation we've seen so far uses some
+ kind of 'passphrase' to generate the keys. This variable
+ contains the passphrase. To disable the use of a generator,
+ leave this variable empty.
+
+dot11WEPDefaultKey0
+dot11WEPDefaultKey1
+dot11WEPDefaultKey2
+dot11WEPDefaultKey3
+ If you are configuring your keys by hand, you need to assign
+ these four variables. The format is "xx:xx:xx:xx:xx" and the
+ order of the keys in these variables IS IMPORTANT. Note: If
+ the PRIV_GENSTR variable is not empty, these variables are
+ ignored.
+
+3.5 STA Group
+
+Currently, there is only one variable in the STA group. This will
+change over time.
+
+dot11DesiredSSID="WLAN_PRISM2"
+ This variable contains the SSID or "network name" of the
+ wireless network you wish to associate with.
+
+3.6 AP START Group
+
+If you have access to the necessary hardware and firmware, this driver
+can be used to set up a Access Point. To configure for an access
+point, set the IS_AP variable to 'y'. The following is a quick
+summary of the other AP configuration variables:
+
+
+APBRIDGEDEVICE=eth0
+ Defines the ethernet device that will be the 'other' port for
+ bridging 802.11 frames.
+APSSID="WLAN_PRISM2"
+ Defines the SSID that the AP will use when creating the network.
+APBCNINT=100
+ Defines the beacon interval (in Kus) that the AP will use.
+APDTIMINT=3
+ Defines the DTIM interval (in beacon intervals).
+
+APCFPOLLABLE|APCFPOLLREQ | Description
+---------------------------
+ false | false | No point coordination by this AP
+ false | true | AP will point coordinate for delivery only
+ true | false | AP will point coordinate for deliver and polling
+ true | true | Reserved
+
+APCFPPERIOD=3
+ Defines how often the contention free period occurrs (in
+ beacons).
+
+APCFPMAXDURATION=100
+ Defines the maximum length of the contention free period (in
+ Kus).
+
+APPROBEDELAY=100
+ Not used for infrastructure networks, any value is valid.
+
+APCHANNEL=6
+ Channel that the AP will create the network on. Range of valid
+ values depends on you regulatory domain. In the USA and Canada
+ the range is 1-11. In Japan the range is 1-14.
+
+
+APBASICRATES="2 4"
+ A whitespace separated list of data rates in units of 500Kb/s.
+ The basic rate set is the set of rates that stations MUST
+ support to be allowed to join the network.
+
+APOPRATES="2 4 11 22"
+ A whitespace separated list of data rates in units of 500Kb/s.
+ The operational rate set is the set of rates that are allowed
+ in the network. It must be a superset of the basic rates
+ above.
+
+To complete the configuration of an Access Point, you will need to
+make sure you have kernel bridging enable in your currently running
+kernel and have the brcfg utility installed. One version of the brcfg
+utility can be found at ftp://ftp.absoval.com
+
+To start the access point running, make sure the ethernet card is in the
+system first. Then insert the WLAN card and everything should be
+configured automatically by the /etc/pcmcia/wlan-ng script.
+
+
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/releasepolicy.txt.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/releasepolicy.txt.svn-base
new file mode 100644
index 0000000..b66a571
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/releasepolicy.txt.svn-base
@@ -0,0 +1,37 @@
+linux-wlan Release Policy/Checklist
+--------------------------------------------------
+
+[MSM Note: Here's a _quick_ attempt at a release policy for linux-wlan.
+ It's very brief and relatively simple. I'm open to suggestions
+ for improvement.
+]
+
+The following steps should be taken each time a new release of linux-wlan
+is ready for distribution:
+
+0) Make sure the current code builds, loads, associates, and ftps
+ cleanly on all 3 AVS lab build boxes.
+1) Assign an W.X.Y-preZ version number.
+2) Update the version number in config.in.
+3) Tag the files.
+4) Build the tarball. (Bonehead! double check next time that the tarball
+ and config.in version number match, eh?)
+5) Release to ftp.
+6) Announce on linux-wlan-annouce as a feature frozen 'pre' release.
+7) Announce on freshmeat (Pavel? ;-)
+8) Allow at least 24 hours for bug reports and (hopefully) bugfix patches.
+9a) After 24 hour period, if bugfix patches and/or local fixes to bug
+ reports are present, apply patches and GOTO step 0.
+9b) If no show-stopper bug-reports and/or patches are received during the
+ 'pre' release period GOTO step 10.
+10) Make sure the current code builds, loads, associates, and ftps
+ cleanly on all 3 AVS lab build boxes.
+11) Assign an W.X.Y version number.
+12) Update the version number in config.in.
+13) Tag the files.
+14) Build the tarball. (Bonehead! double check next time that the tarball
+ and config.in version number match, eh?)
+15) Release to ftp.
+16) Announce on linux-wlan-annouce as a final W.X.Y release.
+17) Announce on freshmeat.
+
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/rh71notes.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/rh71notes.svn-base
new file mode 100644
index 0000000..399a2e4
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/doc/.svn/text-base/rh71notes.svn-base
@@ -0,0 +1,61 @@
+[MSM]: Here's an old e-mail. I'm not sure if it's in the list archives
+so I figured I'd save it here.
+
+It may be useful for those using RH71.
+
+Date: Wed, 25 Apr 2001 16:03:20 +0800
+From: Leonard Ye <leonardye@yahoo.com>
+Reply-To: linux-wlan-user@absoval.com
+To: linux-wlan-user@absoval.com
+Subject: [lwlan-user]: REDHAT 7.1 + wlan-ng 0.1.18 HOWTO
+
+Hi all,
+
+Just get the wlan-ng 0.1.18pre11 working on my redhat 7.1 and I would like
+to share the experiences with you.
+
+Assumption:
+ a default installation of redhat 7.1 with
+kernel-pcmcia-cs-3.1.24-2.rpm installed
+
+Four steps as followings:
+
+1) Get kernel source ready
+install kernel-source-2.4.2-2 if you don't have the kernel source ready on
+the machine
+copy a suitable configuration file from the configs directory to .config
+make dep
+
+2) Get pcmcia-cs header files ready
+download the pcmcia-cs-3.1.24.tar.gz package
+unzip it at appropriate place
+make config
+ when you were asked what kind of kernel configuration you want to
+use, select "1"
+make all
+DON'T "make install"
+
+3) compile the wlan-ng-0.1.18pre11 code
+download the linux-wlan-ng-0.1.18pre11.tar.gz
+unzip it at appropriate place
+make config
+ select build-in kernel support
+make all
+make install
+
+4) some minor configuration
+edit /etc/pcmcia/config.opts to comment out the card definition for
+"Intersil PRISM2 11 .."
+edit /etc/wlan-ng.opts
+ change string p2RoamingMode to p2CnfRoamingMode
+ set appropriate SSID for variable DesiredSSID
+create an ifcfg-wlan0 file in /etc/sysconfig/network-scripts
+
+Ok, your machine should be able to work as a STA using
+wlan-ng-0.1.18pre11. If you have experience with enabling AP mode, it
+shouldn't be a problem for you enable it in redhat 7.1
+
+Regards,
+Leonard Ye
+
+