summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base')
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/Makefile.svn-base57
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/nwepgen.1.svn-base13
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/prism2dl.1.svn-base93
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wlancfg.1.svn-base54
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wlanctl-ng.1.svn-base27
-rw-r--r--abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wland.1.svn-base23
6 files changed, 267 insertions, 0 deletions
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/Makefile.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/Makefile.svn-base
new file mode 100644
index 0000000..4b68c73
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/Makefile.svn-base
@@ -0,0 +1,57 @@
+# man/Makefile
+#
+# Copyright (C) 1999 AbsoluteValue Systems, Inc. All Rights Reserved.
+# --------------------------------------------------------------------
+#
+# linux-wlan
+#
+# The contents of this file are subject to the Mozilla Public
+# License Version 1.1 (the "License"); you may not use this file
+# except in compliance with the License. You may obtain a copy of
+# the License at http://www.mozilla.org/MPL/
+#
+# Software distributed under the License is distributed on an "AS
+# IS" basis, WITHOUT WARRANTY OF ANY KIND, either express or
+# implied. See the License for the specific language governing
+# rights and limitations under the License.
+#
+# Alternatively, the contents of this file may be used under the
+# terms of the GNU Public License version 2 (the "GPL"), in which
+# case the provisions of the GPL are applicable instead of the
+# above. If you wish to allow the use of your version of this file
+# only under the terms of the GPL and not to allow others to use
+# your version of this file under the MPL, indicate your decision
+# by deleting the provisions above and replace them with the notice
+# and other provisions required by the GPL. If you do not delete
+# the provisions above, a recipient may use your version of this
+# file under either the MPL or the GPL.
+#
+# --------------------------------------------------------------------
+#
+# Inquiries regarding the linux-wlan Open Source project can be
+# made directly to:
+#
+# AbsoluteValue Systems Inc.
+# info@linux-wlan.com
+# http://www.linux-wlan.com
+#
+# --------------------------------------------------------------------
+#
+# Portions of the development of this software were funded by
+# Intersil Corporation as part of PRISM(R) chipset product development.
+#
+# --------------------------------------------------------------------
+
+-include ../config.mk
+
+all:
+ @echo "Nothing to do..."
+
+install:
+ mkdir -p $(TARGET_ROOT_ON_HOST)/usr/local/man/man1
+ cp *.1 $(TARGET_ROOT_ON_HOST)/usr/local/man/man1
+
+clean:
+ rm -f core core.* *.o .*.o *.s *.a .depend tmp_make *~ tags
+ for i in *_obj; do if [ -d $$i ]; then rm -fr $$i; fi; done
+
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/nwepgen.1.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/nwepgen.1.svn-base
new file mode 100644
index 0000000..5c803ed
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/nwepgen.1.svn-base
@@ -0,0 +1,13 @@
+.TH NWEPGEN 8
+.SH NAME
+nwepgen \- generates Neesus Datacom compatible WEP keys
+.SH SYNOPSIS
+.B nwepgen genstr length
+.SH DESCRIPTION
+.B nwepgen
+generates Neesus Datacom compatible WEP keys from a string. You will
+typically not run it by hand, but it is called by the linux-wlan-ng
+initialization scripts if you specify a WEP key string in the config file.
+.P
+.SH AUTHOR
+This minimal man page was written by Joey Hess.
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/prism2dl.1.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/prism2dl.1.svn-base
new file mode 100644
index 0000000..0f4758d
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/prism2dl.1.svn-base
@@ -0,0 +1,93 @@
+.TH PRISM2DL 8
+.SH NAME
+prism2dl \- 802.11 frame dump utility
+.SH SYNOPSIS
+.B prism2dl [OPTIONS] devname
+.SH DESCRIPTION
+.B prism2dl
+User utility for downloading prism2 images
+.SH OPTIONS
+.TP
+.B -s (status)
+Show CIS, PDA from card and exit
+.TP
+.B -v (verbose)
+Show more status info during operation
+.TP
+.B -V (Version)
+Show version and exit
+.TP
+.B -n (nowrite)
+Do all processing, including card PDA read but do not write to card
+.TP
+.B -d (debug)
+Do all processing, excluding card PDA read but do not write to card. A valid
+interface name is _not_ required for this mode.
+.TP
+.B -g (generate)
+Show the PDA in a format readable by this program. Useful for saving the
+existing from a card.
+.SH IMAGEFILE OPTIONS
+.TP
+.B -r <file> (ram)
+Load SREC file to card RAM. This option may be specified multiple times.
+If the value is "stdin", the file will be read from stdin and the option
+may only be specified once.
+.TP
+.B -f <file> (flash)
+Load SREC file to card FLASH. This option may be specified multiple times.
+If the value is "stdin", the file will be read from stdin and the option
+may only be specified once.
+.SH PDA OPTIONS
+.TP
+.B -a <file> (addpdr)
+Add the PDRs from file to the PDA from card. This option may be specified
+multiple times.
+.TP
+.B -p <file> (pda)
+Replace the card PDA with the contents of file.
+.TP
+.B -m <haddr> (macaddr)
+Overwrite the MAC address PDR with the given value.
+<addr> ::= xx:xx:xx:xx:xx:xx, where xx is a two digit hex number.
+.TP
+.B -S <str> (Sernum)
+Overwrite the serial number PDR with the given string. String must be <= 12
+characters, any extra will be truncated.
+.TP
+.B -l <adrr> (padloc)
+PDA location in card memory. Commonly values:
+ HFA3841 ==> 0x003f0000
+ HFA3842 ==> 0x007f0000
+.TP
+.B devname
+Linux device name (e.g. eth0, wlan0)
+.SH EXAMPLES
+Review card status:
+ prism2dl -s wlan0
+
+Load a new PDA:
+ prism2dl -p pdafile.txt wlan0
+ or
+ prism2dl -p pdafile.txt -a pda1.txt -a pda2.txt wlan0
+
+ Note that the f/w images will most likely contain bogus plug info after
+ rewriting the PDA by itself. It is generally recommended to reload the
+ primage and secondary images at the same time as modifying the PDA.
+
+Load a FLASH image _and_ PDA:
+ prism2dl -p pdafile.txt -f CIS.hex -f primary.hex -f secondary.hex wlan0
+
+Load a RAM image:
+ prism2dl -a pda1.txt -r tertiary.hex
+
+Note: PDA records are additive starting with the records from the card
+ OR the records from the -p specified file. -a specified file(s)
+ overwrite, append, or remove records one at a time. If multiple
+ files are specified using the -a option, the files are processed
+ from left to right. This implies that a record removed from the
+ current working PDA may then be added again by a record that
+ appears after the "remove" record in the file set.
+.P
+.SH AUTHOR
+This minimal man page was written by Victor Seva.
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wlancfg.1.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wlancfg.1.svn-base
new file mode 100644
index 0000000..257ccd8
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wlancfg.1.svn-base
@@ -0,0 +1,54 @@
+.TH WLANCFG 8
+.SH NAME
+wlancfg \- manupulate linux-wlan-ng MIB values
+.SH SYNOPSIS
+.B wlancfg query dev
+.P
+.B wlancfg show dev [all]
+.P
+.B wlancfg set dev
+.P
+.B wlancfg list
+.P
+.B wlancfg version
+.SH DESCRIPTION
+The wlancfg utility program provides an alternative method to
+.B wlanctl-ng (1)
+, for manipulating MIB values. It was designed to provide
+an easier mechanism for saving and restoring the complete wireless
+configuration (i.e. when re-starting the device driver) and to provide
+a more efficient mechanism for GUI's to query multiple MIB's.
+.SH OPTIONS
+.TP
+.B dev
+The name of the device (e.g., wlan0).
+.TP
+.B query
+Read MIB names (separated by whitespace) from stdin
+and output their values (separated by carriage returns)
+to stdout. The MIB's may be either read/write or
+read-only.
+.TP
+.B show
+Query the values of all supported read/write MIB's and
+output their values (separated by carriage returns) to
+stdout. The syntax of the output will be:
+ name=value
+.RS
+If the "all" parameter is specified, then all supported
+MIB's (i.e. read-only MIB's as well) are output.
+.RE
+.TP
+.B set
+Read MIB name/value pairs (separated by carriage returns)
+from stdin and set the values of the specified MIB's. The
+pairs must have the same syntax as above. The MIB's must
+be read/write.
+.TP
+.B list
+Display a list of all supported MIB's.
+.TP
+.B version
+Display the compiled version of wlancfg.
+.SH AUTHOR
+This minimal man page was written by Joey Hess.
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wlanctl-ng.1.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wlanctl-ng.1.svn-base
new file mode 100644
index 0000000..4c6186a
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wlanctl-ng.1.svn-base
@@ -0,0 +1,27 @@
+.TH WLANCTL-NG 8
+.SH NAME
+wlanctl-ng \- control utility for linux-wlan-ng 802.11 devices
+.SH SYNOPSIS
+.B wlanctl-ng interface|verson|commands|mibs cmd cmdarg [cmdarg..]
+.SH DESCRIPTION
+The wlanctl-ng utility program is used to set up linux-wlan-ng 802.11
+devices. linux-wlan-ng devices are configured using a MIB.
+.P
+Only experts will want to use this program, as it is quite complicated.
+Everyone else edits a config file and uses a script that runs this program
+as necessary.
+.SH OPTIONS
+.TP
+.B commands
+Output a list of all available commands.
+.TP
+.B mibs
+Outputs a list of available mibs.
+.TP
+.B version
+Outputs the version of the program.
+.TP
+.B interface
+The name of a wireless network interface, such as wlan0.
+.SH AUTHOR
+This minimal man page was written by Joey Hess.
diff --git a/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wland.1.svn-base b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wland.1.svn-base
new file mode 100644
index 0000000..02250e1
--- /dev/null
+++ b/abs/core-testing/wlan-ng26-utils/tmp/trunk/man/.svn/text-base/wland.1.svn-base
@@ -0,0 +1,23 @@
+.TH WLAND 8
+.SH NAME
+wland \- linux-wlan-ng daemon
+.SH SYNOPSIS
+.B wland [-V|-v] [-d wlandpath] [-u]
+.SH DESCRIPTION
+.B wland
+is a daemon for receiving and handling events from 802.11 services and
+MAC-specific linux-wlan-ng drivers. It is not currently used.
+.SH OPTIONS
+.TP
+.B -V
+.TP
+.B -v
+Display version number.
+.TP
+.B -d wlandpath
+Specify the directory to run in.
+.TP
+.B -u
+Do not daemonize; run in foreground.
+.SH AUTHOR
+This minimal man page was written by Joey Hess.