summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/xf86-video-vmware
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/xf86-video-vmware')
-rw-r--r--abs/core-testing/xf86-video-vmware/LICENSE27
-rw-r--r--abs/core-testing/xf86-video-vmware/PKGBUILD28
-rw-r--r--abs/core-testing/xf86-video-vmware/abi2.patch38
3 files changed, 0 insertions, 93 deletions
diff --git a/abs/core-testing/xf86-video-vmware/LICENSE b/abs/core-testing/xf86-video-vmware/LICENSE
deleted file mode 100644
index 7934272..0000000
--- a/abs/core-testing/xf86-video-vmware/LICENSE
+++ /dev/null
@@ -1,27 +0,0 @@
-This package was downloaded from
-http://xorg.freedesktop.org/releases/individual/driver/
-
-Copyright (C) 1994-2003 The XFree86 Project, Inc. All Rights Reserved.
-Copyright (C) 1998-2002 VMware, Inc.
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is fur-
-nished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FIT-
-NESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-XFREE86 PROJECT BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
-IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CON-
-NECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-
-Except as contained in this notice, the name of the XFree86 Project shall not
-be used in advertising or otherwise to promote the sale, use or other deal-
-ings in this Software without prior written authorization from the XFree86
-Project.
diff --git a/abs/core-testing/xf86-video-vmware/PKGBUILD b/abs/core-testing/xf86-video-vmware/PKGBUILD
deleted file mode 100644
index 8c7a752..0000000
--- a/abs/core-testing/xf86-video-vmware/PKGBUILD
+++ /dev/null
@@ -1,28 +0,0 @@
-# $Id: PKGBUILD 75868 2010-04-04 18:42:20Z jgc $
-# Maintainer: Jan de Groot <jgc@archlinux.org>
-
-pkgname=xf86-video-vmware
-pkgver=11.0.1
-pkgrel=1
-pkgdesc="X.org vmware video driver"
-arch=(i686 x86_64)
-url="http://xorg.freedesktop.org/"
-license=('custom')
-depends=('glibc')
-makedepends=('pkgconfig' 'xorg-server>=1.8.0' 'randrproto' 'renderproto' 'xextproto' 'xineramaproto' 'videoproto')
-conflicts=('xorg-server<1.8.0')
-groups=('xorg-video-drivers')
-options=('!libtool')
-source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2
- LICENSE)
-sha1sums=('cc82cbacaa90c28b42440f6a197f5167595c8417'
- 'f7fad008ca63b6862056f9d1123a81aef053d586')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
- install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/" || return 1
-}
diff --git a/abs/core-testing/xf86-video-vmware/abi2.patch b/abs/core-testing/xf86-video-vmware/abi2.patch
deleted file mode 100644
index 29e8dde..0000000
--- a/abs/core-testing/xf86-video-vmware/abi2.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -up xf86-video-vmware-10.16.7/src/vmware.c.jx xf86-video-vmware-10.16.7/src/vmware.c
---- xf86-video-vmware-10.16.7/src/vmware.c.jx 2009-08-07 16:31:33.000000000 -0400
-+++ xf86-video-vmware-10.16.7/src/vmware.c 2009-08-07 16:32:10.000000000 -0400
-@@ -640,8 +640,6 @@ VMWAREPreInit(ScrnInfoPtr pScrn, int fla
- return FALSE;
- }
-
-- xf86LoaderReqSymLists(vgahwSymbols, NULL);
--
- if (!vgaHWGetHWRec(pScrn)) {
- return FALSE;
- }
-@@ -959,7 +957,6 @@ VMWAREPreInit(ScrnInfoPtr pScrn, int fla
- VMWAREFreeRec(pScrn);
- return FALSE;
- }
-- xf86LoaderReqSymLists(fbSymbols, shadowfbSymbols, NULL);
-
- /* Need ramdac for hwcursor */
- if (pVMWARE->hwCursor) {
-@@ -967,7 +964,6 @@ VMWAREPreInit(ScrnInfoPtr pScrn, int fla
- VMWAREFreeRec(pScrn);
- return FALSE;
- }
-- xf86LoaderReqSymLists(ramdacSymbols, NULL);
- }
-
- return TRUE;
-@@ -2051,9 +2047,6 @@ vmwareSetup(pointer module, pointer opts
- setupDone = TRUE;
- xf86AddDriver(&VMWARE, module, VMWARE_DRIVER_FUNC);
-
-- LoaderRefSymLists(vgahwSymbols, fbSymbols, ramdacSymbols,
-- shadowfbSymbols, NULL);
--
- return (pointer)1;
- }
- if (errmaj) {