summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/zlib
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/zlib')
-rw-r--r--abs/core-testing/zlib/PKGBUILD33
-rw-r--r--abs/core-testing/zlib/zlib-1.2.5-lfs-decls.patch13
2 files changed, 0 insertions, 46 deletions
diff --git a/abs/core-testing/zlib/PKGBUILD b/abs/core-testing/zlib/PKGBUILD
deleted file mode 100644
index f320d37..0000000
--- a/abs/core-testing/zlib/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# $Id: PKGBUILD 80715 2010-05-20 20:58:22Z pierre $
-# Maintainer: Pierre Schmitz <pierre@archlinux.de>
-
-pkgname=zlib
-pkgver=1.2.5
-pkgrel=2
-pkgdesc='Compression library implementing the deflate compression method found in gzip and PKZIP'
-arch=('i686' 'x86_64')
-license=('custom')
-url="http://www.zlib.net/"
-depends=('glibc')
-options=('!makeflags')
-source=("http://zlib.net/zlib-${pkgver}.tar.gz"
- 'zlib-1.2.5-lfs-decls.patch')
-md5sums=('c735eab2d659a96e5a594c9e8541ad63'
- '4cb279ea3beab621f3526bf7b7ab99e5')
-
-build() {
- cd ${srcdir}/zlib-$pkgver
- # see http://bugs.archlinux.org/task/19280
- patch -p1 -i ${srcdir}/zlib-1.2.5-lfs-decls.patch || return 1
- export CFLAGS="${CFLAGS/-O2/-O3} -DUNALIGNED_OK"
- ./configure --prefix=/usr
- make || return 1
-
- grep -A 24 '^ Copyright' zlib.h > LICENSE
-}
-
-package() {
- cd ${srcdir}/zlib-$pkgver
- make install DESTDIR=${pkgdir} || return 1
- install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/zlib/LICENSE
-}
diff --git a/abs/core-testing/zlib/zlib-1.2.5-lfs-decls.patch b/abs/core-testing/zlib/zlib-1.2.5-lfs-decls.patch
deleted file mode 100644
index 36e26af..0000000
--- a/abs/core-testing/zlib/zlib-1.2.5-lfs-decls.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: zlib-1.2.5/zlib.h
-===================================================================
---- zlib-1.2.5.orig/zlib.h
-+++ zlib-1.2.5/zlib.h
-@@ -1578,7 +1578,7 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
- # define gzoffset gzoffset64
- # define adler32_combine adler32_combine64
- # define crc32_combine crc32_combine64
--# ifdef _LARGEFILE64_SOURCE
-+# ifndef _LARGEFILE64_SOURCE
- ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
- ZEXTERN z_off_t ZEXPORT gzseek64 OF((gzFile, z_off_t, int));
- ZEXTERN z_off_t ZEXPORT gztell64 OF((gzFile));