summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/acpid/Makefile56
-rw-r--r--abs/core-testing/acpid/PKGBUILD31
-rwxr-xr-xabs/core-testing/acpid/acpi_handler.sh23
-rw-r--r--abs/core-testing/acpid/acpid35
-rw-r--r--abs/core-testing/acpid/acpid-1.0.4-gcc4.patch20
-rw-r--r--abs/core-testing/acpid/anything3
-rw-r--r--abs/core-testing/acpid/default20
-rwxr-xr-xabs/core-testing/acpid/handler.sh69
-rw-r--r--abs/core-testing/eventlog/PKGBUILD20
-rw-r--r--abs/core-testing/evieext/PKGBUILD19
-rw-r--r--abs/core-testing/fftwsingle/PKGBUILD26
-rwxr-xr-xabs/core-testing/iplib/PKGBUILD15
-rw-r--r--abs/core-testing/libxres/PKGBUILD22
-rw-r--r--abs/core-testing/lshw/PKGBUILD26
-rw-r--r--abs/core-testing/lshw/abi_stdlib.diff10
-rw-r--r--abs/core-testing/lshw/gcc4.3.patch282
-rwxr-xr-xabs/core-testing/ntp/PKGBUILD26
-rwxr-xr-xabs/core-testing/ntp/ntp-client.conf8
-rwxr-xr-xabs/core-testing/ntp/ntp.conf48
-rwxr-xr-xabs/core-testing/ntp/ntpd39
-rwxr-xr-xabs/core-testing/ntp/ntpdate30
21 files changed, 828 insertions, 0 deletions
diff --git a/abs/core-testing/acpid/Makefile b/abs/core-testing/acpid/Makefile
new file mode 100644
index 0000000..a5fe385
--- /dev/null
+++ b/abs/core-testing/acpid/Makefile
@@ -0,0 +1,56 @@
+# Makefile for ACPI daemon
+
+# update these numbers for new releases
+VERSION = 1.0.6
+
+INSTPREFIX =
+BINDIR = $(INSTPREFIX)/usr/bin
+SBINDIR = $(INSTPREFIX)/usr/sbin
+MAN8DIR = $(INSTPREFIX)/usr/share/man/man8
+
+SBIN_PROGS = acpid
+BIN_PROGS = acpi_listen
+PROGS = $(SBIN_PROGS) $(BIN_PROGS)
+
+acpid_SRCS = acpid.c event.c ud_socket.c
+acpid_OBJS = $(acpid_SRCS:.c=.o)
+
+acpi_listen_SRCS = acpi_listen.c ud_socket.c
+acpi_listen_OBJS = $(acpi_listen_SRCS:.c=.o)
+
+MAN8 = acpid.8 acpi_listen.8
+MAN8GZ = $(MAN8:.8=.8.gz)
+
+CFLAGS = -Wall -Werror -g $(DEFS) -D_GNU_SOURCE
+DEFS = -DVERSION="\"$(VERSION)\""
+
+all: $(PROGS)
+
+acpid: $(acpid_OBJS)
+
+acpi_listen: $(acpi_listen_OBJS)
+
+man: $(MAN8)
+ for a in $^; do gzip -f -9 -c $$a > $$a.gz; done
+
+install: $(PROGS) man
+ mkdir -p $(SBINDIR)
+ mkdir -p $(BINDIR)
+ install -m 750 acpid $(SBINDIR)
+ install -m 755 acpi_listen $(BINDIR)
+ mkdir -p $(MAN8DIR)
+ install -m 644 $(MAN8GZ) $(MAN8DIR)
+
+DISTTMP=/tmp
+dist:
+ rm -rf $(DISTTMP)/acpid-$(VERSION)
+ mkdir -p $(DISTTMP)/acpid-$(VERSION)
+ cp -a * $(DISTTMP)/acpid-$(VERSION)
+ find $(DISTTMP)/acpid-$(VERSION) -type d -name CVS | xargs rm -rf
+ make -C $(DISTTMP)/acpid-$(VERSION) clean
+ tar -C $(DISTTMP) -zcvf acpid-$(VERSION).tar.gz acpid-$(VERSION)
+ rm -rf $(DISTTMP)/acpid-$(VERSION)
+
+clean:
+ $(RM) $(PROGS) $(MAN8GZ) *.o
+
diff --git a/abs/core-testing/acpid/PKGBUILD b/abs/core-testing/acpid/PKGBUILD
new file mode 100644
index 0000000..f39bbc1
--- /dev/null
+++ b/abs/core-testing/acpid/PKGBUILD
@@ -0,0 +1,31 @@
+
+pkgname=acpid
+pkgver=1.0.6
+pkgrel=3
+arch=('i686')
+pkgdesc="Utilities for using ACPI power management"
+url="http://acpid.sourceforge.net"
+depends=(glibc)
+source=(http://easynews.dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
+ acpid-1.0.4-gcc4.patch
+ acpid
+ anything
+ handler.sh
+ Makefile )
+backup=('etc/acpi/handler.sh' 'etc/acpi/events/anything')
+#options='-D_GNU_SOURCE'
+MAKEFLAGS="-j2"
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ # patch -Np1 -i ${startdir}/src/acpid-1.0.4-gcc4.patch || return 1
+ cp ../Makefile .
+ /usr/bin/make || return 1
+ /bin/install -d -m0755 $startdir/pkg/usr/bin
+ /usr/bin/make INSTPREFIX=$startdir/pkg \
+ MAN8DIR=$startdir/pkg/usr/man/man8 install
+ /bin/install -D -m0755 ../acpid $startdir/pkg/etc/rc.d/acpid
+ /bin/install -d -m0755 $startdir/pkg/etc/acpi/events
+ /bin/install -D -m0644 ../anything $startdir/pkg/etc/acpi/events/anything
+ /bin/install -D -m0755 ../handler.sh $startdir/pkg/etc/acpi/handler.sh
+}
diff --git a/abs/core-testing/acpid/acpi_handler.sh b/abs/core-testing/acpid/acpi_handler.sh
new file mode 100755
index 0000000..65e4ee5
--- /dev/null
+++ b/abs/core-testing/acpid/acpi_handler.sh
@@ -0,0 +1,23 @@
+#!/bin/sh
+# Default acpi script that takes an entry for all actions
+set $*
+EVENT=`echo $1 |cut -d/ -f1`
+ACTION=`echo $1|cut -d/ -f2`
+
+#echo $EVENT
+#echo $ACTION
+case "$EVENT" in
+ button)
+ case "$ACTION" in
+ power)
+ echo Please wait while the system powers off | /usr/local/bin/putfifo /tmp/onscreen &
+ xsay "Please wait while the system powers off" &
+ /sbin/init 0
+ ;;
+ *) logger "ACPI action $2 is not defined"
+ ;;
+ esac
+ ;;
+ *) logger "ACPI group $1 / action $2 is not defined"
+ ;;
+esac
diff --git a/abs/core-testing/acpid/acpid b/abs/core-testing/acpid/acpid
new file mode 100644
index 0000000..585944f
--- /dev/null
+++ b/abs/core-testing/acpid/acpid
@@ -0,0 +1,35 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/acpid`
+case "$1" in
+ start)
+ stat_busy "Starting acpid"
+ [ -z "$PID" ] && /usr/sbin/acpid
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon acpid
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping acpid"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon acpid
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0
diff --git a/abs/core-testing/acpid/acpid-1.0.4-gcc4.patch b/abs/core-testing/acpid/acpid-1.0.4-gcc4.patch
new file mode 100644
index 0000000..b56901d
--- /dev/null
+++ b/abs/core-testing/acpid/acpid-1.0.4-gcc4.patch
@@ -0,0 +1,20 @@
+--- acpid-1.0.4/ud_socket.c 2005-04-26 10:26:29.000000000 +0000
++++ acpid-1.0.4.az/ud_socket.c 2005-04-26 10:27:09.000000000 +0000
+@@ -60,7 +60,7 @@
+ struct sockaddr_un cliaddr;
+ int len = sizeof(struct sockaddr_un);
+
+- newsock = accept(listenfd, (struct sockaddr *)&cliaddr, &len);
++ newsock = accept(listenfd, (struct sockaddr *)&cliaddr, (socklen_t *)&len);
+ if (newsock < 0) {
+ if (errno == EINTR) {
+ continue; /* signal */
+@@ -71,7 +71,7 @@
+
+ if (cred) {
+ len = sizeof(struct ucred);
+- getsockopt(newsock, SOL_SOCKET, SO_PEERCRED,cred,&len);
++ getsockopt(newsock, SOL_SOCKET, SO_PEERCRED,cred,(socklen_t *)&len);
+ }
+
+ return newsock;
diff --git a/abs/core-testing/acpid/anything b/abs/core-testing/acpid/anything
new file mode 100644
index 0000000..d182898
--- /dev/null
+++ b/abs/core-testing/acpid/anything
@@ -0,0 +1,3 @@
+# Pass all events to our one handler script
+event=.*
+action=/etc/acpi/handler.sh %e
diff --git a/abs/core-testing/acpid/default b/abs/core-testing/acpid/default
new file mode 100644
index 0000000..93944aa
--- /dev/null
+++ b/abs/core-testing/acpid/default
@@ -0,0 +1,20 @@
+# This is the ACPID default configuration, it takes all
+# events and passes them to /etc/acpi/default.sh for further
+# processing.
+
+# event keeps a regular expression matching the event. To get
+# power events only, just use something like "event=button power.*"
+# to catch it.
+# action keeps the command to be executed after an event occurs
+#This halts the computer when the Power button is pressed.
+
+event=button power.*
+#action=/sbin/shutdown -h now
+action=/usr/local/sbin/shutdown.sh
+
+# Optionally you can specify the placeholder %e. It will pass
+# through the whole kernel event message to the program you've
+# specified.
+
+event=.*
+action=/etc/acpi/acpi_handler.sh %e
diff --git a/abs/core-testing/acpid/handler.sh b/abs/core-testing/acpid/handler.sh
new file mode 100755
index 0000000..b885f77
--- /dev/null
+++ b/abs/core-testing/acpid/handler.sh
@@ -0,0 +1,69 @@
+#!/bin/sh
+# Default acpi script that takes an entry for all actions
+
+# NOTE: This is a 2.6-centric script. If you use 2.4.x, you'll have to
+# modify it to not use /sys
+
+minspeed=`cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq`
+maxspeed=`cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq`
+setspeed="/sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed"
+
+set $*
+
+case "$1" in
+ button/power)
+ #echo "PowerButton pressed!">/dev/tty5
+ case "$2" in
+ PWRF) logger "PowerButton pressed: $2"
+ xsay "Please wait while the system powers off" &
+ /sbin/halt-runit
+ ;;
+ *) logger "ACPI action undefined: $2" ;;
+ esac
+ ;;
+ button/sleep)
+ case "$2" in
+ SLPB) echo -n mem >/sys/power/state ;;
+ *) logger "ACPI action undefined: $2" ;;
+ esac
+ ;;
+ ac_adapter)
+ case "$2" in
+ AC)
+ case "$4" in
+ 00000000)
+ echo -n $minspeed >$setspeed
+ #/etc/laptop-mode/laptop-mode start
+ ;;
+ 00000001)
+ echo -n $maxspeed >$setspeed
+ #/etc/laptop-mode/laptop-mode stop
+ ;;
+ esac
+ ;;
+ *) logger "ACPI action undefined: $2" ;;
+ esac
+ ;;
+ battery)
+ case "$2" in
+ BAT0)
+ case "$4" in
+ 00000000) #echo "offline" >/dev/tty5
+ ;;
+ 00000001) #echo "online" >/dev/tty5
+ ;;
+ esac
+ ;;
+ CPU0)
+ ;;
+ *) logger "ACPI action undefined: $2" ;;
+ esac
+ ;;
+
+ button/lid)
+ #echo "LID switched!">/dev/tty5
+ ;;
+ *)
+ logger "ACPI group/action undefined: $1 / $2"
+ ;;
+esac
diff --git a/abs/core-testing/eventlog/PKGBUILD b/abs/core-testing/eventlog/PKGBUILD
new file mode 100644
index 0000000..476dbad
--- /dev/null
+++ b/abs/core-testing/eventlog/PKGBUILD
@@ -0,0 +1,20 @@
+
+pkgname=eventlog
+pkgver=0.2.5
+pkgrel=2
+pkgdesc="A new API to format and send structured log messages"
+arch=('i686' 'x86_64')
+url="http://www.balabit.com/support/community/products/"
+license=('BSD')
+depends=('glibc')
+options=('!libtool')
+source=(http://www.balabit.com/downloads/files/eventlog/0.2/eventlog-$pkgver.tar.gz)
+md5sums=('a6bdba91f88540cc69b398fd138d86cd')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+ install -D -m644 COPYING $startdir/pkg/usr/share/licenses/$pkgname/LICENSE
+} \ No newline at end of file
diff --git a/abs/core-testing/evieext/PKGBUILD b/abs/core-testing/evieext/PKGBUILD
new file mode 100644
index 0000000..0f7161a
--- /dev/null
+++ b/abs/core-testing/evieext/PKGBUILD
@@ -0,0 +1,19 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+#Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=evieext
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="X11 Event Interception extension wire protocol"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org/"
+source=(${url}/releases/individual/proto/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('2507b5d0f4b2848147fbddd155aa6cfe')
+sha1sums=('1ab4048ffbfb6b69e88d2f0f2cab7ca60e50cc99')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+}
diff --git a/abs/core-testing/fftwsingle/PKGBUILD b/abs/core-testing/fftwsingle/PKGBUILD
new file mode 100644
index 0000000..c167d3f
--- /dev/null
+++ b/abs/core-testing/fftwsingle/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: ndlarsen <ndlarsen@gmail.com>
+# Comment: Based on PKGBUILDs from the Extra repo for fftw2, maintained by damir <damir@archlinux.org>, and from AUR for fftw2double, maintained by bricem13.
+
+pkgname=fftw2single
+pkgver=2.1.5
+pkgrel=1
+pkgdesc="FFTW is a C subroutine library for computing the discrete Fourier transform (DFT) in one or more dimensions, of both real and complex data, and of arbitrary input size. This is package is offering backwards compatibility version 2.x.y. of fftw."
+arch=('i686')
+license=('GPL')
+url="http://www.fftw.org/"
+depends=('glibc')
+makedepends=('gcc-fortran>=4.1.1')
+source=(http://www.fftw.org/fftw-$pkgver.tar.gz)
+md5sums=('8d16a84f3ca02a785ef9eb36249ba433')
+
+build() {
+
+ cd $startdir/src/fftw-$pkgver
+
+ ./configure F77=gfortran --prefix=/usr \
+ --enable-float --enable-shared \
+ --enable-threads
+ make || return 1
+ make prefix=$startdir/pkg/usr install || return 1
+
+}
diff --git a/abs/core-testing/iplib/PKGBUILD b/abs/core-testing/iplib/PKGBUILD
new file mode 100755
index 0000000..9171293
--- /dev/null
+++ b/abs/core-testing/iplib/PKGBUILD
@@ -0,0 +1,15 @@
+pkgname=python-iplib
+pkgver=1.0
+pkgrel=1
+pkgdesc="IPlib is a Python module useful to convert amongst many different notations and to manage couples of address/netmask in the CIDR notation."
+url="http://www.pymedia.org"
+license=""
+depends=('python')
+makedepends=('python>=2.3')
+source=(http://erlug.linux.it/~da/soft/iplib/iplib-1.0.tar.gz)
+
+ arch=('i686')
+build() {
+ cd $startdir/src/iplib*
+ yes "" | python setup.py install --root=$startdir/pkg --prefix=/usr
+ }
diff --git a/abs/core-testing/libxres/PKGBUILD b/abs/core-testing/libxres/PKGBUILD
new file mode 100644
index 0000000..56dbf49
--- /dev/null
+++ b/abs/core-testing/libxres/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+pkgname=libxres
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="X11 Resource extension library"
+arch=(i686 x86_64)
+url="http://xorg.freedesktop.org"
+depends=('libxext')
+makedepends=('pkgconfig' 'resourceproto' 'damageproto' 'compositeproto' 'scrnsaverproto')
+options=(!libtool)
+source=(${url}/releases/individual/lib/libXres-${pkgver}.tar.bz2)
+
+build() {
+ cd ${startdir}/src/libXres-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --build=${CHOST} --host=${CHOST}
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+}
+md5sums=('de66ffb657aba64c9d6dbdeabb757f3e')
diff --git a/abs/core-testing/lshw/PKGBUILD b/abs/core-testing/lshw/PKGBUILD
new file mode 100644
index 0000000..b2d786b
--- /dev/null
+++ b/abs/core-testing/lshw/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Stefano Zamprogno <stefano dot zamprogno at gmail dot com>
+# Contributor: Chuck Yang <Chuck.Yang@gmail.com>
+
+pkgname=lshw
+pkgver=B.02.13
+pkgrel=1
+pkgdesc="A small tool to provide detailed information on the hardware configuration of the machine."
+url="http://ezix.org/project/wiki/HardwareLiSter"
+license=('GPL')
+source=(http://ezix.org/software/files/lshw-B.02.13.tar.gz abi_stdlib.diff)
+md5sums=('e94c728ed037ca706436b5ef71aa392d' '8696f9e8ecb71bedf374b538e8634d2d')
+arch=('i686' 'x86_64')
+depends=('gtk2')
+makedepends=('gcc')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+
+ patch -Np0 -i ../abi_stdlib.diff || return 1
+
+ make || return 1
+ make gui || return 1
+ make DESTDIR=$startdir/pkg/ install
+ make DESTDIR=$startdir/pkg/ install-gui
+}
+
diff --git a/abs/core-testing/lshw/abi_stdlib.diff b/abs/core-testing/lshw/abi_stdlib.diff
new file mode 100644
index 0000000..8ab61a0
--- /dev/null
+++ b/abs/core-testing/lshw/abi_stdlib.diff
@@ -0,0 +1,10 @@
+--- src/core/abi.cc 2008-05-24 22:30:21.000000000 -0500
++++ src/core/abi.cc 2008-05-24 22:29:28.000000000 -0500
+@@ -9,6 +9,7 @@
+ #include "osutils.h"
+ #include <unistd.h>
+ #include <dirent.h>
++#include <stdlib.h>
+
+ __ID("@(#) $Id: mem.cc 1352 2006-05-27 23:54:13Z ezix $");
+
diff --git a/abs/core-testing/lshw/gcc4.3.patch b/abs/core-testing/lshw/gcc4.3.patch
new file mode 100644
index 0000000..70b1b12
--- /dev/null
+++ b/abs/core-testing/lshw/gcc4.3.patch
@@ -0,0 +1,282 @@
+diff -Naur lshw-B.02.12.01-old/src/core/blockio.cc lshw-B.02.12.01/src/core/blockio.cc
+--- lshw-B.02.12.01-old/src/core/blockio.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/blockio.cc 2008-05-01 14:35:02.000000000 -0600
+@@ -7,6 +7,8 @@
+ #define _LARGEFILE_SOURCE
+ #define _FILE_OFFSET_BITS 64
+
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "blockio.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/cdrom.cc lshw-B.02.12.01/src/core/cdrom.cc
+--- lshw-B.02.12.01-old/src/core/cdrom.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/cdrom.cc 2008-05-01 14:15:33.000000000 -0600
+@@ -15,6 +15,7 @@
+ *
+ */
+
++#include <limits.h>
+ #include "version.h"
+ #include "cdrom.h"
+ #include "partitions.h"
+diff -Naur lshw-B.02.12.01-old/src/core/cpuid.cc lshw-B.02.12.01/src/core/cpuid.cc
+--- lshw-B.02.12.01-old/src/core/cpuid.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/cpuid.cc 2008-05-01 14:11:32.000000000 -0600
+@@ -1,3 +1,5 @@
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "cpuid.h"
+ #include <stdio.h>
+diff -Naur lshw-B.02.12.01-old/src/core/cpuinfo.cc lshw-B.02.12.01/src/core/cpuinfo.cc
+--- lshw-B.02.12.01-old/src/core/cpuinfo.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/cpuinfo.cc 2008-05-01 14:06:49.000000000 -0600
+@@ -1,3 +1,4 @@
++#include <cstdlib>
+ #include "version.h"
+ #include "cpuinfo.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/device-tree.cc lshw-B.02.12.01/src/core/device-tree.cc
+--- lshw-B.02.12.01-old/src/core/device-tree.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/device-tree.cc 2008-05-01 14:05:05.000000000 -0600
+@@ -9,6 +9,8 @@
+ *
+ */
+
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "device-tree.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/fb.cc lshw-B.02.12.01/src/core/fb.cc
+--- lshw-B.02.12.01-old/src/core/fb.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/fb.cc 2008-05-01 14:23:24.000000000 -0600
+@@ -4,6 +4,8 @@
+ *
+ */
+
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "fb.h"
+ #include <sys/types.h>
+diff -Naur lshw-B.02.12.01-old/src/core/hw.cc lshw-B.02.12.01/src/core/hw.cc
+--- lshw-B.02.12.01-old/src/core/hw.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/hw.cc 2008-05-01 13:59:33.000000000 -0600
+@@ -7,10 +7,12 @@
+ #include <vector>
+ #include <map>
+ #include <sstream>
+-#include <unistd.h>
++#include <stdlib.h>
+ #include <stdio.h>
++#include <string.h>
+ #include <ctype.h>
+ #include <unistd.h>
++#include <limits.h>
+ #include <sys/utsname.h>
+
+ using namespace hw;
+diff -Naur lshw-B.02.12.01-old/src/core/ide.cc lshw-B.02.12.01/src/core/ide.cc
+--- lshw-B.02.12.01-old/src/core/ide.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/ide.cc 2008-05-01 14:13:01.000000000 -0600
+@@ -10,6 +10,8 @@
+ * by calling scan_disk() and scan_cdrom(), as appropriate.
+ */
+
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "cpuinfo.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/ideraid.cc lshw-B.02.12.01/src/core/ideraid.cc
+--- lshw-B.02.12.01-old/src/core/ideraid.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/ideraid.cc 2008-05-01 14:44:23.000000000 -0600
+@@ -3,6 +3,8 @@
+ *
+ */
+
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "cpuinfo.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/lvm.cc lshw-B.02.12.01/src/core/lvm.cc
+--- lshw-B.02.12.01-old/src/core/lvm.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/lvm.cc 2008-05-01 14:40:42.000000000 -0600
+@@ -9,6 +9,8 @@
+ *
+ */
+
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "lvm.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/mounts.cc lshw-B.02.12.01/src/core/mounts.cc
+--- lshw-B.02.12.01-old/src/core/mounts.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/mounts.cc 2008-05-01 14:54:07.000000000 -0600
+@@ -4,6 +4,8 @@
+ *
+ */
+
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "mounts.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/osutils.cc lshw-B.02.12.01/src/core/osutils.cc
+--- lshw-B.02.12.01-old/src/core/osutils.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/osutils.cc 2008-05-01 14:08:08.000000000 -0600
+@@ -1,3 +1,4 @@
++#include <cstring>
+ #include "version.h"
+ #include "osutils.h"
+ #include <sstream>
+diff -Naur lshw-B.02.12.01-old/src/core/parisc.cc lshw-B.02.12.01/src/core/parisc.cc
+--- lshw-B.02.12.01-old/src/core/parisc.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/parisc.cc 2008-05-01 14:28:11.000000000 -0600
+@@ -9,6 +9,7 @@
+ *
+ */
+
++#include <cstdlib>
+ #include "version.h"
+ #include "device-tree.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/partitions.cc lshw-B.02.12.01/src/core/partitions.cc
+--- lshw-B.02.12.01-old/src/core/partitions.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/partitions.cc 2008-05-01 14:33:22.000000000 -0600
+@@ -14,6 +14,8 @@
+ #define _LARGEFILE_SOURCE
+ #define _FILE_OFFSET_BITS 64
+
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "partitions.h"
+ #include "blockio.h"
+diff -Naur lshw-B.02.12.01-old/src/core/pci.cc lshw-B.02.12.01/src/core/pci.cc
+--- lshw-B.02.12.01-old/src/core/pci.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/pci.cc 2008-05-01 14:09:46.000000000 -0600
+@@ -1,3 +1,5 @@
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "pci.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/pcmcia.cc lshw-B.02.12.01/src/core/pcmcia.cc
+--- lshw-B.02.12.01-old/src/core/pcmcia.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/pcmcia.cc 2008-05-01 14:45:40.000000000 -0600
+@@ -1,3 +1,4 @@
++#include <cstdlib>
+ #include "version.h"
+ #include "pcmcia.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/pcmcia-legacy.cc lshw-B.02.12.01/src/core/pcmcia-legacy.cc
+--- lshw-B.02.12.01-old/src/core/pcmcia-legacy.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/pcmcia-legacy.cc 2008-05-01 14:17:18.000000000 -0600
+@@ -1,3 +1,5 @@
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "pcmcia-legacy.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/pnp.cc lshw-B.02.12.01/src/core/pnp.cc
+--- lshw-B.02.12.01-old/src/core/pnp.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/pnp.cc 2008-05-01 14:21:45.000000000 -0600
+@@ -6,6 +6,7 @@
+ *
+ *
+ */
++#include <cstdlib>
+ #include "version.h"
+ #include "pnp.h"
+
+diff -Naur lshw-B.02.12.01-old/src/core/print.cc lshw-B.02.12.01/src/core/print.cc
+--- lshw-B.02.12.01-old/src/core/print.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/print.cc 2008-05-01 14:02:00.000000000 -0600
+@@ -7,6 +7,8 @@
+ *
+ */
+
++#include <cstdlib>
++#include <cstring>
+ #include "print.h"
+ #include "options.h"
+ #include "version.h"
+diff -Naur lshw-B.02.12.01-old/src/core/scsi.cc lshw-B.02.12.01/src/core/scsi.cc
+--- lshw-B.02.12.01-old/src/core/scsi.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/scsi.cc 2008-05-01 14:18:40.000000000 -0600
+@@ -1,3 +1,5 @@
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "mem.h"
+ #include "cdrom.h"
+diff -Naur lshw-B.02.12.01-old/src/core/smp.cc lshw-B.02.12.01/src/core/smp.cc
+--- lshw-B.02.12.01-old/src/core/smp.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/smp.cc 2008-05-01 14:56:39.000000000 -0600
+@@ -4,6 +4,7 @@
+ *
+ */
+
++#include <cstring>
+ #include "version.h"
+ #include "smp.h"
+ #include <sys/types.h>
+diff -Naur lshw-B.02.12.01-old/src/core/spd.cc lshw-B.02.12.01/src/core/spd.cc
+--- lshw-B.02.12.01-old/src/core/spd.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/spd.cc 2008-05-01 14:20:10.000000000 -0600
+@@ -1,3 +1,5 @@
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "spd.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/sysfs.cc lshw-B.02.12.01/src/core/sysfs.cc
+--- lshw-B.02.12.01-old/src/core/sysfs.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/sysfs.cc 2008-05-01 14:26:29.000000000 -0600
+@@ -4,6 +4,7 @@
+ *
+ */
+
++#include <cstring>
+ #include "version.h"
+ #include "sysfs.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/usb.cc lshw-B.02.12.01/src/core/usb.cc
+--- lshw-B.02.12.01-old/src/core/usb.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/usb.cc 2008-05-01 14:24:55.000000000 -0600
+@@ -7,6 +7,8 @@
+ #define _GNU_SOURCE
+ #endif
+
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "usb.h"
+ #include "osutils.h"
+diff -Naur lshw-B.02.12.01-old/src/core/volumes.cc lshw-B.02.12.01/src/core/volumes.cc
+--- lshw-B.02.12.01-old/src/core/volumes.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/core/volumes.cc 2008-05-01 14:50:09.000000000 -0600
+@@ -6,6 +6,8 @@
+ #define _LARGEFILE_SOURCE
+ #define _FILE_OFFSET_BITS 64
+
++#include <cstdlib>
++#include <cstring>
+ #include "version.h"
+ #include "volumes.h"
+ #include "blockio.h"
+diff -Naur lshw-B.02.12.01-old/src/lshw.cc lshw-B.02.12.01/src/lshw.cc
+--- lshw-B.02.12.01-old/src/lshw.cc 2008-05-01 13:22:58.000000000 -0600
++++ lshw-B.02.12.01/src/lshw.cc 2008-05-01 14:58:24.000000000 -0600
+@@ -1,3 +1,5 @@
++#include <cstdlib>
++#include <cstring>
+ #include "hw.h"
+ #include "print.h"
+ #include "main.h"
diff --git a/abs/core-testing/ntp/PKGBUILD b/abs/core-testing/ntp/PKGBUILD
new file mode 100755
index 0000000..3b60cdf
--- /dev/null
+++ b/abs/core-testing/ntp/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=ntp
+pkgver=4.2.4p5
+pkgrel=1
+pkgdesc="NTP (Network Time Protocol) tries to keep servers in sync"
+arch=(i686 x86_64)
+url="http://www.ntp.org/"
+depends=('openssl' 'readline' )
+backup=('etc/ntp.conf' 'conf.d/ntp-client.conf')
+source=(http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2.4p5.tar.gz \
+ ntp.conf ntp-client.conf ntpd ntpdate )
+
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make prefix=$startdir/pkg/usr install
+ mkdir -p $startdir/pkg/usr/share/ntp/ $startdir/pkg/usr/man/man1/
+ install -D -m644 conf/* $startdir/pkg/usr/share/ntp/
+ install -D -m755 $startdir/ntpd $startdir/pkg/etc/rc.d/ntpd
+ install -D -m755 $startdir/ntpdate $startdir/pkg/etc/rc.d/ntpdate
+ install -D -m644 $startdir/src/man/* $startdir/pkg/usr/man/man1/
+ install -D -m644 $startdir/ntp-client.conf $startdir/pkg/etc/conf.d/ntp-client.conf
+ install -D -m644 $startdir/ntp.conf $startdir/pkg/etc/ntp.conf
+}
+
diff --git a/abs/core-testing/ntp/ntp-client.conf b/abs/core-testing/ntp/ntp-client.conf
new file mode 100755
index 0000000..4acabee
--- /dev/null
+++ b/abs/core-testing/ntp/ntp-client.conf
@@ -0,0 +1,8 @@
+# change this to a server closer to your location
+#NTP_CLIENT_SERVER="pool.ntp.org"
+NTP_CLIENT_SERVER="ntp1.cs.wisc.edu"
+# client options
+NTP_CLIENT_OPTION="-b -u"
+
+# timeout for the ntp-client
+NTPCLIENT_TIMEOUT=10
diff --git a/abs/core-testing/ntp/ntp.conf b/abs/core-testing/ntp/ntp.conf
new file mode 100755
index 0000000..e2c20e5
--- /dev/null
+++ b/abs/core-testing/ntp/ntp.conf
@@ -0,0 +1,48 @@
+# NOTES:
+# - you should only have to update the server line below
+# - if you start getting lines like 'restrict' and 'fudge'
+# and you didnt add them, AND you run dhcpcd on your
+# network interfaces, be sure to add '-Y -N' to the
+# dhcpcd_ethX variables in /etc/conf.d/net
+
+# Name of the servers ntpd should sync with
+# Please respect the access policy as stated by the responsible person.
+#server ntp.example.tld iburst
+
+#server pool.ntp.org
+server ntp1.cs.wisc.edu
+
+##
+# A list of available servers can be found here:
+# http://www.pool.ntp.org/
+# http://www.pool.ntp.org/#use
+# A good way to get servers for your machine is:
+# netselect -s 3 pool.ntp.org
+##
+
+# you should not need to modify the following paths
+driftfile /var/lib/ntp/ntp.drift
+
+#server ntplocal.example.com prefer
+#server timeserver.example.org
+
+# Warning: Using default NTP settings will leave your NTP
+# server accessible to all hosts on the Internet.
+
+# If you want to deny all machines (including your own)
+# from accessing the NTP server, uncomment:
+#restrict default ignore
+
+
+# To deny other machines from changing the
+# configuration but allow localhost:
+restrict default nomodify nopeer
+restrict 127.0.0.1
+
+
+# To allow machines within your network to synchronize
+# their clocks with your server, but ensure they are
+# not allowed to configure the server or used as peers
+# to synchronize against, uncomment this line.
+#
+restrict 192.168.0.0 mask 255.255.255.0 nomodify nopeer notrap
diff --git a/abs/core-testing/ntp/ntpd b/abs/core-testing/ntp/ntpd
new file mode 100755
index 0000000..bb39123
--- /dev/null
+++ b/abs/core-testing/ntp/ntpd
@@ -0,0 +1,39 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/bin/ntpd`
+case "$1" in
+ start)
+ stat_busy "Starting NTP Daemon"
+ if [ -z "$PID" ]; then
+ /usr/bin/ntpd -g &
+ fi
+ if [ ! -z "$PID" -o $? -gt 0 ]; then
+ stat_fail
+ else
+ PID=`pidof -o %PPID /usr/bin/ntpd`
+ echo $PID > /var/run/ntpd.pid
+ add_daemon ntpd
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping NTP Daemon"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon ntpd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
diff --git a/abs/core-testing/ntp/ntpdate b/abs/core-testing/ntp/ntpdate
new file mode 100755
index 0000000..643ae19
--- /dev/null
+++ b/abs/core-testing/ntp/ntpdate
@@ -0,0 +1,30 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+. /etc/conf.d/ntp-client.conf
+
+case "$1" in
+ start)
+ stat_busy "Starting NTP Client"
+ /usr/bin/ntpdate $NTP_CLIENT_OPTION -t $NTPCLIENT_TIMEOUT $NTP_CLIENT_SERVER > /dev/null 2>&1
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon ntpdate
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping NTP Client"
+ rm_daemon ntpdate
+ stat_done
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac