summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/LinHES-config')
-rw-r--r--abs/core/LinHES-config/PKGBUILD6
-rwxr-xr-xabs/core/LinHES-config/mv_ir.py26
-rwxr-xr-xabs/core/LinHES-config/soundconfig.sh3
3 files changed, 29 insertions, 6 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 1c26f9b..de71e5b 100644
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.3
-pkgrel=61
+pkgrel=64
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
@@ -112,7 +112,7 @@ md5sums=('64fad755c12f8eb12940e216e403354e'
'9ae8d79f620c6d19973c55c32a921874'
'960017a34d9cc78af6298f45aad6eb8e'
'ecf9e5df20683a769c4a8a8f2d65de85'
- 'eaf845dda830c531649d5840e0584f8e'
+ '6d32a88e76b0a97b0ce67d37ef6394aa'
'5a1cbcf58855bbd93a5a18e6673aa2e6'
'6aff504ed5e860adc1b7317cd0780900'
'55fccb1da0417a896b724f7cfc32dd5a'
@@ -125,7 +125,7 @@ md5sums=('64fad755c12f8eb12940e216e403354e'
'5f3259afe031fda189edae41dd1458f0'
'dc150c1e2c915a55a616d1af5bb1f6de'
'b845de3e05c1734cce4b9ac5e8f1baaf'
- '8f58093cc2bbf92c95e54090cf243117'
+ '03d866e4dc287d13734e35f4ebe15edb'
'5e69839659d65ddda35b8a9982dc29e9'
'62b4ce94277c32f525db5c1480670acd'
'ec6a9961e4d1b53ec1240c5979efff11'
diff --git a/abs/core/LinHES-config/mv_ir.py b/abs/core/LinHES-config/mv_ir.py
index 0e54f92..df6feb5 100755
--- a/abs/core/LinHES-config/mv_ir.py
+++ b/abs/core/LinHES-config/mv_ir.py
@@ -44,7 +44,7 @@ def setup_lirc_links(mythhome):
else:
logging.debug(" %s/.lircrc already present",mythhome)
else:
- logging.debug(" /etc/lircrc does not exisit, can not link it")
+ logging.debug(" /etc/lircrc does not exist, can not link it")
def scrub_modules(filename,module):
logging.debug(" scrubbing %s from %s",module,filename)
@@ -92,6 +92,8 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType):
mv_common.runcmd(cmd)
cmd = "mv /etc/lircrc /etc/lircrc-%s" %currenttime
mv_common.runcmd(cmd)
+ cmd = "mv /etc/remote.run /etc/remote.run-%s" %currenttime
+ mv_common.runcmd(cmd)
if os.path.isdir(mythhome+"/remotes/"+Remotetype):
@@ -113,6 +115,15 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType):
logging.debug(" %s is a dir, skipping",filename)
continue
include_file("/etc/lircrc",filename)
+ files = mythhome + "/remotes/" + Remotetype + "/remote.run*"
+ logging.debug(" Using %s",files)
+ for filename in glob.glob(files):
+ # Ignore subfolders
+ if os.path.isdir (filename):
+ logging.debug(" %s is a dir, skipping",filename)
+ continue
+ cmd = "cp %s /etc/remote.run" %filename
+ mv_common.runcmd(cmd)
else:
#template dir
files = templates + "/remotes/" + Remotetype + "/lircd*"
@@ -131,9 +142,18 @@ def setup_ir_remote(Remotetype,templates,mythhome,HostBlasterType):
logging.debug(" %s is a dir, skipping",filename)
continue
include_file("/etc/lircrc",filename)
+ files = templates + "/remotes/" + Remotetype + "/remote.run*"
+ logging.debug(" Using %s",files)
+ for filename in glob.glob(files):
+ # Ignore subfolders
+ if os.path.isdir (filename):
+ logging.debug(" %s is a dir, skipping",filename)
+ continue
+ cmd = "cp %s /etc/remote.run" %filename
+ mv_common.runcmd(cmd)
- cmd = "chmod 755 /etc/lircrc"
+ cmd = "chmod 755 /etc/lircrc /etc/remote.run"
mv_common.runcmd(cmd)
mv_common.add_service("lircd")
@@ -365,4 +385,4 @@ def setup_ir(systemconfig, data_config):
else:
logging.debug(" LCD not defined")
logging.info("__End IR\n")
- return rc \ No newline at end of file
+ return rc
diff --git a/abs/core/LinHES-config/soundconfig.sh b/abs/core/LinHES-config/soundconfig.sh
index 5778cee..c268136 100755
--- a/abs/core/LinHES-config/soundconfig.sh
+++ b/abs/core/LinHES-config/soundconfig.sh
@@ -28,6 +28,9 @@ function load_alsa() {
# echo " installing alsa-lib"
#pacman -Sf --noconfirm alsa-lib
+ echo " uninstalling oss"
+ pacman -R --noconfirm oss
+
echo "triggering udev module load"
depmod -a
cd - > /dev/null