summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/LinHES-system/PKGBUILD')
-rwxr-xr-x[-rw-r--r--]abs/core/LinHES-system/PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 0dcefd7..8219d17 100644..100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,16 +1,16 @@
pkgname=LinHES-system
pkgver=2
-pkgrel=52
+pkgrel=54
arch=('i686' 'x86_64')
MVDIR=$startdir/pkg/usr/LH
BINDIR=$startdir/pkg/usr/bin
#install=LinHES.install
pkgdesc="scripts and things related to having an automated system"
-depends=(linhes-sounds xdotool tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'udisks' 'LinHES-config>=2.3-59' 'sudo')
+depends=(linhes-sounds xdotool tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'udisks' 'LinHES-config>=2.3-59' 'sudo' 'python2-dbus')
backup=(etc/modprobe.d/alsa-base)
binfiles="LinHES-start optimize_mythdb.py
myth_mtc.py myth_mtc.sh LinHES-run
- firstboot.sh load-modules-mythvantage.sh
+ load-modules-mythvantage.sh
unclutter-toggle.sh tvterm.sh
mythfrontend-start set_windowmanager.sh
myth_status.py myth_status.sh
@@ -21,9 +21,11 @@ binfiles="LinHES-start optimize_mythdb.py
lh_system_all_host_update
add_storage.py
diskspace.sh
- cacheclean lh_message.sh switch_web.sh"
+ cacheclean lh_message.sh switch_web.sh
+ create_media_dirs.sh
+ msg_client.py msg_daemon.py"
-source=(LinHES-session LinHES-profile.sh $binfiles alsa-base myth_mtc.lr
+source=(LinHES-session LinHES-profile.sh $binfiles alsa-base myth_mtc.lr
diskspace smolt.cron cacheclean.cron)
build() {
@@ -44,7 +46,7 @@ build() {
item=$i
install -m755 -D $item $MVDIR/bin/$item
echo $item
- done
+ done
install -m644 -D $startdir/src/alsa-base $startdir/pkg/etc/modprobe.d/alsa-base.conf
install -m755 -D $startdir/src/smolt.cron $startdir/pkg/etc/cron.weekly/smolt.cron
@@ -53,14 +55,13 @@ build() {
mkdir $startdir/pkg/etc/logrotate.d
cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
}
-md5sums=('d1a5963c5a440a608031c6d750232633'
+md5sums=('c5bbcfbc2b426158d90e79103a524b7c'
'5881bdb43d578ec3a79d1f77ea58a3db'
'a875ee97f86e46f34a741c2bc455f894'
'76b2637cac0452b3acdbeeb4e8a5474b'
- 'd1f27cb422010077c841376526fe46ea'
+ '781c977f8872543f033dad2caaf0458e'
'2ef9f945e034119f77d9b6beb17e4fa5'
'4b4585ccba30595cf958d202997c57f7'
- 'cbe4cba14fa9d01a62e2196edc1bd98b'
'dc3eef2a624754e16805d72bbe488b67'
'dc0be354ce77ba2b89868fc29b942c43'
'542e670e78d117657f93141e9689f54d'
@@ -75,10 +76,13 @@ md5sums=('d1a5963c5a440a608031c6d750232633'
'859a80ddb4c234506379c605114c1343'
'47e093e8cfe4b5b96602358e1f540832'
'6faeba0aeb38e772121f751cabda8683'
- '68e3e87571f3b0fa4a48a10df50dc220'
- '9603b0ca6e090eff31e76482a3c335e7'
- 'b798ee0796d1b760a2998f90eb8ce9cc'
+ '8fb300778c0d9f03edb92fdd3d9f9158'
+ '6519d209e151cdc39ae7e1091d189c3e'
+ 'd318ea06dacdfe7a474121eac1f75be0'
'4a3cd8f9b33b2b86fdba47a8f1fa2859'
+ '717b80d5069188ccef52001de0df0c21'
+ 'a182af47a7d373b2a63a27e1bb7485b2'
+ '5148fe4c6ac27fff8152c819c4d2b47a'
'eb879fee9603a05d5420d4ce8ed9e450'
'f1870a9522c79e6b248fcbf81dec3280'
'84492954db16740f949d795b74383189'