summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/LinHES-system/PKGBUILD')
-rw-r--r--abs/core/LinHES-system/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
new file mode 100644
index 0000000..2a10fe0
--- /dev/null
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -0,0 +1,42 @@
+pkgname=LinHES-system
+pkgver=1.0
+pkgrel=69
+arch=('i686')
+MVDIR=$startdir/pkg/usr/LH
+BINDIR=$startdir/pkg/usr/bin
+install=LinHES.install
+pkgdesc="scripts and things related to having a automated system"
+depends=(linhes-sounds xdotool)
+backup=(etc/modprobe.d/alsa-base)
+binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh LinHES-run firstboot.sh load-modules-mythvantage.sh unclutter-toggle.sh myth_mtc.lr"
+
+source=(LinHES-session LinHES-profile.sh $binfiles alsa-base)
+
+build() {
+ cd $startdir/src
+ install -m755 -D LinHES-session $startdir/pkg/etc/X11/Sessions/LinHES
+ install -m755 -D LinHES-profile.sh $startdir/pkg/etc/profile.d/LinHES-profile.sh
+####### install to /usr/LH/bin
+#mkdir -p $BINDIR
+
+for i in $binfiles
+do
+ item=$i
+ install -m755 -D $item $MVDIR/bin/$item
+ echo $item
+
+done
+
+cd $startdir/bin
+for i in *
+do
+ item=$i
+ install -m755 -D $item $MVDIR/bin/$item
+ echo $item
+
+done
+install -m755 -D $startdir/src/alsa-base $startdir/pkg/etc/modprobe.d/alsa-base
+mkdir $startdir/pkg/etc/logrotate.d
+cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
+}
+