summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD11
-rw-r--r--abs/core/LinHES-system/myth2mkv8
-rw-r--r--abs/core/LinHES-system/myth_status.py21
3 files changed, 20 insertions, 20 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 5ecc711..c83c19a 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,13 +1,14 @@
pkgname=LinHES-system
-pkgver=8.5.1
+pkgver=8.5.2
pkgrel=2
-arch=('i686' 'x86_64')
+arch=('x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
license=('GPL2')
depends=('linhes-sounds' 'xdotool' 'tilda' 'keylaunch' 'dvdbackup'
'python_aosd' 'udisks' 'LinHES-config>=2.3-59' 'sudo'
- 'python2-dateutil' 'python2-dbus' 'unclutter' 'wmctrl' 'archlinux-xdg-menu'
+ 'python2-dateutil' 'python2-dbus' 'python2-tzlocal' 'unclutter'
+ 'wmctrl' 'archlinux-xdg-menu'
'ethtool' 'gnu-netcat' 'normalize' 'ttf-overlock'
'handbrake-cli' 'mkvtoolnix-cli' 'mplayer' 'runit-scripts>=8.1-12')
backup=('etc/modprobe.d/alsa-base.conf' 'etc/X11/autostart/autostart.run')
@@ -90,7 +91,7 @@ md5sums=('c6e6b83a1f4c35ef4501e277657ab2ac'
'542e670e78d117657f93141e9689f54d'
'8da6a7f1703a002f84e66629e847d8a6'
'bb72ab230c7a71706285bd0f31a4fb1f'
- '7cc012ad0e71b40b4a376ab33a33c1cd'
+ '14352e6d2cd3ed4206b1dff4ff35880d'
'962a3e9eaba2d1466251b7ab0956705d'
'1758aed160de64abfafb28a3a8f3390e'
'33fbebbd546672cedd3c5e7350ab414e'
@@ -132,7 +133,7 @@ md5sums=('c6e6b83a1f4c35ef4501e277657ab2ac'
'a94fe6d980f4b810f2e2ae5352084b39'
'0d1632ea63d8145c173c6aecf0b007f0'
'ff689f2e9572a78d88384b2e5774f579'
- '28f29578e5b3ba84fdf2aa57cf475bcf'
+ 'a811c5c01cc127ef403a24c941e03c66'
'4a1fda884dcd7d65fb2690fbdbd92a83'
'29f451783db3220b612e00c29e3ded73'
'7fe42dfc99af42a45440c9c3954c3c19'
diff --git a/abs/core/LinHES-system/myth2mkv b/abs/core/LinHES-system/myth2mkv
index 1352476..51a0c9b 100644
--- a/abs/core/LinHES-system/myth2mkv
+++ b/abs/core/LinHES-system/myth2mkv
@@ -93,7 +93,7 @@ fi
check_background_progress()
# check handbrake progress in background
{
-while [ `tail -2 ${STATUSFILE} | grep -c "^HandBrake has exited"` = 0 ]
+while [ ! -f ${HB_RETURN_CODE} ]
do
sleep 15
check_myth_jobcmds
@@ -197,19 +197,19 @@ if [[ ${QUALITY} = HP ]] ; then
if [[ -n ${CROP} ]] ; then
CROP="--crop ${CROP}"
else
- CROP="--crop 0:0:0:0 --strict-anamorphic"
+ CROP="--crop 0:0:0:0 --auto-anamorphic"
fi
HB_OPTS="-o ${TMPFILE} -e x264 ${TUNING} -q 20.0 -a 1,1 -E copy:ac3,faac -B 160,160 -6 dpl2,auto -R Auto,Auto -D 0.0,0.0 --audio-copy-mask aac,ac3,dtshd,dts,mp3 --audio-fallback ffac3 -f mkv --decomb --loose-anamorphic --modulus 2 -m --x264-preset medium --h264-profile high --h264-level 4.1 ${CROP} -s 1"
elif [[ ${QUALITY} = HQ ]] ; then
if [[ -n ${CROP} ]] ; then
CROP="--crop ${CROP}"
else
- CROP="--crop 0:0:0:0 --strict-anamorphic"
+ CROP="--crop 0:0:0:0 --auto-anamorphic"
fi
HB_OPTS="-o ${TMPFILE} -f mkv -m -e x264 ${TUNING} -x b-adapt=2:rc-lookahead=50 -b 5000 -2 -T ${WIDTH} ${HEIGHT} -r ${FPS} --cfr ${CROP} ${DEINT} -a 1 -E copy -s 1"
else
if [[ ${CROP} = "--crop 0:0:0:0" ]] ; then
- CROP="${CROP} --strict-anamorphic"
+ CROP="${CROP} --auto-anamorphic"
fi
if [[ ${QUALITY} = LQ ]] ; then
HB_OPTS="-o ${TMPFILE} -f mkv -m -e x264 ${TUNING} -b 1250 ${WIDTH} ${HEIGHT} -r ${FPS} --pfr ${CROP} ${DEINT} -a 1 -E lame -B 128 -Q 8 -6 stereo -s 1"
diff --git a/abs/core/LinHES-system/myth_status.py b/abs/core/LinHES-system/myth_status.py
index 0662f79..cd541ca 100644
--- a/abs/core/LinHES-system/myth_status.py
+++ b/abs/core/LinHES-system/myth_status.py
@@ -3,9 +3,10 @@
#Also will display alerts generated by xymon. If the location of xymon changes, this script needs to be updated.
from MythTV import MythBE,MythDB,MythLog
-import datetime,time,sys,subprocess,re
+import datetime,pytz,re,socket,subprocess,sys,time
from dateutil.parser import parse
-from dateutil import tz
+from tzlocal import get_localzone
+
import os,glob
from socket import gethostname;
@@ -110,7 +111,8 @@ def print_alerts():
class tuner_recording_status:
def __init__ (self,num_upcoming):
- self.now = datetime.datetime.now()
+ self.now = datetime.datetime.now(pytz.utc)
+ self.currTZ = get_localzone()
self.farout=99999999
self.next_start_diff=datetime.timedelta(self.farout)
self.num_upcoming=num_upcoming
@@ -176,7 +178,6 @@ class tuner_recording_status:
a=self.be.getUpcomingRecordings()
r=0
- currTZ = tz.tzlocal()
for i in a:
r += 1
if r > self.num_upcoming:
@@ -184,14 +185,11 @@ class tuner_recording_status:
title_chan="%s (%s)" %(i.title, i.channame)
# convert timezone to local timezone
start_time=parse(str(i.starttime))
- start_time=start_time.astimezone(currTZ)
+ start_time=start_time.astimezone(self.currTZ)
start_time_out=start_time.strftime("%a %b %d %I:%M%p")
self.upcoming_list.append([start_time_out,i.hostname, title_chan])
- #remove timezone
- start_time=re.split("[-+]\d\d:\d\d",str(i.starttime))[0]
- start_time_struct=datetime.datetime.strptime(start_time, "%Y-%m-%d %H:%M:%S")
- diff = start_time_struct - self.now
+ diff = start_time - self.now
if diff < self.next_start_diff :
self.next_start_diff = diff
@@ -230,13 +228,12 @@ class tuner_recording_status:
def conflicts(self):
a=self.be.getConflictedRecordings()
- currTZ = tz.tzlocal()
for i in a:
out_line=''
title_chan="%s (%s)" %(i.title, i.channame)
# convert timezone to local timezone
start_time=parse(str(i.starttime))
- start_time=start_time.astimezone(currTZ)
+ start_time=start_time.astimezone(self.currTZ)
start_time_out=start_time.strftime("%a %b %d %I:%M%p")
out_line=(start_time_out,i.hostname,title_chan)
self.conflict_list.append(out_line)
@@ -258,6 +255,8 @@ class tuner_recording_status:
def go():
+ welcomeFile=open("/etc/LinHES-release", "r")
+ print "Welcome to %s on %s\n" %(welcomeFile.readline().rstrip(), socket.gethostname())
tuner = tuner_recording_status(12)
if tuner.get_db_check_status() == 0:
tuner.print_tuner_status()