summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD8
-rwxr-xr-x[-rw-r--r--]abs/core/LinHES-system/lh_system_backup_job0
-rwxr-xr-x[-rw-r--r--]abs/core/LinHES-system/lh_system_restore_job12
-rw-r--r--abs/core/LinHES-system/myth_status.py7
4 files changed, 15 insertions, 12 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 348996b..a236769 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
-pkgver=8.5.2
-pkgrel=3
+pkgver=8.6.0
+pkgrel=1
arch=('x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -91,7 +91,7 @@ md5sums=('c6e6b83a1f4c35ef4501e277657ab2ac'
'542e670e78d117657f93141e9689f54d'
'8da6a7f1703a002f84e66629e847d8a6'
'bb72ab230c7a71706285bd0f31a4fb1f'
- '14352e6d2cd3ed4206b1dff4ff35880d'
+ 'c25915a9c5382122f849a3a11b943010'
'962a3e9eaba2d1466251b7ab0956705d'
'1758aed160de64abfafb28a3a8f3390e'
'33fbebbd546672cedd3c5e7350ab414e'
@@ -99,7 +99,7 @@ md5sums=('c6e6b83a1f4c35ef4501e277657ab2ac'
'3edef50a49a47694bf8add39cc160add'
'01cbbf411d2a585feb71f2881755e5d8'
'f421f670a9c74724037f70d1dabcad00'
- 'bc69a520add58ede9b060c73e67ace13'
+ 'eab2d188992b1ac561e0ba968544d7a3'
'74e17d6f7453c52d56fecaed5c3f6ad5'
'47e093e8cfe4b5b96602358e1f540832'
'727a886a1ba237906f48cda2e4e7844b'
diff --git a/abs/core/LinHES-system/lh_system_backup_job b/abs/core/LinHES-system/lh_system_backup_job
index 8539ff2..8539ff2 100644..100755
--- a/abs/core/LinHES-system/lh_system_backup_job
+++ b/abs/core/LinHES-system/lh_system_backup_job
diff --git a/abs/core/LinHES-system/lh_system_restore_job b/abs/core/LinHES-system/lh_system_restore_job
index da7dbca..f39aeaa 100644..100755
--- a/abs/core/LinHES-system/lh_system_restore_job
+++ b/abs/core/LinHES-system/lh_system_restore_job
@@ -17,8 +17,9 @@ function usage(){
echo "------------------------------------------------------"
echo "This program will restore the database from a system backup."
- echo "Files are expected to be in the $BACKUPDIR"
- echo "usage:"
+ echo "System backup files are expected to be in the $BACKUPDIR"
+ echo ""
+ echo "Usage:"
echo ""
echo "lh_system_restore_job \$filename [cleanup partial]"
echo ""
@@ -26,9 +27,10 @@ function usage(){
echo ""
echo ""
- echo "If the script is called with cleanup, it will cleanup the the restore dir."
- echo "If the script is called with restore, it will restore the dir, and then copy back some settings."
- echo " It's intended to be used with restoring R7 databases only"
+ echo "If the script is called with cleanup, it will cleanup the restore dir."
+ echo "If the script is called with partial, it will restore the db,"
+ echo " and then copy back some settings."
+ echo " partial is intended to be used to restore R7 databases only."
echo "------------------------------------------------------"
exit 1
diff --git a/abs/core/LinHES-system/myth_status.py b/abs/core/LinHES-system/myth_status.py
index cd541ca..63328d0 100644
--- a/abs/core/LinHES-system/myth_status.py
+++ b/abs/core/LinHES-system/myth_status.py
@@ -144,11 +144,12 @@ class tuner_recording_status:
a=self.be.getRecorderList()
for i in a:
outline=''
- cmd="select cardtype,hostname from capturecard where cardid=%s;" %i
+ cmd="select cardtype,hostname,displayname from capturecard where cardid=%s;" %i
self.cursor.execute(cmd)
results=self.cursor.fetchall()
type = results[0][0]
hostname = results[0][1]
+ displayname = results[0][2]
id = i
try:
c=self.be.getCurrentRecording(i)
@@ -156,10 +157,10 @@ class tuner_recording_status:
current_recording = "Idle"
else:
current_recording = "Recording %s" %c.title
- outline = " Tuner %s (%s) on %s : %s " %(id, type, hostname, current_recording)
+ outline = " Tuner %s - %s (%s) on %s : %s " %(id, displayname, type, hostname, current_recording)
self.tuner_status_list.append(outline)
except:
- outline = " Tuner %s (%s) on %s : %s " %(id, type, hostname, "Tuner Error")
+ outline = " Tuner %s - %s (%s) on %s : %s " %(id, displayname, type, hostname, "Tuner Error")
self.tuner_status_list.append(outline)
def get_tuner_status(self):