summaryrefslogtreecommitdiffstats
path: root/abs/core/aalib
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/aalib')
-rw-r--r--abs/core/aalib/PKGBUILD24
-rw-r--r--abs/core/aalib/aclocal-fixes.patch11
2 files changed, 35 insertions, 0 deletions
diff --git a/abs/core/aalib/PKGBUILD b/abs/core/aalib/PKGBUILD
new file mode 100644
index 0000000..ee23967
--- /dev/null
+++ b/abs/core/aalib/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 2990 2008-06-18 01:46:24Z eric $
+# Maintainer: arjan <arjan@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+#
+pkgname=aalib
+pkgver=1.4rc5
+pkgrel=5
+pkgdesc="AAlib is a portable ASCII art GFX library"
+arch=('i686' 'x86_64')
+url="http://aa-project.sourceforge.net/aalib/"
+license=('LGPL')
+depends=('glibc' 'ncurses' 'gpm>=1.20.4' 'libx11')
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/aa-project/$pkgname-$pkgver.tar.gz
+ aclocal-fixes.patch)
+md5sums=('9801095c42bba12edebd1902bcf0a990' '863a96a6689aa7ee073ca448bc2f133d')
+
+build() {
+ cd $startdir/src/$pkgname-1.4.0
+ patch -Np0 -i ${startdir}/src/aclocal-fixes.patch || return 1
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}
diff --git a/abs/core/aalib/aclocal-fixes.patch b/abs/core/aalib/aclocal-fixes.patch
new file mode 100644
index 0000000..3f1919a
--- /dev/null
+++ b/abs/core/aalib/aclocal-fixes.patch
@@ -0,0 +1,11 @@
+--- aalib.m4.orig 2006-03-05 13:58:21.000000000 +0000
++++ aalib.m4 2006-03-05 13:58:32.000000000 +0000
+@@ -9,7 +9,7 @@
+ dnl AM_PATH_AALIB([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+ dnl Test for AALIB, and define AALIB_CFLAGS and AALIB_LIBS
+ dnl
+-AC_DEFUN(AM_PATH_AALIB,
++AC_DEFUN([AM_PATH_AALIB],
+ [dnl
+ dnl Get the cflags and libraries from the aalib-config script
+ dnl