summaryrefslogtreecommitdiffstats
path: root/abs/core/acpid/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/acpid/PKGBUILD')
-rw-r--r--abs/core/acpid/PKGBUILD38
1 files changed, 16 insertions, 22 deletions
diff --git a/abs/core/acpid/PKGBUILD b/abs/core/acpid/PKGBUILD
index a4d931a..8cd7875 100644
--- a/abs/core/acpid/PKGBUILD
+++ b/abs/core/acpid/PKGBUILD
@@ -1,38 +1,29 @@
-# $Id: PKGBUILD 71877 2012-06-02 17:57:44Z seblu $
-# Maintainer: Sébastien Luttringer <seblu@aur.archlinux.org>
+# $Id: PKGBUILD 97250 2013-09-15 20:35:17Z seblu $
+# Maintainer: Sébastien Luttringer
# Contributor: xduugu
# Contributor: Manolis Tzanidakis
# Contributor: Jonathan Schmidt <j.schmidt@archlinux.us
pkgname=acpid
-pkgver=2.0.16
-pkgrel=3
+pkgver=2.0.20
+pkgrel=1
pkgdesc='A daemon for delivering ACPI power management events with netlink support'
arch=('i686' 'x86_64')
-url='http://tedfelix.com/linux/acpid-netlink.html'
+url='http://sourceforge.net/projects/acpid2/'
license=('GPL')
depends=('bash')
optdepends=('perl: use perl based examples')
replaces=('acpid2')
-backup=('etc/acpi/handler.sh' 'etc/acpi/events/anything' 'etc/conf.d/acpid')
-source=("http://www.tedfelix.com/linux/$pkgname-$pkgver.tar.xz"
- 'acpid.rc'
- 'acpid.conf'
+backup=('etc/acpi/handler.sh' 'etc/acpi/events/anything')
+source=("http://downloads.sourceforge.net/sourceforge/acpid2/$pkgname-$pkgver.tar.xz"
'acpid.socket'
'acpid.service'
'anything'
'handler.sh')
-md5sums=('d59fc02c9c34f0d5c137495302e2c074'
- '077475c75fbdd9de75f9a397130ccd91'
- '929c6d2e91295c22ed9ec6212d7eabef'
- 'ee6cb99e50e580c50331a73045412ae9'
- '7f545754db5be7296d2dd97c049062ee'
- '2d37b98d6e74bab815604b8b48c6cfd4'
- '74ee3c33714ff5cb44f30c9a0dceeef0')
build() {
cd $pkgname-$pkgver
- ./configure --prefix=/usr
+ ./configure --prefix=/usr --sbindir=/usr/bin
make
}
@@ -45,14 +36,17 @@ package() {
install -Dm644 anything "$pkgdir/etc/acpi/events/anything"
install -Dm755 handler.sh "$pkgdir/etc/acpi/handler.sh"
- # initscripts
- install -Dm755 acpid.rc "$pkgdir/etc/rc.d/acpid"
- install -Dm644 acpid.conf "$pkgdir/etc/conf.d/acpid"
+ # systemd
install -Dm644 acpid.socket "$pkgdir/usr/lib/systemd/system/acpid.socket"
install -Dm644 acpid.service "$pkgdir/usr/lib/systemd/system/acpid.service"
# fix acpid rights
- chmod 755 "$pkgdir/usr/sbin/acpid"
+ chmod 755 "$pkgdir/usr/bin/acpid"
}
-# vim:set ts=2 sw=2 ft=sh et:
+# vim:set ts=2 sw=2 et:
+md5sums=('1b740e6419cf45aaeb2bd78d589f27f9'
+ 'd11700eb136e0489835ddaf977a7905b'
+ '79cc7a9dceacdeffd51f070c2ba5f023'
+ '2d37b98d6e74bab815604b8b48c6cfd4'
+ 'e97277eb1937c7ffe92a95fa60c073e4')