summaryrefslogtreecommitdiffstats
path: root/abs/core/apache/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/apache/PKGBUILD')
-rw-r--r--abs/core/apache/PKGBUILD43
1 files changed, 25 insertions, 18 deletions
diff --git a/abs/core/apache/PKGBUILD b/abs/core/apache/PKGBUILD
index d4344e6..13f0aa7 100644
--- a/abs/core/apache/PKGBUILD
+++ b/abs/core/apache/PKGBUILD
@@ -4,10 +4,10 @@
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=apache
-pkgver=2.4.9
+pkgver=2.4.33
pkgrel=1
pkgdesc='A high performance Unix-based HTTP server'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='http://www.apache.org/dist/httpd'
license=('APACHE')
backup=(
@@ -19,30 +19,32 @@ backup=(
etc/httpd/conf/{mime.types,magic}
etc/logrotate.d/httpd
)
-depends=('zlib' 'apr-util' 'pcre')
-makedepends=('libxml2' 'lua' 'openssl')
+depends=('zlib' 'apr-util' 'pcre' 'libnghttp2' 'openssl')
+makedepends=('libxml2' 'lua')
optdepends=(
'lua: for mod_lua module'
- 'openssl: for mod_ssl module'
- 'libxml2: for mod_proxy_html, mod_xml2enc modules'
+ 'libxml2: for mod_proxy_html, mod_xml2enc modules'
'lynx: apachectl status'
)
-install=apache.install
source=(
- http://www.apache.org/dist/httpd/httpd-${pkgver}.tar.bz2{,.asc}
+ https://www.apache.org/dist/httpd/httpd-${pkgver}.tar.bz2{,.asc}
+ openssl-malloc-init.patch
apache.tmpfiles.conf
httpd.logrotate
httpd.service
arch.layout
)
-sha256sums=('f78cc90dfa47caf3d83ad18fd6b4e85f237777c1733fc9088594b70ce2847603'
+sha256sums=('de02511859b00d17845b9abdd1f975d5ccb5d0b280c567da5bf2ad4b70846f05'
'SKIP'
+ 'd305f8b52ac2a9bbda7bb0776496471e69e9d30642740f594d00086a8c7e344c'
'63da1a420f4714a3e7af2672d28384419cc7eedbe7bf35baebd02938fabc15bf'
- '875903831634edf35d8d57e9a51bacb818255ecb3bfff29627f03e43d1ab65c3'
- '14d0a775eea7f8c66ba55399a9ad1e4fd29e0302f479a15b28bbfc754c5aa347'
+ '0bbbfae23a917b2fce0bf8f900f60319b50769224a96314e9301a75ccd078e16'
+ 'f574bac6d5f398e7a649fc0e1ca66ff01ad4ef34dac71258e93d8a9d9a2b3960'
'dda05c6e76f12624e418ca18a36f2e90ec1c5b1cc52fed7142fce6076ec413f3')
+validpgpkeys=('A93D62ECC3C8EA12DB220EC934EA76E6791485A8' # Jim Jagielski
+ 'B9E8213AEFB861AF35A41F2C995E35221AD84DFF') # Daniel Ruggeri
-build() {
+prepare() {
cd httpd-${pkgver}
# set default user
@@ -51,7 +53,14 @@ build() {
-i docs/conf/httpd.conf.in
cat "${srcdir}/arch.layout" >> config.layout
-
+
+ # https://github.com/openssl/openssl/issues/2865
+ patch -Np1 -i ../openssl-malloc-init.patch
+}
+
+build() {
+ cd httpd-${pkgver}
+
./configure --sbindir=/usr/bin \
--enable-layout=Arch \
--enable-mpms-shared=all \
@@ -64,14 +73,14 @@ build() {
--with-suexec-logfile=/var/log/httpd/suexec.log \
--with-suexec-bin=/usr/bin/suexec \
--with-suexec-uidmin=99 --with-suexec-gidmin=99 \
- --enable-ldap --enable-authnz-ldap \
+ --enable-ldap --enable-authnz-ldap --enable-authnz-fcgi \
--enable-cache --enable-disk-cache --enable-mem-cache --enable-file-cache \
--enable-ssl --with-ssl \
--enable-deflate --enable-cgi --enable-cgid \
--enable-proxy --enable-proxy-connect \
--enable-proxy-http --enable-proxy-ftp \
--enable-dbd --enable-imagemap --enable-ident --enable-cern-meta \
- --enable-lua --enable-xml2enc \
+ --enable-lua --enable-xml2enc --enable-http2 \
--with-apr=/usr/bin/apr-1-config \
--with-apr-util=/usr/bin/apu-1-config \
--with-pcre=/usr
@@ -90,10 +99,8 @@ package() {
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# symlinks for /etc/httpd
- # do we really need these symlinks?
- #ln -fs /var/log/httpd "${pkgdir}/etc/httpd/logs"
+ # do we really need this symlink?
ln -fs /usr/lib/httpd/modules "${pkgdir}/etc/httpd/modules"
- #ln -fs /usr/lib/httpd/build "${pkgdir}/etc/httpd/build"
# set sane defaults
sed -e 's#/usr/lib/httpd/modules/#modules/#' \