summaryrefslogtreecommitdiffstats
path: root/abs/core/apr-util/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/apr-util/PKGBUILD')
-rw-r--r--abs/core/apr-util/PKGBUILD49
1 files changed, 38 insertions, 11 deletions
diff --git a/abs/core/apr-util/PKGBUILD b/abs/core/apr-util/PKGBUILD
index 4a8b380..4ce2874 100644
--- a/abs/core/apr-util/PKGBUILD
+++ b/abs/core/apr-util/PKGBUILD
@@ -1,24 +1,51 @@
-# $Id: PKGBUILD 149396 2012-02-07 13:30:38Z jgc $
+# $Id$
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
pkgname=apr-util
-pkgver=1.4.1
-pkgrel=1
+pkgver=1.6.1
+pkgrel=2
pkgdesc="The Apache Portable Runtime"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://apr.apache.org/"
-depends=('apr' 'gdbm' 'expat' 'db' 'libldap' 'unixodbc')
-options=('!libtool')
+depends=('apr' 'expat')
+makedepends=('gdbm' 'libldap' 'unixodbc' 'openssl' 'nss' 'sqlite' 'libmariadbclient' 'db' 'postgresql-libs' 'python2')
+optdepends=(
+ 'gdbm: enable gdbm support'
+ 'libldap: enable ldap support'
+ 'unixodbc: enable odbc support'
+ 'libmariadbclient: enable mysql/mariadb support'
+ 'postgresql-libs: enable postgres support'
+ 'db: enable berkley db support'
+ 'sqlite: enable sqlite support'
+ 'nss: enable nss crypto support'
+ 'openssl: enable openssl crypto support'
+)
license=('APACHE')
-source=("http://www.apache.org/dist/apr/apr-util-${pkgver}.tar.bz2")
-md5sums=('52b31b33fb1aa16e65ddaefc76e41151')
+source=(https://www.apache.org/dist/apr/apr-util-${pkgver}.tar.bz2{,.asc}
+ disable_failing_test.patch # TODO: figure out why dbm test fails
+ buildconf_config.guess_sub_location.patch)
+sha512sums=('40eff8a37c0634f7fdddd6ca5e596b38de15fd10767a34c30bbe49c632816e8f3e1e230678034f578dd5816a94f246fb5dfdf48d644829af13bf28de3225205d'
+ 'SKIP'
+ 'f3de06f845972e5fc85c0d01847bcd0cfbbdd5015798970c73e5ef1b2699c54118f00ba5b939d84bbdf748bd1a5088c1393289b1e62c005fa77878436c165802'
+ 'd19024b8a19e46e85dd03e2c06afae13b527e56c0e2864e5b92652c8ed558f155647f50b9cfaddb6e919b5a60922970b1d9f6c7fc62cd5872b3d22e787f99c65')
+validpgpkeys=('5B5181C2C0AB13E59DA3F7A3EC582EB639FF092C' # Jeff Trawick
+ 'B1B96F45DFBDCCF974019235193F180AB55D9977' # William A. Rowe, Jr. <wrowe@rowe-clan.net>
+ '3CE3BAC2EB7BBC624D1D22D8F3B9D88CB87F79A9') # Nick Kew <niq@apache.org>
+
+prepare() {
+ cd apr-util-$pkgver
+ patch -Np1 -i ../buildconf_config.guess_sub_location.patch
+ patch -Np1 -i ../disable_failing_test.patch
+ ./buildconf --with-apr=`apr-1-config --srcdir`
+}
build() {
cd "${srcdir}/apr-util-${pkgver}"
- ./configure --prefix=/usr --with-apr=/usr \
- --without-pgsql --without-mysql --without-sqlite2 --without-sqlite3 \
- --with-berkeley-db=/usr --with-gdbm=/usr --with-ldap
+ ./configure --prefix=/usr --with-apr=/usr --with-ldap --with-crypto \
+ --with-gdbm=/usr --with-sqlite3=/usr --with-nss=/usr --with-odbc=/usr \
+ --with-berkeley-db=/usr --with-pgsql=/usr --with-mysql=/usr --with-oracle=/usr \
+ --with-openssl=/usr
make
}